aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:32:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-08-08 14:53:54 +0000
commit40991a18a2dd010c381e2056fda2617297425f2a (patch)
treedc8a1c44feb833437faac660fafa8d78187df359
parent0f44ea4143781cff831954dbe9f2d9bca0640af5 (diff)
downloadports-40991a18a2dd010c381e2056fda2617297425f2a.tar.gz
ports-40991a18a2dd010c381e2056fda2617297425f2a.zip
textproc/py-nbsphinx: Add py-nbsphinx 0.8.6
nbsphinx is a Sphinx extension that provides a source parser for *.ipynb files. Custom Sphinx directives are used to show Jupyter Notebook code cells (and of course their results) in both HTML and LaTeX output. Unevaluated notebooks -- i.e. notebooks without stored output cells -- will be automatically executed during the Sphinx build process. WWW: https://github.com/spatialaudio/nbsphinx
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-nbsphinx/Makefile27
-rw-r--r--textproc/py-nbsphinx/distinfo3
-rw-r--r--textproc/py-nbsphinx/pkg-descr7
4 files changed, 38 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fdc7c5a73667..7eedfbdab0e2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1340,6 +1340,7 @@
SUBDIR += py-mkdocs-nature
SUBDIR += py-mwparserfromhell
SUBDIR += py-myst-parser
+ SUBDIR += py-nbsphinx
SUBDIR += py-nltk
SUBDIR += py-normality
SUBDIR += py-numpydoc
diff --git a/textproc/py-nbsphinx/Makefile b/textproc/py-nbsphinx/Makefile
new file mode 100644
index 000000000000..085951fa94a0
--- /dev/null
+++ b/textproc/py-nbsphinx/Makefile
@@ -0,0 +1,27 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= nbsphinx
+PORTVERSION= 0.8.6
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Jupyter Notebook Tools for Sphinx
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}docutils>=0:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbconvert>=0:devel/py-nbconvert@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}nbformat>=0:devel/py-nbformat@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=1.8,1:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=0:devel/py-traitlets@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-nbsphinx/distinfo b/textproc/py-nbsphinx/distinfo
new file mode 100644
index 000000000000..e7e8d36db973
--- /dev/null
+++ b/textproc/py-nbsphinx/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1628103016
+SHA256 (nbsphinx-0.8.6.tar.gz) = 097dee333558f400e9abbb53ce7d4fa64a257cfa89dd20f7554dca7f0cd5e143
+SIZE (nbsphinx-0.8.6.tar.gz) = 146019
diff --git a/textproc/py-nbsphinx/pkg-descr b/textproc/py-nbsphinx/pkg-descr
new file mode 100644
index 000000000000..db71249783a2
--- /dev/null
+++ b/textproc/py-nbsphinx/pkg-descr
@@ -0,0 +1,7 @@
+nbsphinx is a Sphinx extension that provides a source parser for *.ipynb files.
+Custom Sphinx directives are used to show Jupyter Notebook code cells (and of
+course their results) in both HTML and LaTeX output. Unevaluated notebooks --
+i.e. notebooks without stored output cells -- will be automatically executed
+during the Sphinx build process.
+
+WWW: https://github.com/spatialaudio/nbsphinx