aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-03 23:43:03 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-04 00:39:47 +0000
commit420f1411e09e589f6ffe4c78a66a1870fe05db15 (patch)
tree2d6b73f6e4993b366c46b71e23b43148c15ab143
parent3887986f673b9aa45588ab13e18544654ba5218a (diff)
downloadports-420f1411e09e589f6ffe4c78a66a1870fe05db15.tar.gz
ports-420f1411e09e589f6ffe4c78a66a1870fe05db15.zip
math/chuffed: Update 0.10.4 -> 0.10.4.20210104 (devel branch)
-rw-r--r--math/chuffed/Makefile18
-rw-r--r--math/chuffed/distinfo10
-rw-r--r--math/chuffed/files/patch-submodules_cp-profiler-integration_connector.hpp12
-rw-r--r--math/chuffed/pkg-plist57
4 files changed, 54 insertions, 43 deletions
diff --git a/math/chuffed/Makefile b/math/chuffed/Makefile
index 218e4b15bc49..22009192b674 100644
--- a/math/chuffed/Makefile
+++ b/math/chuffed/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chuffed
-DISTVERSION= 0.10.4
+DISTVERSION= 0.10.4.20210104
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -10,21 +10,15 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= bison cmake compiler:c++11-lang
USE_GITHUB= yes
+GH_TAGNAME= e04bedd # devel branch: only devel branch is compatible with the current MiniZinc
-GH_TUPLE= cp-profiler:cpp-integration:d695d93:cpi/submodules/cp-profiler-integration
+GH_TUPLE= cp-profiler:cpp-integration:f16b313:cpi/submodules/cp-profiler-integration
-CXXFLAGS+= -I${BUILD_WRKSRC}/chuffed/flatzinc # workaround for: fatal error: 'parser.tab.h' file not found, see https://github.com/chuffed/chuffed/issues/75
-
-post-patch: # workaround for: unknown symbol YYEMPTY: wrong parser.tab.h is used by the build, see https://github.com/chuffed/chuffed/issues/75
- @${RM} ${WRKSRC}/chuffed/flatzinc/parser.tab.h
+DATADIR= ${PREFIX}/share/minizinc/chuffed
post-install:
- # move the msc file where MiniZinc looks for it, see https://github.com/chuffed/chuffed/issues/74
- cd ${STAGEDIR}${PREFIX} && \
- ${MKDIR} share/minizinc/solvers && \
- ${MV} chuffed.msc share/minizinc/solvers
- # adjust mzn executable and lib paths for MiniZinc to find them
- ${REINPLACE_CMD} -i '' -e 's|bin/|${PREFIX}/&| ; s|share/chuffed/|${PREFIX}/&|' \
+ # correct version in the config file
+ ${REINPLACE_CMD} -i '' -e 's|"version": ".*",|"version": "${PORTVERSION}",|' \
${STAGEDIR}${PREFIX}/share/minizinc/solvers/chuffed.msc
.include <bsd.port.mk>
diff --git a/math/chuffed/distinfo b/math/chuffed/distinfo
index d420e4c6986a..2549d219c91c 100644
--- a/math/chuffed/distinfo
+++ b/math/chuffed/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1620064310
-SHA256 (chuffed-chuffed-0.10.4_GH0.tar.gz) = f7e7028d5a6b0d936f39d33e1e70ff71ccd34e39a5728928699132b213e52fde
-SIZE (chuffed-chuffed-0.10.4_GH0.tar.gz) = 308901
-SHA256 (cp-profiler-cpp-integration-d695d93_GH0.tar.gz) = ff556f0fcbdf4e438226c070bdf41e04b584bd193501b8882c6a1de8d4756ea9
-SIZE (cp-profiler-cpp-integration-d695d93_GH0.tar.gz) = 403484
+TIMESTAMP = 1620084173
+SHA256 (chuffed-chuffed-0.10.4.20210104-e04bedd_GH0.tar.gz) = 42dc36cf0d7a408ccbced3c7c0b1a492898588401ddab435ff2f30580f0293aa
+SIZE (chuffed-chuffed-0.10.4.20210104-e04bedd_GH0.tar.gz) = 321590
+SHA256 (cp-profiler-cpp-integration-f16b313_GH0.tar.gz) = 871b081fbc4ee76077eccd388ff1c6063e0376f365eba2cb9d8ce0ab9a617275
+SIZE (cp-profiler-cpp-integration-f16b313_GH0.tar.gz) = 5214
diff --git a/math/chuffed/files/patch-submodules_cp-profiler-integration_connector.hpp b/math/chuffed/files/patch-submodules_cp-profiler-integration_connector.hpp
new file mode 100644
index 000000000000..fafaeb4e8a12
--- /dev/null
+++ b/math/chuffed/files/patch-submodules_cp-profiler-integration_connector.hpp
@@ -0,0 +1,12 @@
+- https://github.com/cp-profiler/cpp-integration/issues/1
+
+--- submodules/cp-profiler-integration/connector.hpp.orig 2021-05-03 23:30:50 UTC
++++ submodules/cp-profiler-integration/connector.hpp
+@@ -7,6 +7,7 @@
+ #include <sstream>
+ #include <vector>
+ #include <cstring>
++#include <sys/socket.h>
+
+ #ifdef WIN32
+
diff --git a/math/chuffed/pkg-plist b/math/chuffed/pkg-plist
index 41b89998f06f..5a2a2085ba9c 100644
--- a/math/chuffed/pkg-plist
+++ b/math/chuffed/pkg-plist
@@ -1,28 +1,33 @@
bin/fzn-chuffed
-%%DATADIR%%/mznlib/all_different_int.mzn
-%%DATADIR%%/mznlib/arg_max_bool.mzn
-%%DATADIR%%/mznlib/at_least_int.mzn
-%%DATADIR%%/mznlib/at_most_int.mzn
-%%DATADIR%%/mznlib/chuffed.mzn
-%%DATADIR%%/mznlib/circuit.mzn
-%%DATADIR%%/mznlib/cost_regular.mzn
-%%DATADIR%%/mznlib/count.mzn
-%%DATADIR%%/mznlib/cumulative.mzn
-%%DATADIR%%/mznlib/disjunctive.mzn
-%%DATADIR%%/mznlib/disjunctive_strict.mzn
-%%DATADIR%%/mznlib/distribute.mzn
-%%DATADIR%%/mznlib/exactly_int.mzn
-%%DATADIR%%/mznlib/global_cardinality_low_up.mzn
-%%DATADIR%%/mznlib/inverse.mzn
-%%DATADIR%%/mznlib/maximum_int.mzn
-%%DATADIR%%/mznlib/minimum_int.mzn
-%%DATADIR%%/mznlib/nvalue.mzn
-%%DATADIR%%/mznlib/redefinitions.mzn
-%%DATADIR%%/mznlib/regular.mzn
-%%DATADIR%%/mznlib/subcircuit.mzn
-%%DATADIR%%/mznlib/table_int.mzn
-%%DATADIR%%/mznlib/values_interchange.mzn
-%%DATADIR%%/mznlib/values_sequences.mzn
-%%DATADIR%%/mznlib/variables_interchange.mzn
-%%DATADIR%%/mznlib/variables_sequences.mzn
+%%DATADIR%%/chuffed.mzn
+%%DATADIR%%/edit_distance.mzn
+%%DATADIR%%/fzn_all_different_int.mzn
+%%DATADIR%%/fzn_arg_max_bool.mzn
+%%DATADIR%%/fzn_circuit.mzn
+%%DATADIR%%/fzn_cost_regular.mzn
+%%DATADIR%%/fzn_count_eq.mzn
+%%DATADIR%%/fzn_count_eq_par.mzn
+%%DATADIR%%/fzn_count_geq.mzn
+%%DATADIR%%/fzn_count_geq_par.mzn
+%%DATADIR%%/fzn_count_gt.mzn
+%%DATADIR%%/fzn_count_gt_par.mzn
+%%DATADIR%%/fzn_count_leq.mzn
+%%DATADIR%%/fzn_count_leq_par.mzn
+%%DATADIR%%/fzn_count_lt.mzn
+%%DATADIR%%/fzn_count_lt_par.mzn
+%%DATADIR%%/fzn_cumulative.mzn
+%%DATADIR%%/fzn_disjunctive.mzn
+%%DATADIR%%/fzn_disjunctive_strict.mzn
+%%DATADIR%%/fzn_distribute.mzn
+%%DATADIR%%/fzn_global_cardinality_low_up.mzn
+%%DATADIR%%/fzn_inverse.mzn
+%%DATADIR%%/fzn_nvalue.mzn
+%%DATADIR%%/fzn_regular.mzn
+%%DATADIR%%/fzn_subcircuit.mzn
+%%DATADIR%%/fzn_table_int.mzn
+%%DATADIR%%/redefinitions.mzn
+%%DATADIR%%/values_interchange.mzn
+%%DATADIR%%/values_sequences.mzn
+%%DATADIR%%/variables_interchange.mzn
+%%DATADIR%%/variables_sequences.mzn
share/minizinc/solvers/chuffed.msc