aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 14:13:20 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:06:08 +0000
commit51e1402c8475f5b12707b4138ef10330f05c8614 (patch)
tree603730f5d0af0fb4c7ac76427d1b852cb904c79a
parentfa39b281adb9ca0fdce94b03f783f44ef296cdd9 (diff)
downloadports-51e1402c8475f5b12707b4138ef10330f05c8614.tar.gz
ports-51e1402c8475f5b12707b4138ef10330f05c8614.zip
net-im/py-slackeventsapi: Add py-slackeventsapi 3.0.1
The Slack Events Adapter is a Python-based solution to receive and parse events from Slack's Events API. This library uses an event emitter framework to allow you to easily process Slack events by simply attaching functions to event listeners. This adapter enhances and simplifies Slack's Events API by incorporating useful best practices, patterns, and opportunities to abstract out common tasks.
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-slackeventsapi/Makefile22
-rw-r--r--net-im/py-slackeventsapi/distinfo3
-rw-r--r--net-im/py-slackeventsapi/files/patch-setup.py11
-rw-r--r--net-im/py-slackeventsapi/pkg-descr7
5 files changed, 44 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 8db413a7f55e..3e6764b4a2cf 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -116,6 +116,7 @@
SUBDIR += py-punjab
SUBDIR += py-python-telegram-bot
SUBDIR += py-slack-sdk
+ SUBDIR += py-slackeventsapi
SUBDIR += py-slixmpp
SUBDIR += py-telepot
SUBDIR += py-toxcore-c
diff --git a/net-im/py-slackeventsapi/Makefile b/net-im/py-slackeventsapi/Makefile
new file mode 100644
index 000000000000..e61b39812fd5
--- /dev/null
+++ b/net-im/py-slackeventsapi/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= slackeventsapi
+PORTVERSION= 3.0.1
+CATEGORIES= net-im python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Slack Events API adapter for Flask
+WWW= https://github.com/slackapi/python-slack-events-api
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}flask>=2:www/py-flask@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyee>=8:devel/py-pyee@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-im/py-slackeventsapi/distinfo b/net-im/py-slackeventsapi/distinfo
new file mode 100644
index 000000000000..b4287810154c
--- /dev/null
+++ b/net-im/py-slackeventsapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1708448844
+SHA256 (slackeventsapi-3.0.1.tar.gz) = 24f8e843a60118b08368161105bae8a998801202f85782239d48f8635e2ead58
+SIZE (slackeventsapi-3.0.1.tar.gz) = 7309
diff --git a/net-im/py-slackeventsapi/files/patch-setup.py b/net-im/py-slackeventsapi/files/patch-setup.py
new file mode 100644
index 000000000000..0c965be1a65a
--- /dev/null
+++ b/net-im/py-slackeventsapi/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-11-30 08:16:52 UTC
++++ setup.py
+@@ -34,7 +34,7 @@ setup(name='slackeventsapi',
+ long_description_content_type='text/x-rst',
+ long_description=long_description,
+ install_requires=[
+- 'flask>=2,<3',
++ 'flask>=2',
+ 'pyee>=8',
+ ],
+ classifiers=[
diff --git a/net-im/py-slackeventsapi/pkg-descr b/net-im/py-slackeventsapi/pkg-descr
new file mode 100644
index 000000000000..5120bc58d989
--- /dev/null
+++ b/net-im/py-slackeventsapi/pkg-descr
@@ -0,0 +1,7 @@
+The Slack Events Adapter is a Python-based solution to receive and parse events
+from Slack's Events API. This library uses an event emitter framework to allow
+you to easily process Slack events by simply attaching functions to event
+listeners.
+
+This adapter enhances and simplifies Slack's Events API by incorporating useful
+best practices, patterns, and opportunities to abstract out common tasks.