aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:04 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:04 +0000
commit593c9916f8d3ac20dc11e2cc82571c7f30e98dfa (patch)
treeb0cf1a2986d5deb355271e2f28105cf5413fedf2
parent5ebdd1f6c32e5f6b10eb4eb034de286a26a48727 (diff)
downloadports-593c9916f8d3ac20dc11e2cc82571c7f30e98dfa.tar.gz
ports-593c9916f8d3ac20dc11e2cc82571c7f30e98dfa.zip
devel/rubygem-google-apis-pubsub_v1: Add rubygem-google-apis-pubsub_v1 0.8.0
This is a simple client library for version V1 of the Cloud Pub/Sub API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts. WWW: https://github.com/googleapis/google-api-ruby-client WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-pubsub_v1
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-pubsub_v1/Makefile21
-rw-r--r--devel/rubygem-google-apis-pubsub_v1/distinfo3
-rw-r--r--devel/rubygem-google-apis-pubsub_v1/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6eaa47d0fcfe..9a12486acec5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6342,6 +6342,7 @@
SUBDIR += rubygem-google-apis-generator
SUBDIR += rubygem-google-apis-iamcredentials_v1
SUBDIR += rubygem-google-apis-monitoring_v3
+ SUBDIR += rubygem-google-apis-pubsub_v1
SUBDIR += rubygem-google-apis-storage_v1
SUBDIR += rubygem-google-gax
SUBDIR += rubygem-google-protobuf
diff --git a/devel/rubygem-google-apis-pubsub_v1/Makefile b/devel/rubygem-google-apis-pubsub_v1/Makefile
new file mode 100644
index 000000000000..fc5c15bc357e
--- /dev/null
+++ b/devel/rubygem-google-apis-pubsub_v1/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-apis-pubsub_v1
+PORTVERSION= 0.8.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Cloud Pub/Sub API V1
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.4<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-pubsub_v1/distinfo b/devel/rubygem-google-apis-pubsub_v1/distinfo
new file mode 100644
index 000000000000..c87678d5ec5b
--- /dev/null
+++ b/devel/rubygem-google-apis-pubsub_v1/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773612
+SHA256 (rubygem/google-apis-pubsub_v1-0.8.0.gem) = 9d019534a6be50aa26429e40bf6a8cc91bba2e92cd7df8c514bd8e072926fcee
+SIZE (rubygem/google-apis-pubsub_v1-0.8.0.gem) = 33280
diff --git a/devel/rubygem-google-apis-pubsub_v1/pkg-descr b/devel/rubygem-google-apis-pubsub_v1/pkg-descr
new file mode 100644
index 000000000000..915bdd3da2b0
--- /dev/null
+++ b/devel/rubygem-google-apis-pubsub_v1/pkg-descr
@@ -0,0 +1,10 @@
+This is a simple client library for version V1 of the Cloud Pub/Sub API. It
+provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.
+
+WWW: https://github.com/googleapis/google-api-ruby-client
+WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-pubsub_v1