aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:02 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:02 +0000
commit5ebdd1f6c32e5f6b10eb4eb034de286a26a48727 (patch)
treebbe89dcd875ef796991505fb8490638d6ef6cff9
parent3468aa764fcc0e130851f5b04c29deb164d84d35 (diff)
downloadports-5ebdd1f6c32e5f6b10eb4eb034de286a26a48727.tar.gz
ports-5ebdd1f6c32e5f6b10eb4eb034de286a26a48727.zip
devel/rubygem-google-apis-monitoring_v3: Add rubygem-google-apis-monitoring_v3 0.14.0
This is a simple client library for version V3 of the Cloud Monitoring API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts. WWW: https://github.com/google/google-api-ruby-client WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-monitoring_v3
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-monitoring_v3/Makefile21
-rw-r--r--devel/rubygem-google-apis-monitoring_v3/distinfo3
-rw-r--r--devel/rubygem-google-apis-monitoring_v3/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index dccaacfbb27f..6eaa47d0fcfe 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6341,6 +6341,7 @@
SUBDIR += rubygem-google-apis-discovery_v1
SUBDIR += rubygem-google-apis-generator
SUBDIR += rubygem-google-apis-iamcredentials_v1
+ SUBDIR += rubygem-google-apis-monitoring_v3
SUBDIR += rubygem-google-apis-storage_v1
SUBDIR += rubygem-google-gax
SUBDIR += rubygem-google-protobuf
diff --git a/devel/rubygem-google-apis-monitoring_v3/Makefile b/devel/rubygem-google-apis-monitoring_v3/Makefile
new file mode 100644
index 000000000000..76bee916816d
--- /dev/null
+++ b/devel/rubygem-google-apis-monitoring_v3/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-apis-monitoring_v3
+PORTVERSION= 0.14.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Cloud Monitoring API V3
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.4<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-monitoring_v3/distinfo b/devel/rubygem-google-apis-monitoring_v3/distinfo
new file mode 100644
index 000000000000..ef4c663bc811
--- /dev/null
+++ b/devel/rubygem-google-apis-monitoring_v3/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773610
+SHA256 (rubygem/google-apis-monitoring_v3-0.14.0.gem) = f25f7dc9fa5bad681bb82dd814ff83e75b4b51fccd29c88acaa010086f28f88f
+SIZE (rubygem/google-apis-monitoring_v3-0.14.0.gem) = 69120
diff --git a/devel/rubygem-google-apis-monitoring_v3/pkg-descr b/devel/rubygem-google-apis-monitoring_v3/pkg-descr
new file mode 100644
index 000000000000..d2c58540d628
--- /dev/null
+++ b/devel/rubygem-google-apis-monitoring_v3/pkg-descr
@@ -0,0 +1,10 @@
+This is a simple client library for version V3 of the Cloud Monitoring API. It
+provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.
+
+WWW: https://github.com/google/google-api-ruby-client
+WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-monitoring_v3