aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-07-27 12:47:48 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-08-06 13:32:09 +0000
commit5a493165ba00d2dc26900c689f9e1bd175081d81 (patch)
tree42bf323d2463527534472058a4a2308229e68ff7
parent0b34ae623a58b1975b3e2f009f95239e3e950695 (diff)
downloadports-5a493165ba00d2dc26900c689f9e1bd175081d81.tar.gz
ports-5a493165ba00d2dc26900c689f9e1bd175081d81.zip
lang/intel-compute-runtime: update to 21.31.20514
-rw-r--r--lang/intel-compute-runtime/Makefile2
-rw-r--r--lang/intel-compute-runtime/distinfo6
-rw-r--r--lang/intel-compute-runtime/files/patch-no-rebar80
3 files changed, 84 insertions, 4 deletions
diff --git a/lang/intel-compute-runtime/Makefile b/lang/intel-compute-runtime/Makefile
index 8ef72b7ad0df..a1d91f8952a3 100644
--- a/lang/intel-compute-runtime/Makefile
+++ b/lang/intel-compute-runtime/Makefile
@@ -1,5 +1,5 @@
PORTNAME= compute-runtime
-DISTVERSION= 21.30.20482
+DISTVERSION= 21.31.20514
CATEGORIES= lang
PKGNAMEPREFIX= intel-
diff --git a/lang/intel-compute-runtime/distinfo b/lang/intel-compute-runtime/distinfo
index a830df3bff32..984779264915 100644
--- a/lang/intel-compute-runtime/distinfo
+++ b/lang/intel-compute-runtime/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1626975336
-SHA256 (intel-compute-runtime-21.30.20482_GH0.tar.gz) = 978e8d8471e658beca650890ec0d3160a2aac958a3c865ce4b61d334c73b2fb1
-SIZE (intel-compute-runtime-21.30.20482_GH0.tar.gz) = 4416357
+TIMESTAMP = 1627390068
+SHA256 (intel-compute-runtime-21.31.20514_GH0.tar.gz) = 338f4a0c1be72fb41e591cdee3924f1d126418d7d5aff3b2255a706f68fa8b90
+SIZE (intel-compute-runtime-21.31.20514_GH0.tar.gz) = 4434425
SHA256 (4a926516c3ea.patch) = 1a9c4694dbe892f01a7d3be5c5229b6b3bb34222848d61054f7bdf91134ca60f
SIZE (4a926516c3ea.patch) = 1691
diff --git a/lang/intel-compute-runtime/files/patch-no-rebar b/lang/intel-compute-runtime/files/patch-no-rebar
new file mode 100644
index 000000000000..16b5ece68112
--- /dev/null
+++ b/lang/intel-compute-runtime/files/patch-no-rebar
@@ -0,0 +1,80 @@
+Limit resizable BAR to Linux as NEO doesn't use libpci.
+
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:15:10: fatal error: 'linux/pci_regs.h' file not found
+#include <linux/pci_regs.h>
+ ^~~~~~~~~~~~~~~~~~
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:157:20: error: use of undeclared identifier 'PCI_CFG_SPACE_SIZE'
+ uint32_t pos = PCI_CFG_SPACE_SIZE;
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:167:23: error: use of undeclared identifier 'PCI_CFG_SPACE_EXP_SIZE'
+ auto loopCount = (PCI_CFG_SPACE_EXP_SIZE - PCI_CFG_SPACE_SIZE) / 8;
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:167:48: error: use of undeclared identifier 'PCI_CFG_SPACE_SIZE'
+ auto loopCount = (PCI_CFG_SPACE_EXP_SIZE - PCI_CFG_SPACE_SIZE) / 8;
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:174:13: error: use of undeclared identifier 'PCI_EXT_CAP_ID'
+ if (PCI_EXT_CAP_ID(header) == PCI_EXT_CAP_ID_REBAR) {
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:174:39: error: use of undeclared identifier 'PCI_EXT_CAP_ID_REBAR'
+ if (PCI_EXT_CAP_ID(header) == PCI_EXT_CAP_ID_REBAR) {
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:177:15: error: use of undeclared identifier 'PCI_EXT_CAP_NEXT'
+ pos = PCI_EXT_CAP_NEXT(header);
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:178:19: error: use of undeclared identifier 'PCI_CFG_SPACE_SIZE'
+ if (pos < PCI_CFG_SPACE_SIZE) {
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:202:48: error: use of undeclared identifier 'PCI_CFG_SPACE_EXP_SIZE'
+ configMemory = std::make_unique<uint8_t[]>(PCI_CFG_SPACE_EXP_SIZE);
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:203:35: error: use of undeclared identifier 'PCI_CFG_SPACE_EXP_SIZE'
+ memset(configMemory.get(), 0, PCI_CFG_SPACE_EXP_SIZE);
+ ^
+level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp:204:55: error: use of undeclared identifier 'PCI_CFG_SPACE_EXP_SIZE'
+ this->preadFunction(fdConfig, configMemory.get(), PCI_CFG_SPACE_EXP_SIZE, 0);
+ ^
+
+--- level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp.orig 2021-07-27 12:47:48 UTC
++++ level_zero/tools/source/sysman/pci/linux/os_pci_imp.cpp
+@@ -12,7 +12,9 @@
+
+ #include "sysman/pci/pci_imp.h"
+
++#ifdef __linux__
+ #include <linux/pci_regs.h>
++#endif
+
+ namespace L0 {
+
+@@ -154,6 +156,7 @@ ze_result_t LinuxPciImp::initializeBarProperties(std::
+
+ // Parse PCIe configuration space to see if resizable Bar is supported
+ bool LinuxPciImp::resizableBarSupported() {
++#ifdef __linux__
+ uint32_t pos = PCI_CFG_SPACE_SIZE;
+ uint32_t header = 0;
+
+@@ -180,6 +183,7 @@ bool LinuxPciImp::resizableBarSupported() {
+ }
+ header = getDwordFromConfig(pos);
+ }
++#endif
+ return false;
+ }
+
+@@ -192,6 +196,7 @@ ze_result_t LinuxPciImp::getState(zes_pci_state_t *sta
+ }
+
+ void LinuxPciImp::pciExtendedConfigRead() {
++#ifdef __linux__
+ std::string pciConfigNode;
+ pSysfsAccess->getRealPath("device/config", pciConfigNode);
+ int fdConfig = -1;
+@@ -203,6 +208,7 @@ void LinuxPciImp::pciExtendedConfigRead() {
+ memset(configMemory.get(), 0, PCI_CFG_SPACE_EXP_SIZE);
+ this->preadFunction(fdConfig, configMemory.get(), PCI_CFG_SPACE_EXP_SIZE, 0);
+ this->closeFunction(fdConfig);
++#endif
+ }
+
+ LinuxPciImp::LinuxPciImp(OsSysman *pOsSysman) {