aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Zheng <kevinz5000@gmail.com>2023-05-18 21:53:29 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-05-21 17:27:20 +0000
commit8eb2398e0b7b307df5ed20c738648b08aa557c7f (patch)
treef74da7fbb473319812324ade66c56fa5380ec207
parentdc299b36fdc2faedaab1b411afa5e6cae7b68619 (diff)
downloadports-8eb2398e0b7b307df5ed20c738648b08aa557c7f.tar.gz
ports-8eb2398e0b7b307df5ed20c738648b08aa557c7f.zip
games/openclonk: Fix link on 14-CURRENT i386
Fix build on 14-CURRENT i386 by disabling dynamic relocation checks with lld 15. While here, since this port is BROKEN_powerpc64, remove the old powerpc build flags. PR: 271500 MFH: 2023Q2 (cherry picked from commit 35a33a5fa5b5da7b48d7401435403461796680e0)
-rw-r--r--games/openclonk/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/games/openclonk/Makefile b/games/openclonk/Makefile
index 46a6d9ba5675..dc565d626eb9 100644
--- a/games/openclonk/Makefile
+++ b/games/openclonk/Makefile
@@ -27,7 +27,7 @@ LIB_DEPENDS= libalut.so:audio/freealut \
WRKSRC= ${WRKDIR}/openclonk-release-${PORTVERSION}-src
# make install has parallel issues with ninja
-USES= cmake:noninja desktop-file-utils gl gnome jpeg openal \
+USES= cmake:noninja compiler:c++14-lang desktop-file-utils gl gnome jpeg openal \
pkgconfig sdl tar:bzip2 xorg
USE_GL= gl glew glu
USE_SDL= sdl2
@@ -35,17 +35,14 @@ USE_XORG= x11 xpm
CMAKE_ARGS= -DAudio_TK:STRING="OpenAL"
LDFLAGS_i386= -Wl,-znotext
-.include <bsd.port.options.mk>
+.include <bsd.port.pre.mk>
-.if ${ARCH} == powerpc64le
-CFLAGS+= -DNO_WARN_X86_INTRINSICS
-USES+= compiler:gcc-c++11-lib
-.else
-USES+= compiler:c++14-lang
+.if ${COMPILER_TYPE} == "clang" && ${COMPILER_VERSION} >= 150
+LDFLAGS_i386+= -Wl,--no-check-dynamic-relocations
.endif
post-patch:
@${REINPLACE_CMD} -e 's|DESTINATION games|DESTINATION bin|' \
-e 's|share/games|share|' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>