aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:42:28 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:30 +0000
commit9d85369d82f211e37f4c95412f1ad6d3b3dc6321 (patch)
tree6017625d0b7de27aca70c7c28a0b0f52a008c716
parent95203371dfaa957fc577320bb06ea533426be241 (diff)
downloadports-9d85369d82f211e37f4c95412f1ad6d3b3dc6321.tar.gz
ports-9d85369d82f211e37f4c95412f1ad6d3b3dc6321.zip
devel/py-ansi: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-ansi/Makefile9
-rw-r--r--devel/py-ansi/files/setup.py3
2 files changed, 5 insertions, 7 deletions
diff --git a/devel/py-ansi/Makefile b/devel/py-ansi/Makefile
index 5959485b7847..ede5e40fdd89 100644
--- a/devel/py-ansi/Makefile
+++ b/devel/py-ansi/Makefile
@@ -1,5 +1,6 @@
PORTNAME= ansi
PORTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,12 +12,12 @@ WWW= https://github.com/tehmaze/ansi
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=62.6:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0.37.1:devel/py-wheel@${PY_FLAVOR}
+
USES= python:3.6+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.mk>
diff --git a/devel/py-ansi/files/setup.py b/devel/py-ansi/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-ansi/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()