aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:05 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-10-13 05:34:05 +0000
commita887d6b59464a76e2a557656ca1e237c1ffea9c1 (patch)
tree89d71b2a30d94bf66515a8277dec9f98698e574c
parent593c9916f8d3ac20dc11e2cc82571c7f30e98dfa (diff)
downloadports-a887d6b59464a76e2a557656ca1e237c1ffea9c1.tar.gz
ports-a887d6b59464a76e2a557656ca1e237c1ffea9c1.zip
devel/rubygem-google-apis-sqladmin_v1beta4: Add rubygem-google-apis-sqladmin_v1beta4 0.17.0
This is a simple client library for version V1beta4 of the Cloud SQL Admin API. It provides: - A client object that connects to the HTTP/JSON REST endpoint for the service. - Ruby objects for data structures related to the service. - Integration with the googleauth gem for authentication using OAuth, API keys, and service accounts. - Control of retry, pagination, and timeouts. WWW: https://github.com/googleapis/google-api-ruby-client WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-sqladmin_v1beta4
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-sqladmin_v1beta4/Makefile21
-rw-r--r--devel/rubygem-google-apis-sqladmin_v1beta4/distinfo3
-rw-r--r--devel/rubygem-google-apis-sqladmin_v1beta4/pkg-descr10
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9a12486acec5..49722e8948ce 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6343,6 +6343,7 @@
SUBDIR += rubygem-google-apis-iamcredentials_v1
SUBDIR += rubygem-google-apis-monitoring_v3
SUBDIR += rubygem-google-apis-pubsub_v1
+ SUBDIR += rubygem-google-apis-sqladmin_v1beta4
SUBDIR += rubygem-google-apis-storage_v1
SUBDIR += rubygem-google-gax
SUBDIR += rubygem-google-protobuf
diff --git a/devel/rubygem-google-apis-sqladmin_v1beta4/Makefile b/devel/rubygem-google-apis-sqladmin_v1beta4/Makefile
new file mode 100644
index 000000000000..e1ff0356989d
--- /dev/null
+++ b/devel/rubygem-google-apis-sqladmin_v1beta4/Makefile
@@ -0,0 +1,21 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= google-apis-sqladmin_v1beta4
+PORTVERSION= 0.17.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Cloud SQL Admin API V1beta4
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.4<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-sqladmin_v1beta4/distinfo b/devel/rubygem-google-apis-sqladmin_v1beta4/distinfo
new file mode 100644
index 000000000000..5c3c0134e2ce
--- /dev/null
+++ b/devel/rubygem-google-apis-sqladmin_v1beta4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1632773614
+SHA256 (rubygem/google-apis-sqladmin_v1beta4-0.17.0.gem) = a0242a5f38e3bdcd1cfb824666b8ccba50b551dcf56abc4489bebfc970a2cc11
+SIZE (rubygem/google-apis-sqladmin_v1beta4-0.17.0.gem) = 45056
diff --git a/devel/rubygem-google-apis-sqladmin_v1beta4/pkg-descr b/devel/rubygem-google-apis-sqladmin_v1beta4/pkg-descr
new file mode 100644
index 000000000000..6f9ae1098c99
--- /dev/null
+++ b/devel/rubygem-google-apis-sqladmin_v1beta4/pkg-descr
@@ -0,0 +1,10 @@
+This is a simple client library for version V1beta4 of the Cloud SQL Admin API.
+It provides:
+- A client object that connects to the HTTP/JSON REST endpoint for the service.
+- Ruby objects for data structures related to the service.
+- Integration with the googleauth gem for authentication using OAuth, API keys,
+ and service accounts.
+- Control of retry, pagination, and timeouts.
+
+WWW: https://github.com/googleapis/google-api-ruby-client
+WWW: https://github.com/googleapis/google-api-ruby-client/tree/master/generated/google-apis-sqladmin_v1beta4