aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-10-11 14:53:15 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-10-11 14:57:51 +0000
commita90e961f4d19d53621612d1257a77a5635906ee0 (patch)
treeb22d551c6e4b218b366906c3b16594e742c6b7ee
parentc5420e877724ce867a6f8bcd98c613bb9af9e6e4 (diff)
downloadports-a90e961f4d19d53621612d1257a77a5635906ee0.tar.gz
ports-a90e961f4d19d53621612d1257a77a5635906ee0.zip
*/*: Avoid extra CPE_VENDOR=kde by properly sorting USES
CPE_VENDOR=kde is already set in Uses/kde.mk so adding cpe after kde in our USES line makes sure that it's picked up properly. Approved by: portmgr (blanket)
-rw-r--r--archivers/ark/Makefile5
-rw-r--r--devel/kf5-ktexteditor/Makefile3
-rw-r--r--graphics/okular/Makefile5
-rw-r--r--security/plasma5-kscreenlocker/Makefile4
-rw-r--r--sysutils/plasma5-discover/Makefile6
-rw-r--r--sysutils/plasma5-kde-cli-tools/Makefile3
-rw-r--r--x11/plasma5-plasma-desktop/Makefile6
-rw-r--r--x11/plasma5-plasma-workspace/Makefile6
8 files changed, 13 insertions, 25 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index fc8f6caa7ad9..bc61c9864283 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -8,8 +8,8 @@ COMMENT= Archiving tool for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext libarchive kde:5 \
- qt:5 shared-mime-info tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext libarchive kde:5 \
+ cpe qt:5 shared-mime-info tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools i18n iconthemes \
itemmodels itemviews jobwidgets khtml kio parts pty service \
@@ -19,7 +19,6 @@ USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-CPE_VENDOR= kde
OPTIONS_DEFINE= 7ZIP RAR ZIP DOCS
OPTIONS_DEFAULT= 7ZIP ZIP DOCS
diff --git a/devel/kf5-ktexteditor/Makefile b/devel/kf5-ktexteditor/Makefile
index 6899a3628193..17b888b79f89 100644
--- a/devel/kf5-ktexteditor/Makefile
+++ b/devel/kf5-ktexteditor/Makefile
@@ -8,7 +8,7 @@ COMMENT= KF5 advanced embeddable text editor
LIB_DEPENDS= libgit2.so:devel/libgit2 \
libeditorconfig.so:editors/editorconfig-core-c
-USES= cmake compiler:c++11-lib cpe gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib gettext kde:5 cpe pkgconfig qt:5 tar:xz
USE_KDE= archive auth codecs completion config configwidgets \
coreaddons guiaddons i18n iconthemes itemviews \
jobwidgets kio parts service sonnet syntaxhighlighting \
@@ -17,6 +17,5 @@ USE_KDE= archive auth codecs completion config configwidgets \
USE_QT= concurrent core dbus declarative gui network printsupport \
script widgets xml xmlpatterns \
buildtools_build qmake_build
-CPE_VENDOR= kde
.include <bsd.port.mk>
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index efd29237e60b..a16387a5d749 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -21,8 +21,8 @@ LIB_DEPENDS= libchm.so:misc/chmlib \
libtiff.so:graphics/tiff \
libzip.so:archivers/libzip
-USES= cmake compiler:c++11-lib cpe desktop-file-utils \
- gettext jpeg kde:5 pkgconfig qca qt:5 tar:xz
+USES= cmake compiler:c++11-lib desktop-file-utils \
+ gettext jpeg kde:5 cpe pkgconfig qca qt:5 tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config \
configwidgets coreaddons crash dbusaddons emoticons i18n \
iconthemes init itemmodels itemviews jobwidgets js \
@@ -33,7 +33,6 @@ USE_KDE= activities archive auth bookmarks codecs completion config \
USE_QT= concurrent core dbus declarative gui network phonon4 printsupport speech \
svg widgets xml \
buildtools_build qmake_build testlib_build
-CPE_VENDOR= kde
OPTIONS_DEFINE= DOCS PURPOSE
OPTIONS_DEFAULT= PURPOSE
diff --git a/security/plasma5-kscreenlocker/Makefile b/security/plasma5-kscreenlocker/Makefile
index d18bf37e97ee..450688230613 100644
--- a/security/plasma5-kscreenlocker/Makefile
+++ b/security/plasma5-kscreenlocker/Makefile
@@ -11,7 +11,7 @@ LIB_DEPENDS= libwayland-client.so:graphics/wayland \
RUN_DEPENDS= ck-list-sessions:sysutils/consolekit2\
dbus-send:devel/dbus
-USES= cmake compiler:c++11-lib cpe gettext kde:5 pkgconfig qt:5 \
+USES= cmake compiler:c++11-lib gettext kde:5 cpe pkgconfig qt:5 \
shebangfix tar:xz xorg
USE_KDE= auth codecs config configwidgets coreaddons crash emoticons \
globalaccel i18n idletime init itemmodels kcmutils \
@@ -23,8 +23,6 @@ USE_QT= core dbus declarative gui network qdbus widgets x11extras xml \
buildtools_build qmake_build testlib_build
USE_XORG= ice sm x11 xcb xcursor xext xi
-CPE_VENDOR= kde
-
SHEBANG_FILES= updaters/ksreenlocker_5_3_separate_autologin.pl
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-discover/Makefile b/sysutils/plasma5-discover/Makefile
index 92e151885819..2520ee66db00 100644
--- a/sysutils/plasma5-discover/Makefile
+++ b/sysutils/plasma5-discover/Makefile
@@ -8,8 +8,8 @@ COMMENT= Plasma5 package management tools
# TODO: update packagekit-qt5
#LIB_DEPENDS= libpackagekit-qt.so:ports-mgmt/packagekit-qt5
-USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext kde:5 \
- pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 \
+ cpe pkgconfig qt:5 tar:xz
USE_KDE= archive attica auth codecs completion config configwidgets \
coreaddons crash dbusaddons i18n iconthemes idletime \
itemmodels itemviews jobwidgets kcmutils kdeclarative kio \
@@ -21,6 +21,4 @@ USE_QT= concurrent core dbus declarative gui network svg widgets \
x11extras xml \
buildtools_build qmake_build testlib_build
-CPE_VENDOR= kde
-
.include <bsd.port.mk>
diff --git a/sysutils/plasma5-kde-cli-tools/Makefile b/sysutils/plasma5-kde-cli-tools/Makefile
index 695fd5a96bff..2978cde83be6 100644
--- a/sysutils/plasma5-kde-cli-tools/Makefile
+++ b/sysutils/plasma5-kde-cli-tools/Makefile
@@ -5,7 +5,7 @@ CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 non-interactive system tools
-USES= cmake compiler:c++11-lib cpe gettext kde:5 qt:5 tar:xz xorg
+USES= cmake compiler:c++11-lib gettext kde:5 cpe qt:5 tar:xz xorg
USE_KDE= activities auth bookmarks codecs completion config \
configwidgets coreaddons crash emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets kcmutils \
@@ -17,6 +17,5 @@ USE_QT= concurrent core dbus declarative gui network printsupport svg \
widgets x11extras xml \
buildtools_build qmake_build testlib_build
USE_XORG= x11
-CPE_VENDOR= kde
.include <bsd.port.mk>
diff --git a/x11/plasma5-plasma-desktop/Makefile b/x11/plasma5-plasma-desktop/Makefile
index 312b818d7fb0..a39475e9d8d6 100644
--- a/x11/plasma5-plasma-desktop/Makefile
+++ b/x11/plasma5-plasma-desktop/Makefile
@@ -23,8 +23,8 @@ BUILD_DEPENDS= xf86-input-evdev>0:x11-drivers/xf86-input-evdev \
xf86-input-synaptics>0:x11-drivers/xf86-input-synaptics \
xf86-input-libinput>0:x11-drivers/xf86-input-libinput
-USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext gnome \
- kde:5 pkgconfig python:3.5+,run qt:5 shebangfix tar:xz xorg
+USES= cmake compiler:c++11-lib desktop-file-utils gettext gnome \
+ kde:5 cpe pkgconfig python:3.5+,run qt:5 shebangfix tar:xz xorg
USE_GNOME= glib20
USE_KDE= activities activities-stats archive attica auth baloo \
bookmarks codecs completion config configwidgets coreaddons \
@@ -43,8 +43,6 @@ USE_QT= concurrent core dbus declarative gui network phonon4 \
buildtools_build qmake_build
USE_XORG= ice sm x11 xcb xcursor xext xfixes xft xi xrender
-CPE_VENDOR= kde
-
CMAKE_ON= WANT_SYNAPTICS
SHEBANG_FILES= kcms/ksmserver/kconf_update/*.py \
diff --git a/x11/plasma5-plasma-workspace/Makefile b/x11/plasma5-plasma-workspace/Makefile
index a3c28312eac0..e68811e4e028 100644
--- a/x11/plasma5-plasma-workspace/Makefile
+++ b/x11/plasma5-plasma-workspace/Makefile
@@ -24,8 +24,8 @@ RUN_DEPENDS= ck-launch-session:sysutils/consolekit2\
${LOCALBASE}/bin/genv:sysutils/coreutils
-USES= cmake compiler:c++11-lib cpe desktop-file-utils gettext kde:5 \
- pkgconfig qt:5 tar:xz xorg
+USES= cmake compiler:c++11-lib desktop-file-utils gettext kde:5 \
+ cpe pkgconfig qt:5 tar:xz xorg
USE_KDE= activities activities-stats activitymanagerd archive attica \
auth baloo bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons emoticons filemetadata globalaccel \
@@ -46,8 +46,6 @@ USE_QT= concurrent core dbus declarative graphicaleffects gui network \
paths_run quickcontrols_run
USE_XORG= ice sm x11 xau xcb xcomposite xcursor xext xfixes xft xkbfile xrender xtst
-CPE_VENDOR= kde
-
CMAKE_OFF= BUILD_TESTING
# In 5.15 a file was moved from x11/plasma5-plasma-desktop to x11/plasma5-plasma-workspace: