aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:44:15 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:20:44 +0000
commitb23c576d2d0c0d49ce89d29eb184300dba4f35ab (patch)
treeb0ffcea2eb171aae200f1a216df8b7ad51a7e108
parentcaa325dc5363185de26c10b77d19ceb36d911eda (diff)
downloadports-b23c576d2d0c0d49ce89d29eb184300dba4f35ab.tar.gz
ports-b23c576d2d0c0d49ce89d29eb184300dba4f35ab.zip
devel/py-jaraco.text: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for dependency and package change
-rw-r--r--devel/py-jaraco.text/Makefile9
-rw-r--r--devel/py-jaraco.text/files/setup.py3
2 files changed, 5 insertions, 7 deletions
diff --git a/devel/py-jaraco.text/Makefile b/devel/py-jaraco.text/Makefile
index f6a71c9727ea..4ca671fee633 100644
--- a/devel/py-jaraco.text/Makefile
+++ b/devel/py-jaraco.text/Makefile
@@ -1,5 +1,6 @@
PORTNAME= jaraco.text
PORTVERSION= 3.11.0
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,6 +12,9 @@ WWW= https://github.com/jaraco/jaraco.text
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=56:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=3.4.1:devel/py-setuptools_scm@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}autocommand>=0:devel/py-autocommand@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}inflect>=0:devel/py-inflect@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}jaraco.context>=4.1:devel/py-jaraco.context@${PY_FLAVOR} \
@@ -18,7 +22,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}autocommand>=0:devel/py-autocommand@${PY_FLA
${PYTHON_PKGNAMEPREFIX}more-itertools>=0:devel/py-more-itertools@${PY_FLAVOR}
USES= python:3.7+
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
@@ -28,7 +32,4 @@ NO_ARCH= yes
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-resources>=0:devel/py-importlib-resources@${PY_FLAVOR}
.endif
-post-patch:
- @${CP} ${FILESDIR}/setup.py ${WRKSRC}/
-
.include <bsd.port.post.mk>
diff --git a/devel/py-jaraco.text/files/setup.py b/devel/py-jaraco.text/files/setup.py
deleted file mode 100644
index 606849326a40..000000000000
--- a/devel/py-jaraco.text/files/setup.py
+++ /dev/null
@@ -1,3 +0,0 @@
-from setuptools import setup
-
-setup()