aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2021-11-26 05:45:13 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2021-11-26 05:45:13 +0000
commitb915ce8529c242c62180bd64442c482030703456 (patch)
treeb4dca5af84b00dfc556c19f8efc706cbda08905c
parent77ea6411e8deb12c116369e0c2e80040bd2617cc (diff)
downloadports-b915ce8529c242c62180bd64442c482030703456.tar.gz
ports-b915ce8529c242c62180bd64442c482030703456.zip
net/wireshark: Add missing dependencies to fix plist.
PR: 260053 Differential Revision: https://reviews.freebsd.org/D33122
-rw-r--r--net/wireshark/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 9026beab3158..bf62b994c9ab 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -2,6 +2,7 @@
PORTNAME?= wireshark
PORTVERSION= 3.6.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.wireshark.org/download/src/ \
http://ftp.uni-kl.de/pub/wireshark/src/ \
@@ -31,12 +32,14 @@ USE_PERL5= build
USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
+BUILD_DEPENDS= asciidoctor:textproc/rubygem-asciidoctor
LIB_DEPENDS+= libgpg-error.so:security/libgpg-error \
libgcrypt.so:security/libgcrypt \
liblz4.so:archivers/liblz4 \
libnghttp2.so:www/libnghttp2 \
libsnappy.so:archivers/snappy \
- libcares.so:dns/c-ares
+ libcares.so:dns/c-ares \
+ libzstd.so:archivers/zstd
#CFLAGS+= -funit-at-a-time
PLIST_SUB+= PORTVERSION=${PORTVERSION}