aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-05-17 17:16:29 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-05-17 17:17:21 +0000
commitba2119a49de294dedc4c370111d04311f69a3e2c (patch)
treea2ab869f4d0addd7377c6a0010ceebd7853c53ce
parentbac77ada52603ea9b734dfac40b6642b17d483c9 (diff)
downloadports-ba2119a49de294dedc4c370111d04311f69a3e2c.tar.gz
ports-ba2119a49de294dedc4c370111d04311f69a3e2c.zip
www/libdatachannel: Update 0.13.0 -> 0.13.0-8
* Add tests. * Add USES=ssl
-rw-r--r--www/libdatachannel/Makefile13
-rw-r--r--www/libdatachannel/distinfo12
-rw-r--r--www/libdatachannel/pkg-plist4
3 files changed, 17 insertions, 12 deletions
diff --git a/www/libdatachannel/Makefile b/www/libdatachannel/Makefile
index 8f9615fc8d47..f13949d5baab 100644
--- a/www/libdatachannel/Makefile
+++ b/www/libdatachannel/Makefile
@@ -1,6 +1,7 @@
PORTNAME= libdatachannel
DISTVERSIONPREFIX= v
-DISTVERSION= 0.13.0
+DISTVERSION= 0.13.0-8
+DISTVERSIONSUFFIX= -g5c8d63a
CATEGORIES= www
MAINTAINER= yuri@FreeBSD.org
@@ -11,16 +12,22 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libsrtp2.so:net/libsrtp2
-USES= cmake:testing
+USES= cmake compiler:c++17-lang ssl
USE_GITHUB= yes
GH_ACCOUNT= paullouisageneau
GH_TUPLE= \
SergiusTheBest:plog:d8461e9:plog/deps/plog \
sctplab:usrsctp:07f871b:usrsctp/deps/usrsctp \
- paullouisageneau:libjuice:4393345:libjuice/deps/libjuice \
+ paullouisageneau:libjuice:7a6efb7:libjuice/deps/libjuice \
nlohmann:json:973c52d:json/deps/json
CMAKE_ON= USE_SYSTEM_SRTP NO_EXAMPLES NO_TESTS
+do-test:
+ @cd ${BUILD_WRKSRC} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -DNO_TESTS:BOOL=OFF ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
+ ./tests-${DISTVERSION:C/-.*//}
+
.include <bsd.port.mk>
diff --git a/www/libdatachannel/distinfo b/www/libdatachannel/distinfo
index f3990cbc801d..0d2c32fe8069 100644
--- a/www/libdatachannel/distinfo
+++ b/www/libdatachannel/distinfo
@@ -1,13 +1,11 @@
-TIMESTAMP = 1621197360
-SHA256 (paullouisageneau-libdatachannel-v0.13.0_GH0.tar.gz) = 1ad77e81731d7881fd9f608d87995cf1a9579f8263050990f14187cb00b888d0
-SIZE (paullouisageneau-libdatachannel-v0.13.0_GH0.tar.gz) = 52428117
+TIMESTAMP = 1621268706
+SHA256 (paullouisageneau-libdatachannel-v0.13.0-8-g5c8d63a_GH0.tar.gz) = 7c072c6093f7b472545a2d8741f6aaf515d51273aba9ed538cae47f6278e17cc
+SIZE (paullouisageneau-libdatachannel-v0.13.0-8-g5c8d63a_GH0.tar.gz) = 52428403
SHA256 (SergiusTheBest-plog-d8461e9_GH0.tar.gz) = 2d30536bc920fc44e6ec90f60244afe9249c79bc618574f7d3e78fbcd1a51ec8
SIZE (SergiusTheBest-plog-d8461e9_GH0.tar.gz) = 44215
SHA256 (sctplab-usrsctp-07f871b_GH0.tar.gz) = 1b02f2574e53c8b3dca7c5687172766fe04a0fc8f8f52a0ef8707155ae76cef1
SIZE (sctplab-usrsctp-07f871b_GH0.tar.gz) = 771605
-SHA256 (paullouisageneau-libjuice-4393345_GH0.tar.gz) = 8307296f64820c8083a9bd007ea41b3fdad82f253db1c8e5ef58f8d436b74ac6
-SIZE (paullouisageneau-libjuice-4393345_GH0.tar.gz) = 82427
+SHA256 (paullouisageneau-libjuice-7a6efb7_GH0.tar.gz) = 062046cd992f7b76c2b74546f2dff59b2885877210dff259de8f9cec616295da
+SIZE (paullouisageneau-libjuice-7a6efb7_GH0.tar.gz) = 82772
SHA256 (nlohmann-json-973c52d_GH0.tar.gz) = cd8ec6d071db0dba7b7d2eb107747deb3921aa5b4e0423df39388843937907b5
SIZE (nlohmann-json-973c52d_GH0.tar.gz) = 119021919
-SHA256 (cisco-libsrtp-f379f48_GH0.tar.gz) = 23e26242a9f5b4d9f0bc6fda18b57e6903c4020816c957b197adc9d4fde0ce42
-SIZE (cisco-libsrtp-f379f48_GH0.tar.gz) = 635824
diff --git a/www/libdatachannel/pkg-plist b/www/libdatachannel/pkg-plist
index c8fad885f65b..d9630f86f809 100644
--- a/www/libdatachannel/pkg-plist
+++ b/www/libdatachannel/pkg-plist
@@ -51,5 +51,5 @@ include/rtc/utils.hpp
include/rtc/websocket.hpp
lib/libdatachannel.so
lib/libdatachannel.so.0.13.0
-share/cmake/libdatachannel/datachannel-export-%%CMAKE_BUILD_TYPE%%.cmake
-share/cmake/libdatachannel/datachannel-export.cmake
+share/cmake/libdatachannel/libdatachannel-config-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/libdatachannel/libdatachannel-config.cmake