aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Tartière <romain@FreeBSD.org>2023-03-24 20:49:21 +0000
committerRomain Tartière <romain@FreeBSD.org>2023-03-24 22:24:10 +0000
commitba885e567f3c01af8af2f245abe7479e351153dc (patch)
treeb671b1bbe0abece5f09ad06b40e2105d236a7d2d
parent266e23fd78acb1d2a4285a4419982c89ad025748 (diff)
downloadports-ba885e567f3c01af8af2f245abe7479e351153dc.tar.gz
ports-ba885e567f3c01af8af2f245abe7479e351153dc.zip
sysutils/puppet7: Switch back to older concurrent-ruby
This revert 9b4522cb7997070282339d841af44ee8e57ae798 and update the dependency on concurrent-ruby to use version 1.1. With hat: puppet
-rw-r--r--sysutils/puppet7/Makefile3
-rw-r--r--sysutils/puppet7/files/patch-lib_puppet_thread__local.rb13
2 files changed, 2 insertions, 14 deletions
diff --git a/sysutils/puppet7/Makefile b/sysutils/puppet7/Makefile
index 926db74da1fc..c133e8c67be1 100644
--- a/sysutils/puppet7/Makefile
+++ b/sysutils/puppet7/Makefile
@@ -1,5 +1,6 @@
PORTNAME= puppet
PORTVERSION= 7.23.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= https://forge.puppet.com/v3/files/:forge
PKGNAMESUFFIX= 7
@@ -11,7 +12,7 @@ WWW= https://puppet.com/docs/puppet/latest/puppet_index.html
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= rubygem-concurrent-ruby>1.0:devel/rubygem-concurrent-ruby \
+RUN_DEPENDS= rubygem-concurrent-ruby11>1.0:devel/rubygem-concurrent-ruby11 \
rubygem-deep_merge>1.0:devel/rubygem-deep_merge \
rubygem-fast_gettext1>=1.1:devel/rubygem-fast_gettext1 \
rubygem-hiera>=3.2.1:sysutils/rubygem-hiera \
diff --git a/sysutils/puppet7/files/patch-lib_puppet_thread__local.rb b/sysutils/puppet7/files/patch-lib_puppet_thread__local.rb
deleted file mode 100644
index 25f7f1614577..000000000000
--- a/sysutils/puppet7/files/patch-lib_puppet_thread__local.rb
+++ /dev/null
@@ -1,13 +0,0 @@
-Reference: https://github.com/ruby-concurrency/concurrent-ruby/pull/988
- https://github.com/ruby-concurrency/concurrent-ruby/issues/986
- https://github.com/puppetlabs/puppet/commit/9182bc3dd2576f409a6d01fb5c08d392670e90a2
-
---- lib/puppet/thread_local.rb.orig 2022-12-02 03:58:03 UTC
-+++ lib/puppet/thread_local.rb
-@@ -3,5 +3,5 @@ require 'concurrent'
- # We want to use the pure Ruby implementation even on JRuby. If we use the Java
- # implementation of ThreadLocal, we end up leaking references to JRuby instances
- # and preventing them from being garbage collected.
--class Puppet::ThreadLocal < Concurrent::RubyThreadLocalVar
-+class Puppet::ThreadLocal < Concurrent::ThreadLocalVar
- end