aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 13:58:43 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2022-06-16 13:58:43 +0000
commitba8cf8a9f1e249e34b8f03ed7d5ad5cf8c1ecdff (patch)
treee667e610ea26dc50e2487bab8e30073597482773
parent58a791d95ee7046bc23e1741cef4e8498ba3ac2c (diff)
downloadports-ba8cf8a9f1e249e34b8f03ed7d5ad5cf8c1ecdff.tar.gz
ports-ba8cf8a9f1e249e34b8f03ed7d5ad5cf8c1ecdff.zip
devel/py-watchfiles: Add py-watchfiles 0.14.1
Simple, modern and high performance file watching and code reload in python. WWW: https://github.com/samuelcolvin/watchfiles
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-watchfiles/Makefile23
-rw-r--r--devel/py-watchfiles/distinfo3
-rw-r--r--devel/py-watchfiles/pkg-descr3
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f2545b0a0b0..f86a81f4b9ba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5479,6 +5479,7 @@
SUBDIR += py-wadllib
SUBDIR += py-warlock
SUBDIR += py-watchdog
+ SUBDIR += py-watchfiles
SUBDIR += py-watchgod
SUBDIR += py-watermark
SUBDIR += py-wcwidth
diff --git a/devel/py-watchfiles/Makefile b/devel/py-watchfiles/Makefile
new file mode 100644
index 000000000000..becc2c8c3177
--- /dev/null
+++ b/devel/py-watchfiles/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+
+PORTNAME= watchfiles
+PORTVERSION= 0.14.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple, modern and high performance file watching and code reload in python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}anyio>=3.0.0<4:devel/py-anyio@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+MAKE_ENV= SKIP_RUST_EXTENSION=1
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-watchfiles/distinfo b/devel/py-watchfiles/distinfo
new file mode 100644
index 000000000000..3eb501203a60
--- /dev/null
+++ b/devel/py-watchfiles/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1655208194
+SHA256 (watchfiles-0.14.1.tar.gz) = babcc3a3502879224e33ba5f25adfbf37a4f22898977c2d96d0ed3eee99eca8a
+SIZE (watchfiles-0.14.1.tar.gz) = 18700
diff --git a/devel/py-watchfiles/pkg-descr b/devel/py-watchfiles/pkg-descr
new file mode 100644
index 000000000000..67ac91a9b9b1
--- /dev/null
+++ b/devel/py-watchfiles/pkg-descr
@@ -0,0 +1,3 @@
+Simple, modern and high performance file watching and code reload in python.
+
+WWW: https://github.com/samuelcolvin/watchfiles