aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Osipov <michael.osipov@siemens.com>2023-08-31 13:18:05 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2023-09-15 12:07:41 +0000
commitbbca8e8174da13923b4adb451a7ec20596f36a74 (patch)
tree0ae3490ae87b16c89b246c496dc31a532339b88f
parent83964d19d9f692d91242d53609b9005e2e5e7ac8 (diff)
downloadports-bbca8e8174da13923b4adb451a7ec20596f36a74.tar.gz
ports-bbca8e8174da13923b4adb451a7ec20596f36a74.zip
ghostscript.mk: replace flavors
Flavors for GS 10 create confliciting dependencies, therefore resort to port options. PR: 272541
-rw-r--r--Mk/Uses/ghostscript.mk14
1 files changed, 7 insertions, 7 deletions
diff --git a/Mk/Uses/ghostscript.mk b/Mk/Uses/ghostscript.mk
index 6a0491245acc..9590e55308b7 100644
--- a/Mk/Uses/ghostscript.mk
+++ b/Mk/Uses/ghostscript.mk
@@ -79,9 +79,9 @@ _GS_SELECTED?= 9-agpl
. endif
. endfor
-. undef _GS_FLAVORED
+. undef _GS_STATIC
. if empty(_GS_SELECTED:M9-agpl)
-_GS_FLAVORED= yes
+_GS_STATIC= yes
. endif
# Resolve minor version number for X11.so library.
@@ -93,14 +93,14 @@ _GS_VERSION_MINOR= 9.56.1
# dependencies
_GS_LIB= libgs.so
-_GS_PKGNAME= ghostscript${_GS_SELECTED}${_GS_FLAVORED:?:-base}
-_GS_X11_PKGNAME=ghostscript${_GS_SELECTED}-x11
-_GS_PORT= print/ghostscript${_GS_SELECTED}${_GS_FLAVORED:?:-base}
-_GS_X11_PORT= print/ghostscript${_GS_SELECTED}${_GS_FLAVORED:?@:-}x11
+_GS_PKGNAME= ghostscript${_GS_SELECTED}${_GS_STATIC:?:-base}
+_GS_X11_PKGNAME=ghostscript${_GS_SELECTED}${_GS_STATIC:?:-x11}
+_GS_PORT= print/ghostscript${_GS_SELECTED}${_GS_STATIC:?:-base}
+_GS_X11_PORT= print/ghostscript${_GS_SELECTED}${_GS_STATIC:?:-x11}
. for type in BUILD LIB RUN TEST
. if defined(_GS_${type}_DEP)
-. if !defined(_GS_FLAVORED) || !${_GS_ARGS:Mx11}
+. if !defined(_GS_STATIC) || !${_GS_ARGS:Mx11}
. if ${type:MLIB}
${type}_DEPENDS+= ${_GS_LIB}:${_GS_PORT}
. else