aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2021-10-11 14:26:47 +0000
committerMathieu Arnold <mat@FreeBSD.org>2021-10-11 15:09:43 +0000
commitbe72428b1c4344b228d97c30162782408861753c (patch)
treed35d47652778c0387ca9680ea78336efd0c47f2b
parenta90e961f4d19d53621612d1257a77a5635906ee0 (diff)
downloadports-be72428b1c4344b228d97c30162782408861753c.tar.gz
ports-be72428b1c4344b228d97c30162782408861753c.zip
dns/bind9-devel: update to latest commit
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl16
-rw-r--r--dns/bind9-devel/pkg-plist6
4 files changed, 13 insertions, 19 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 17317eab892d..d4df34e282b1 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -49,13 +49,13 @@ RUN_DEPENDS= bind-tools>0:dns/bind-tools
# XXX: remove tar:bz2
USES= autoreconf compiler:c11 cpe libedit libtool pkgconfig ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.17.18a0.2021.09.24
+ISCVERSION= 9.17.18a0.2021.10.08
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= eeec53eb5da5c0968e099f01c6236127f9813a97
+GL_COMMIT= e112afa15668bd3b1baed59df2d21e01b46da15e
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index 78c37cfdd258..9d8a068d04d7 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1632746052
-SHA256 (isc-projects-bind9-eeec53eb5da5c0968e099f01c6236127f9813a97_GL0.tar.gz) = 771af250c5eed45337cc418827c7fad50ff6fbd09e31f40c126ceb96fd202bae
-SIZE (isc-projects-bind9-eeec53eb5da5c0968e099f01c6236127f9813a97_GL0.tar.gz) = 6123928
+TIMESTAMP = 1633958377
+SHA256 (isc-projects-bind9-e112afa15668bd3b1baed59df2d21e01b46da15e_GL0.tar.gz) = 9910baa816fc993092ff8e29c1a85b1a57e1d3e382e9b70dd0caa79e0221d314
+SIZE (isc-projects-bind9-e112afa15668bd3b1baed59df2d21e01b46da15e_GL0.tar.gz) = 6111472
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 0277ad45fc8d..6b7a6e7736f7 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,6 +1,6 @@
Add the override-cache-ttl feature.
---- bin/named/config.c.orig 2021-09-17 07:10:48 UTC
+--- bin/named/config.c.orig 2021-10-08 10:07:46 UTC
+++ bin/named/config.c
@@ -182,6 +182,7 @@ options {\n\
notify-source *;\n\
@@ -10,9 +10,9 @@ Add the override-cache-ttl feature.
parental-source *;\n\
parental-source-v6 *;\n\
provide-ixfr true;\n\
---- bin/named/server.c.orig 2021-09-17 07:10:48 UTC
+--- bin/named/server.c.orig 2021-10-08 10:07:46 UTC
+++ bin/named/server.c
-@@ -4498,6 +4498,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
+@@ -4479,6 +4479,11 @@ configure_view(dns_view_t *view, dns_viewlist_t *viewl
}
obj = NULL;
@@ -24,7 +24,7 @@ Add the override-cache-ttl feature.
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asduration(obj);
---- lib/dns/include/dns/view.h.orig 2021-09-17 07:10:48 UTC
+--- lib/dns/include/dns/view.h.orig 2021-10-08 10:07:46 UTC
+++ lib/dns/include/dns/view.h
@@ -154,6 +154,7 @@ struct dns_view {
bool requestnsid;
@@ -34,9 +34,9 @@ Add the override-cache-ttl feature.
dns_ttl_t maxncachettl;
dns_ttl_t mincachettl;
dns_ttl_t minncachettl;
---- lib/dns/resolver.c.orig 2021-09-17 07:10:48 UTC
+--- lib/dns/resolver.c.orig 2021-10-08 10:07:46 UTC
+++ lib/dns/resolver.c
-@@ -6382,6 +6382,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
+@@ -5910,6 +5910,12 @@ cache_name(fetchctx_t *fctx, dns_name_t *name, dns_mes
}
/*
@@ -49,9 +49,9 @@ Add the override-cache-ttl feature.
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2021-09-17 07:10:48 UTC
+--- lib/isccfg/namedconf.c.orig 2021-10-08 10:07:46 UTC
+++ lib/isccfg/namedconf.c
-@@ -2050,6 +2050,7 @@ static cfg_clausedef_t view_clauses[] = {
+@@ -2049,6 +2049,7 @@ static cfg_clausedef_t view_clauses[] = {
#endif /* ifdef HAVE_LMDB */
{ "max-acache-size", NULL, CFG_CLAUSEFLAG_ANCIENT },
{ "max-cache-size", &cfg_type_sizeorpercent, 0 },
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index f5e38c9ba9b6..0a156bc25d82 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -57,7 +57,6 @@ include/dns/keyflags.h
include/dns/keymgr.h
include/dns/keytable.h
include/dns/keyvalues.h
-include/dns/lib.h
include/dns/librpz.h
include/dns/log.h
include/dns/lookup.h
@@ -97,7 +96,6 @@ include/dns/secproto.h
include/dns/soa.h
include/dns/ssu.h
include/dns/stats.h
-include/dns/tcpmsg.h
include/dns/time.h
include/dns/timer.h
include/dns/tkey.h
@@ -116,7 +114,6 @@ include/dns/zoneverify.h
include/dns/zt.h
include/dst/dst.h
include/dst/gssapi.h
-include/dst/result.h
include/irs/resconf.h
include/isc/aes.h
include/isc/align.h
@@ -192,7 +189,6 @@ include/isc/regex.h
include/isc/region.h
include/isc/resource.h
include/isc/result.h
-include/isc/resultclass.h
include/isc/rwlock.h
include/isc/safe.h
include/isc/serial.h
@@ -224,7 +220,6 @@ include/isccc/base64.h
include/isccc/cc.h
include/isccc/ccmsg.h
include/isccc/events.h
-include/isccc/result.h
include/isccc/sexpr.h
include/isccc/symtab.h
include/isccc/symtype.h
@@ -240,7 +235,6 @@ include/ns/client.h
include/ns/events.h
include/ns/hooks.h
include/ns/interfacemgr.h
-include/ns/lib.h
include/ns/listenlist.h
include/ns/log.h
include/ns/notify.h