aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 18:35:49 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-03-21 19:19:57 +0000
commitd4e32a3f8e0f49eca95cf1955f0057f5de88cd12 (patch)
tree07bcc7bfbb689d8a16a906f1fb6cc7107c23b1d9
parent318634b5966eb37ed7e19375af1858909d3838a5 (diff)
downloadports-d4e32a3f8e0f49eca95cf1955f0057f5de88cd12.tar.gz
ports-d4e32a3f8e0f49eca95cf1955f0057f5de88cd12.zip
devel/rubygem-google-apis-iam_v2beta: Add rubygem-google-apis-iam_v2beta 0.9.0
This is the simple REST client for Identity and Access Management (IAM) API V2beta. Simple REST clients are Ruby client libraries that provide access to Google services via their HTTP REST API endpoints. These libraries are generated and updated automatically based on the discovery documents published by the service, and they handle most concerns such as authentication, pagination, retry, timeouts, and logging. You can use this client to access the Identity and Access Management (IAM) API, but note that some services may provide a separate modern client that is easier to use.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-google-apis-iam_v2beta/Makefile19
-rw-r--r--devel/rubygem-google-apis-iam_v2beta/distinfo3
-rw-r--r--devel/rubygem-google-apis-iam_v2beta/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6110228d8e49..c33df37344a1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -6732,6 +6732,7 @@
SUBDIR += rubygem-google-apis-generator
SUBDIR += rubygem-google-apis-iam_v1
SUBDIR += rubygem-google-apis-iam_v2
+ SUBDIR += rubygem-google-apis-iam_v2beta
SUBDIR += rubygem-google-apis-iamcredentials_v1
SUBDIR += rubygem-google-apis-monitoring_v3
SUBDIR += rubygem-google-apis-pubsub_v1
diff --git a/devel/rubygem-google-apis-iam_v2beta/Makefile b/devel/rubygem-google-apis-iam_v2beta/Makefile
new file mode 100644
index 000000000000..10029a27a3ca
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2beta/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= google-apis-iam_v2beta
+PORTVERSION= 0.9.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Simple REST client for Identity and Access Management (IAM) API V2beta
+WWW= https://github.com/googleapis/google-api-ruby-client/tree/main/generated/google-apis-iam_v2beta
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+RUN_DEPENDS= rubygem-google-apis-core>=0.11.0<2.0:devel/rubygem-google-apis-core
+
+USES= gem
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-google-apis-iam_v2beta/distinfo b/devel/rubygem-google-apis-iam_v2beta/distinfo
new file mode 100644
index 000000000000..d81d681388b2
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2beta/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1677770973
+SHA256 (rubygem/google-apis-iam_v2beta-0.9.0.gem) = 8802561ccb1550e6fc65b1e7e64fe64be181592089483090529ba89362f624de
+SIZE (rubygem/google-apis-iam_v2beta-0.9.0.gem) = 19456
diff --git a/devel/rubygem-google-apis-iam_v2beta/pkg-descr b/devel/rubygem-google-apis-iam_v2beta/pkg-descr
new file mode 100644
index 000000000000..6d6ff0bb9023
--- /dev/null
+++ b/devel/rubygem-google-apis-iam_v2beta/pkg-descr
@@ -0,0 +1,8 @@
+This is the simple REST client for Identity and Access Management (IAM) API
+V2beta. Simple REST clients are Ruby client libraries that provide access to
+Google services via their HTTP REST API endpoints. These libraries are generated
+and updated automatically based on the discovery documents published by the
+service, and they handle most concerns such as authentication, pagination,
+retry, timeouts, and logging. You can use this client to access the Identity and
+Access Management (IAM) API, but note that some services may provide a separate
+modern client that is easier to use.