aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesús Daniel Colmenares Oviedo <DtxdF@riseup.net>2022-08-18 19:19:31 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-20 03:36:48 +0000
commitdbc31c67be0bd7d590989eb71c33a44ece81596c (patch)
treefe0bede5d3cfd48156c24602ec746a1da1259d39
parented5b9ccf964d53da04bf7deae22244890b9d1548 (diff)
downloadports-dbc31c67be0bd7d590989eb71c33a44ece81596c.tar.gz
ports-dbc31c67be0bd7d590989eb71c33a44ece81596c.zip
sysutils/py-keep: new port
keep is a Meta CLI Toolkit that provides a personal shell command keeper with some useful features: * Save a new command with a brief description * Search the saved commands using powerful patterns * Save the commands as a secret GitHub gist * Use keep push and keep pull to sync the commands between GitHub gist and other computers. WWW: https://github.com/OrkoHunter/keep PR: 265933
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/py-keep/Makefile30
-rw-r--r--sysutils/py-keep/distinfo3
-rw-r--r--sysutils/py-keep/files/LICENSE.md21
-rw-r--r--sysutils/py-keep/files/pkg-message.in44
-rw-r--r--sysutils/py-keep/pkg-descr10
6 files changed, 109 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index e24e970733af..af4945dd52d1 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1073,6 +1073,7 @@
SUBDIR += py-iowait
SUBDIR += py-ioztat
SUBDIR += py-jailconf
+ SUBDIR += py-keep
SUBDIR += py-leviathan
SUBDIR += py-liquidctl
SUBDIR += py-mitogen
diff --git a/sysutils/py-keep/Makefile b/sysutils/py-keep/Makefile
new file mode 100644
index 000000000000..673d870a486a
--- /dev/null
+++ b/sysutils/py-keep/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= keep
+PORTVERSION= 2.10.1
+CATEGORIES= sysutils python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= DtxdF@riseup.net
+COMMENT= Personal shell command keeper
+
+LICENSE= MIT
+LICENSE_FILE= ${FILESDIR}/LICENSE.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>0:devel/py-click@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}terminaltables>0:textproc/py-terminaltables@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygithub>0:devel/py-pygithub@${PY_FLAVOR}
+
+USES= python:3.8+
+USE_PYTHON= autoplist distutils
+
+SUB_FILES= pkg-message
+
+PORTDATA= completions/keep.zsh \
+ completions/keep.bash
+
+post-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}/completions
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDATA} ${STAGEDIR}${DATADIR}/completions)
+
+.include <bsd.port.mk>
diff --git a/sysutils/py-keep/distinfo b/sysutils/py-keep/distinfo
new file mode 100644
index 000000000000..a153fabd8900
--- /dev/null
+++ b/sysutils/py-keep/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1660836731
+SHA256 (keep-2.10.1.tar.gz) = 3abbe445347711cecd9cbb80dab4a0777418972fc14a14e9387d0d2ae4b6adb7
+SIZE (keep-2.10.1.tar.gz) = 13044
diff --git a/sysutils/py-keep/files/LICENSE.md b/sysutils/py-keep/files/LICENSE.md
new file mode 100644
index 000000000000..07b451f45970
--- /dev/null
+++ b/sysutils/py-keep/files/LICENSE.md
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Himanshu Mishra
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/sysutils/py-keep/files/pkg-message.in b/sysutils/py-keep/files/pkg-message.in
new file mode 100644
index 000000000000..dcea9096f587
--- /dev/null
+++ b/sysutils/py-keep/files/pkg-message.in
@@ -0,0 +1,44 @@
+[
+{
+ type: install
+ message: <<EOM
+keep was installed and there are some notes:
+
+1. To enable command-line completion (TAB completion) follow these steps for
+ the shell of your choice:
+
+ bash instructions:
+
+ 1. Create a directory in your home directory called .bash
+
+ mkdir -p ~/.bash
+
+ 2. Copy %%DATADIR%%/completions/keep.bash to ~/.bash/keep
+
+ cp %%DATADIR%%/completions/keep.bash ~/.bash/keep
+
+ 3. Add the following lines to ~/.bash_profile file
+
+ [ -f "$HOME/.bash/keep" ] && . "$HOME/.bash/keep"
+
+ zsh instructions:
+
+ 1. Create a directory in your home called .zsh
+
+ mkdir -p ~/.zsh
+
+ 2. Copy %%DATADIR%%/completions/keep.zsh to ~/.zsh/_keep
+
+ cp %%DATADIR%%/completions/keep.zsh ~/.zsh/_keep
+
+ 3. Add the following lines inside ~/.zshrc file
+
+ fpath=($HOME/.zsh $fpath)
+ autoload -Uz compinit && compinit
+
+2. See also the official keep tutorial:
+
+ * https://github.com/OrkoHunter/keep/blob/master/tutorial.md
+EOM
+}
+]
diff --git a/sysutils/py-keep/pkg-descr b/sysutils/py-keep/pkg-descr
new file mode 100644
index 000000000000..582f49a64ab3
--- /dev/null
+++ b/sysutils/py-keep/pkg-descr
@@ -0,0 +1,10 @@
+keep is a Meta CLI Toolkit that provides a personal shell command
+keeper with some useful features:
+
+* Save a new command with a brief description
+* Search the saved commands using powerful patterns
+* Save the commands as a secret GitHub gist
+* Use keep push and keep pull to sync the commands between GitHub
+ gist and other computers.
+
+WWW: https://github.com/OrkoHunter/keep