aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 20:44:26 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 20:48:27 +0000
commitdc37cfca2d9fae66c3b4df647e400ca46fd0453b (patch)
tree4024cf43a0585f158b4e9b7b7afc697b687d9e14
parent69887310e9ab5a3b6b7ee2ba1e6e644e8468bf42 (diff)
downloadports-dc37cfca2d9fae66c3b4df647e400ca46fd0453b.tar.gz
ports-dc37cfca2d9fae66c3b4df647e400ca46fd0453b.zip
lang/ghc: add NO_CCACHE=yes
This fixes the following build error with ccache (probably caused by CCACHE_DIR not propagated through the build properly): [1 of 1] Compiling Main ( Setup.hs, Setup.o ) ccache: error: Failed to create directory /nonexistent/.ccache/6/3: Permission denied `clang' failed in phase `Assembler'. (Exit code: 1) Approved by: portmgr blanket
-rw-r--r--lang/ghc/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/lang/ghc/Makefile b/lang/ghc/Makefile
index d0dc718a5830..6d2f987eee0d 100644
--- a/lang/ghc/Makefile
+++ b/lang/ghc/Makefile
@@ -25,6 +25,7 @@ USE_PERL5= build
GNU_CONFIGURE= yes
CONFIGURE_ENV= PATH=${SLAVES_PREFIX}/bin:${PATH}
MAKE_ENV= PATH=${SLAVES_PREFIX}/bin:${PATH}
+NO_CCACHE= yes
SUB_FILES= build.mk
SUB_LIST= GHC_VERSION=${GHC_VERSION} \