aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 14:03:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2021-11-17 20:47:25 +0000
commit69887310e9ab5a3b6b7ee2ba1e6e644e8468bf42 (patch)
tree76b8f2346e286b3e7acdc495aed2353d9153c088
parentc4d00da330ffa3ea2745072c4b84dca9bb8c60fd (diff)
downloadports-69887310e9ab5a3b6b7ee2ba1e6e644e8468bf42.tar.gz
ports-69887310e9ab5a3b6b7ee2ba1e6e644e8468bf42.zip
textproc/py-pystemmer: fix build with cython 3.x
The port builds fine with cython 3.x (upcoming cython-devel), which is currently the only option with (upcoming) python 3.11. Remove the needless version limitation which breaks the build. PR: 259899 Approved by: dbaio (maintainer)
-rw-r--r--textproc/py-pystemmer/files/patch-setup.py11
1 files changed, 11 insertions, 0 deletions
diff --git a/textproc/py-pystemmer/files/patch-setup.py b/textproc/py-pystemmer/files/patch-setup.py
new file mode 100644
index 000000000000..8848a3a06110
--- /dev/null
+++ b/textproc/py-pystemmer/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-07-15 11:49:38 UTC
++++ setup.py
+@@ -187,7 +187,7 @@ setup(name='PyStemmer',
+ "Topic :: Text Processing :: Indexing",
+ "Topic :: Text Processing :: Linguistic",
+ ],
+- setup_requires=['Cython>=0.28.5,<1.0', 'setuptools>=18.0'],
++ setup_requires=['Cython>=0.28.5', 'setuptools>=18.0'],
+ ext_modules=[
+ Extension(
+ 'Stemmer',