aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 13:02:35 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 15:10:20 +0000
commitde9c50e72c3542c29b9a12aecb9f736bc3cf45e5 (patch)
tree51316f5354a6f919f4661d04f6115e037f791ba8
parente717a9367f81224bf402a7b739d9b0e4a06c390b (diff)
downloadports-de9c50e72c3542c29b9a12aecb9f736bc3cf45e5.tar.gz
ports-de9c50e72c3542c29b9a12aecb9f736bc3cf45e5.zip
net/pacemaker1: Remove PYTHON_SUFFIX Conditionals
At the moment the minimum supported Python version is 3.8 and later so remove the PYTHON_SUFFIX conditionals for greater than version 3.6 as all version satisfies this conditions. Approved by: portmgr (blanket)
-rw-r--r--net/pacemaker1/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/net/pacemaker1/Makefile b/net/pacemaker1/Makefile
index 0ed8bdd696c3..b978cea40f88 100644
--- a/net/pacemaker1/Makefile
+++ b/net/pacemaker1/Makefile
@@ -22,6 +22,9 @@ SHEBANG_FILES+= cts/cts \
REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
+EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cts_remote.py \
+ ${PATCHDIR}/extra-patch-cts_watcher.py
+
.include <bsd.port.pre.mk>
# Fix building it with clang 11
@@ -29,11 +32,6 @@ REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
CFLAGS+= -fcommon
.endif
-.if ${PYTHON_SUFFIX} > 36
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-cts_remote.py \
- ${PATCHDIR}/extra-patch-cts_watcher.py
-.endif
-
post-patch: post-patch-common
@${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_failcount
@${REINPLACE_CMD} ${REPLACE_ARGS_GETOPT} ${WRKSRC}/tools/crm_master