aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-02-13 09:06:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-02-13 09:10:51 +0000
commitdf3fb512fa9ccd21b0fa5129e68c97875bd487ec (patch)
tree6cff5c2d35ac311482f1f36c083f7e02cc0cb372
parent0339e00c364b887ae2bfc544d12049996289e9f7 (diff)
downloadports-df3fb512fa9ccd21b0fa5129e68c97875bd487ec.tar.gz
ports-df3fb512fa9ccd21b0fa5129e68c97875bd487ec.zip
math/py-py-find-1st: New port: Numpy extension module for efficient search in numpy arrays
-rw-r--r--math/Makefile1
-rw-r--r--math/py-py-find-1st/Makefile27
-rw-r--r--math/py-py-find-1st/distinfo3
-rw-r--r--math/py-py-find-1st/files/patch-pyproject.toml7
-rw-r--r--math/py-py-find-1st/pkg-descr3
5 files changed, 41 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 570bf14101ef..4c85273b1d0b 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -983,6 +983,7 @@
SUBDIR += py-pplpy
SUBDIR += py-primecountpy
SUBDIR += py-primme
+ SUBDIR += py-py-find-1st
SUBDIR += py-pyFFTW
SUBDIR += py-pyaudi
SUBDIR += py-pybloom
diff --git a/math/py-py-find-1st/Makefile b/math/py-py-find-1st/Makefile
new file mode 100644
index 000000000000..85ece5c35c69
--- /dev/null
+++ b/math/py-py-find-1st/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= py-find-1st
+DISTVERSION= 1.1.5
+CATEGORIES= math
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:S/-/_/g}-${PORTVERSION}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Numpy extension module for efficient search in numpy arrays
+WWW= https://github.com/roebel/py_find_1st
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=46.4.0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYNUMPY} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>0:devel/py-wheel@${PY_FLAVOR}
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python:3.6+
+USE_PYTHON= pep517 autoplist pytest # tests are broken, see https://github.com/roebel/py_find_1st/issues/13
+
+TEST_ENV= ${MAKE_ENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/utils_find_1st/find_1st${PYTHON_EXT_SUFFIX}.so
+
+.include <bsd.port.mk>
diff --git a/math/py-py-find-1st/distinfo b/math/py-py-find-1st/distinfo
new file mode 100644
index 000000000000..a63d2f99a5f6
--- /dev/null
+++ b/math/py-py-find-1st/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1676278342
+SHA256 (py_find_1st-1.1.5.tar.gz) = f99207bc83df361c4cd9c6c2aaf504907ffce7fdd33ae3d3cbf39c68a4f1c1a9
+SIZE (py_find_1st-1.1.5.tar.gz) = 8807
diff --git a/math/py-py-find-1st/files/patch-pyproject.toml b/math/py-py-find-1st/files/patch-pyproject.toml
new file mode 100644
index 000000000000..8949cd0b2e61
--- /dev/null
+++ b/math/py-py-find-1st/files/patch-pyproject.toml
@@ -0,0 +1,7 @@
+--- pyproject.toml.orig 2023-02-13 08:53:21 UTC
++++ pyproject.toml
+@@ -1,3 +1,3 @@
+ [build-system]
+ # Minimum requirements for the build system to execute.
+-requires = ["setuptools", "oldest-supported-numpy", "wheel"] # PEP 508 specifications.
++requires = ["setuptools", "numpy", "wheel"] # PEP 508 specifications.
diff --git a/math/py-py-find-1st/pkg-descr b/math/py-py-find-1st/pkg-descr
new file mode 100644
index 000000000000..6f29ac67068f
--- /dev/null
+++ b/math/py-py-find-1st/pkg-descr
@@ -0,0 +1,3 @@
+py_find_1st is a numpy extension that allows to find the first index into an
+1D-array that validates a boolean condition that can consist of a comparison
+operator and a limit value.