aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNuno Teixeira <eduardo@FreeBSD.org>2024-05-20 08:19:39 +0000
committerNuno Teixeira <eduardo@FreeBSD.org>2024-05-20 08:26:30 +0000
commitfd9d600305e5138654fe44e166b6fd31174a7847 (patch)
tree3f03d859dd8a8ee6e70e335a3434e7b291fc47f8
parent04d1c509299c344b6492dc4c691ad8cd29e3efff (diff)
downloadports-fd9d600305e5138654fe44e166b6fd31174a7847.tar.gz
ports-fd9d600305e5138654fe44e166b6fd31174a7847.zip
audio/cmus: Fix build when Input and Output plugin options are empty
Use find to strip .so if exist, i.e., if Input or Output plugins options where selected. This fixes post-install when no plugins are selected.
-rw-r--r--audio/cmus/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/audio/cmus/Makefile b/audio/cmus/Makefile
index 519bd70a8486..2e92285cd7e4 100644
--- a/audio/cmus/Makefile
+++ b/audio/cmus/Makefile
@@ -150,7 +150,8 @@ post-configure:
post-install:
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/cmus*
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/cmus/[io]p/*.so
+ @${FIND} ${STAGEDIR}${PREFIX}/lib -path '${STAGEDIR}${PREFIX}/lib/cmus/*' \
+ -name '*.so*' -exec ${STRIP_CMD} {} +
# Install bash and zsh completion files
${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_DATA} ${WRKSRC}/contrib/cmus.bash-completion \