aboutsummaryrefslogtreecommitdiff
path: root/archivers/ark/Makefile
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2021-10-11 14:53:15 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2021-10-11 14:57:51 +0000
commita90e961f4d19d53621612d1257a77a5635906ee0 (patch)
treeb22d551c6e4b218b366906c3b16594e742c6b7ee /archivers/ark/Makefile
parentc5420e877724ce867a6f8bcd98c613bb9af9e6e4 (diff)
downloadports-a90e961f4d19d53621612d1257a77a5635906ee0.tar.gz
ports-a90e961f4d19d53621612d1257a77a5635906ee0.zip
*/*: Avoid extra CPE_VENDOR=kde by properly sorting USES
CPE_VENDOR=kde is already set in Uses/kde.mk so adding cpe after kde in our USES line makes sure that it's picked up properly. Approved by: portmgr (blanket)
Diffstat (limited to 'archivers/ark/Makefile')
-rw-r--r--archivers/ark/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index fc8f6caa7ad9..bc61c9864283 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -8,8 +8,8 @@ COMMENT= Archiving tool for KDE
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext libarchive kde:5 \
- qt:5 shared-mime-info tar:xz
+USES= cmake compiler:c++11-lang desktop-file-utils gettext libarchive kde:5 \
+ cpe qt:5 shared-mime-info tar:xz
USE_KDE= archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons doctools i18n iconthemes \
itemmodels itemviews jobwidgets khtml kio parts pty service \
@@ -19,7 +19,6 @@ USE_QT= concurrent core dbus gui network widgets xml \
buildtools_build qmake_build
USE_LDCONFIG= yes
-CPE_VENDOR= kde
OPTIONS_DEFINE= 7ZIP RAR ZIP DOCS
OPTIONS_DEFAULT= 7ZIP ZIP DOCS