aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2024-06-19 02:31:53 +0000
committerWen Heping <wen@FreeBSD.org>2024-06-19 05:34:06 +0000
commit0015adf8aaf20e090dcf8cba8c66288d1932c384 (patch)
tree28f5fd079bb51db338e7aef87082a618bbfc3c31
parent3e6569495346505b35035d2ffadab0aa64b160ae (diff)
downloadports-0015adf8aaf20e090dcf8cba8c66288d1932c384.tar.gz
ports-0015adf8aaf20e090dcf8cba8c66288d1932c384.zip
lang/nim: Update to 2.0.6
PR: 279832 Reported by: ports@nicandneal.net(maintainer)
-rw-r--r--lang/nim/Makefile2
-rw-r--r--lang/nim/distinfo6
-rw-r--r--lang/nim/files/patch-koch.nim42
3 files changed, 29 insertions, 21 deletions
diff --git a/lang/nim/Makefile b/lang/nim/Makefile
index 3dc392565732..1fe4a63d97ee 100644
--- a/lang/nim/Makefile
+++ b/lang/nim/Makefile
@@ -1,5 +1,5 @@
PORTNAME= nim
-DISTVERSION= 2.0.4
+DISTVERSION= 2.0.6
CATEGORIES= lang
MASTER_SITES= https://nim-lang.org/download/
diff --git a/lang/nim/distinfo b/lang/nim/distinfo
index a140b9864a9e..3db7bb31f01d 100644
--- a/lang/nim/distinfo
+++ b/lang/nim/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1713362683
-SHA256 (nim-2.0.4.tar.xz) = 71526bd07439dc8e378fa1a6eb407eda1298f1f3d4df4476dca0e3ca3cbe3f09
-SIZE (nim-2.0.4.tar.xz) = 7620508
+TIMESTAMP = 1718761713
+SHA256 (nim-2.0.6.tar.xz) = fbcd5d731743adec2b3bb9bcf6f5fd993ed11b250f957166bebf328f307cba6a
+SIZE (nim-2.0.6.tar.xz) = 7668088
diff --git a/lang/nim/files/patch-koch.nim b/lang/nim/files/patch-koch.nim
index 87fb31e33dfb..bf06daa94b6d 100644
--- a/lang/nim/files/patch-koch.nim
+++ b/lang/nim/files/patch-koch.nim
@@ -1,6 +1,6 @@
---- koch.nim.orig 2023-08-01 01:01:01 UTC
+--- koch.nim.orig 2024-06-18 13:26:19 UTC
+++ koch.nim
-@@ -145,28 +145,28 @@ proc csource(args: string) =
+@@ -146,30 +146,30 @@ proc csource(args: string) =
"--main:compiler/nim.nim compiler/installer.ini $1") %
[args, VersionAsString, compileNimInst])
@@ -19,18 +19,22 @@
- commit = commit, allowBundled = true)
- cloneDependency(distDir / "nimble" / distDir, "https://github.com/nim-lang/checksums.git",
- commit = ChecksumsStableCommit, allowBundled = true) # or copy it from dist?
+- cloneDependency(distDir / "nimble" / distDir, "https://github.com/nim-lang/sat.git",
+- commit = SatStableCommit, allowBundled = true)
- # installer.ini expects it under $nim/bin
- nimCompile("dist/nimble/src/nimble.nim",
-- options = "-d:release --mm:refc --noNimblePath " & args)
+- options = "-d:release -d:nimNimbleBootstrap --mm:refc --noNimblePath " & args)
+#proc bundleNimbleExe(latest: bool, args: string) =
+# let commit = if latest: "HEAD" else: NimbleStableCommit
+# cloneDependency(distDir, "https://github.com/nim-lang/nimble.git",
+# commit = commit, allowBundled = true)
+# cloneDependency(distDir / "nimble" / distDir, "https://github.com/nim-lang/checksums.git",
+# commit = ChecksumsStableCommit, allowBundled = true) # or copy it from dist?
++# cloneDependency(distDir / "nimble" / distDir, "https://github.com/nim-lang/sat.git",
++# commit = SatStableCommit, allowBundled = true)
+# # installer.ini expects it under $nim/bin
+# nimCompile("dist/nimble/src/nimble.nim",
-+# options = "-d:release --mm:refc --noNimblePath " & args)
++# options = "-d:release -d:nimNimbleBootstrap --mm:refc --noNimblePath " & args)
-proc bundleAtlasExe(latest: bool, args: string) =
- let commit = if latest: "HEAD" else: AtlasStableCommit
@@ -49,7 +53,7 @@
proc bundleNimsuggest(args: string) =
nimCompileFold("Compile nimsuggest", "nimsuggest/nimsuggest.nim",
-@@ -203,8 +203,8 @@ proc bundleChecksums(latest: bool) =
+@@ -206,8 +206,8 @@ proc zip(latest: bool; args: string) =
proc zip(latest: bool; args: string) =
bundleChecksums(latest)
@@ -60,7 +64,7 @@
bundleNimsuggest(args)
bundleNimpretty(args)
bundleWinTools(args)
-@@ -213,15 +213,15 @@ proc zip(latest: bool; args: string) =
+@@ -216,15 +216,15 @@ proc zip(latest: bool; args: string) =
exec("$# --var:version=$# --var:mingw=none --main:compiler/nim.nim zip compiler/installer.ini" %
["tools/niminst/niminst".exe, VersionAsString])
@@ -83,7 +87,7 @@
nimexec("cc -r $2 --var:version=$1 --var:mingw=none --main:compiler/nim.nim scripts compiler/installer.ini" %
[VersionAsString, compileNimInst])
exec("$# --var:version=$# --var:mingw=none --main:compiler/nim.nim xz compiler/installer.ini" %
-@@ -257,8 +257,8 @@ proc testTools(args: string = "") =
+@@ -260,8 +260,8 @@ proc nsis(latest: bool; args: string) =
proc nsis(latest: bool; args: string) =
bundleChecksums(latest)
@@ -94,7 +98,7 @@
bundleNimsuggest(args)
bundleWinTools(args)
# make sure we have generated the niminst executables:
-@@ -521,42 +521,42 @@ proc icTest(args: string) =
+@@ -524,43 +524,43 @@ proc icTest(args: string) =
exec(cmd)
inc i
@@ -147,25 +151,29 @@
[hostOS, hostCPU, $int.sizeof, $float.sizeof, $cpuEndian, getCurrentDir()]
-proc installDeps(dep: string, commit = "") =
-+#proc installDeps(dep: string, commit = "") =
- # the hashes/urls are version controlled here, so can be changed seamlessly
- # and tied to a nim release (mimicking git submodules)
+- # the hashes/urls are version controlled here, so can be changed seamlessly
+- # and tied to a nim release (mimicking git submodules)
- var commit = commit
- case dep
- of "tinyc":
- if commit.len == 0: commit = "916cc2f94818a8a382dd8d4b8420978816c1dfb3"
- cloneDependency(distDir, "https://github.com/timotheecour/nim-tinyc-archive", commit)
- else: doAssert false, "unsupported: " & dep
+- # xxx: also add linenoise, niminst etc, refs https://github.com/nim-lang/RFCs/issues/206
++#proc installDeps(dep: string, commit = "") =
++# # the hashes/urls are version controlled here, so can be changed seamlessly
++# # and tied to a nim release (mimicking git submodules)
+# var commit = commit
+# case dep
-+ #of "tinyc":
-+ # if commit.len == 0: commit = "916cc2f94818a8a382dd8d4b8420978816c1dfb3"
-+ # cloneDependency(distDir, "https://github.com/timotheecour/nim-tinyc-archive", commit)
++# of "tinyc":
++# if commit.len == 0: commit = "916cc2f94818a8a382dd8d4b8420978816c1dfb3"
++# cloneDependency(distDir, "https://github.com/timotheecour/nim-tinyc-archive", commit)
+# else: doAssert false, "unsupported: " & dep
- # xxx: also add linenoise, niminst etc, refs https://github.com/nim-lang/RFCs/issues/206
++# # xxx: also add linenoise, niminst etc, refs https://github.com/nim-lang/RFCs/issues/206
proc runCI(cmd: string) =
-@@ -679,18 +679,18 @@ proc showHelp(success: bool) =
+ doAssert cmd.len == 0, cmd # avoid silently ignoring
+@@ -682,18 +682,18 @@ proc showHelp(success: bool) =
quit(HelpText % [VersionAsString & spaces(44-len(VersionAsString)),
CompileDate, CompileTime], if success: QuitSuccess else: QuitFailure)
@@ -191,7 +199,7 @@
localDocsOut = ""
skipIntegrityCheck = false
while true:
-@@ -726,34 +726,34 @@ when isMainModule:
+@@ -729,34 +729,34 @@ when isMainModule:
of "distrohelper": geninstall()
of "install": install(op.cmdLineRest)
of "testinstall": testUnixInstall(op.cmdLineRest)