aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2023-04-29 00:48:09 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2023-04-29 00:49:26 +0000
commit001b0bc7688ef745086d9a48eb4ccbafa1b33a93 (patch)
treef46ac61cba8d8f56f32e1f5fad6ede230cc5ab9e
parent11b7aa935a3eaf34aa6ec0d581e916f4f080893a (diff)
downloadports-001b0bc7688ef745086d9a48eb4ccbafa1b33a93.tar.gz
ports-001b0bc7688ef745086d9a48eb4ccbafa1b33a93.zip
security/boringssl: fix test target
While I'm here regenerate patches and update package description to make portlint(1) happy. Bump PORTREVISION.
-rw-r--r--security/boringssl/Makefile20
-rw-r--r--security/boringssl/distinfo26
-rw-r--r--security/boringssl/files/patch-crypto_CMakeLists.txt6
-rw-r--r--security/boringssl/files/patch-ssl_CMakeLists.txt6
-rw-r--r--security/boringssl/pkg-descr7
5 files changed, 42 insertions, 23 deletions
diff --git a/security/boringssl/Makefile b/security/boringssl/Makefile
index d3e90ae7611a..2d1f80f66871 100644
--- a/security/boringssl/Makefile
+++ b/security/boringssl/Makefile
@@ -1,6 +1,17 @@
PORTNAME= boringssl
PORTVERSION= 0.0.0.0.2023.04.26.01
+PORTREVISION= 1
CATEGORIES= security
+MASTER_SITES+= https://proxy.golang.org/:gomods
+DISTFILES+= golang.org/x/crypto/@v/v0.6.0.zip:gomods \
+ golang.org/x/crypto/@v/v0.6.0.mod:gomods \
+ golang.org/x/net/@v/v0.7.0.zip:gomods \
+ golang.org/x/net/@v/v0.7.0.mod:gomods \
+ golang.org/x/sys/@v/v0.5.0.zip:gomods \
+ golang.org/x/sys/@v/v0.5.0.mod:gomods \
+ golang.org/x/term/@v/v0.5.0.zip:gomods \
+ golang.org/x/term/@v/v0.5.0.mod:gomods
+EXTRACT_ONLY= ${GH_ACCOUNT}-${PORTNAME}-${PORTVERSION}-${GH_TAGNAME}_GH0.tar.gz
MAINTAINER= osa@FreeBSD.org
COMMENT= Fork of OpenSSL
@@ -19,18 +30,13 @@ CPE_VENDOR= google
USE_GITHUB= yes
GH_ACCOUNT= google
GH_TAGNAME= a02b743
-GH_TUPLE= golang:crypto:v0.6.0:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:v0.7.0:golang_net/vendor/golang.org/x/net \
- golang:sys:v0.5.0:golang_sys/vendor/golang.org/x/sys \
- golang:term:v0.5.0:golang_term/vendor/golang.org/x/term
CMAKE_ARGS+= -DBUILD_SHARED_LIBS=1 \
-DCMAKE_BUILD_TYPE=Release
USE_LDCONFIG= yes
LDFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
TEST_TARGET= run_tests
-MAKE_ENV+= GOFLAGS=-mod=mod \
- GOPATH=${WRKSRC}/vendor \
- GOPROXY=off
+MAKE_ENV+= GOFLAGS=-mod=readonly \
+ GOPROXY=file://${DISTDIR}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/tool/bssl ${STAGEDIR}${PREFIX}/bin/
diff --git a/security/boringssl/distinfo b/security/boringssl/distinfo
index 747f6e6a14a5..573594c2c370 100644
--- a/security/boringssl/distinfo
+++ b/security/boringssl/distinfo
@@ -1,11 +1,19 @@
-TIMESTAMP = 1682628690
+TIMESTAMP = 1682726879
+SHA256 (golang.org/x/crypto/@v/v0.6.0.zip) = 81ca88af371cff5a84442ba28e23d8f42ccc1387c8fe152e55e87ba4af9e1ac7
+SIZE (golang.org/x/crypto/@v/v0.6.0.zip) = 1761232
+SHA256 (golang.org/x/crypto/@v/v0.6.0.mod) = 1b6a683455a3b882b6ac53f22752960e87bd91040a94d6f2c5cb61261e2389d8
+SIZE (golang.org/x/crypto/@v/v0.6.0.mod) = 171
+SHA256 (golang.org/x/net/@v/v0.7.0.zip) = 060552064526a90ac9b0bdce2ba0ab34592decc9428d1441c3c9722f853cd290
+SIZE (golang.org/x/net/@v/v0.7.0.zip) = 1559354
+SHA256 (golang.org/x/net/@v/v0.7.0.mod) = 41ec76ea2172f3ee3031e38f9a535939a584d6bb35ef480854fdcb8c2026701b
+SIZE (golang.org/x/net/@v/v0.7.0.mod) = 123
+SHA256 (golang.org/x/sys/@v/v0.5.0.zip) = cf47336ac1bf675fa6d6dd5ac5399b0143c513404c449fa3f3380a58123c7908
+SIZE (golang.org/x/sys/@v/v0.5.0.zip) = 1886681
+SHA256 (golang.org/x/sys/@v/v0.5.0.mod) = f033333096fe198f3151deed93f2deba74e50bbfe7739134045bc3b7ce4a5024
+SIZE (golang.org/x/sys/@v/v0.5.0.mod) = 33
+SHA256 (golang.org/x/term/@v/v0.5.0.zip) = 7d89c49ab41306950128a0f4b7c67fb8e2d2f637ece8e024e6cf38d17a33193b
+SIZE (golang.org/x/term/@v/v0.5.0.zip) = 19924
+SHA256 (golang.org/x/term/@v/v0.5.0.mod) = 0d6f58228aadc1a6528e6755da018516566e3ae5c5201f7ade1773f56fa8d934
+SIZE (golang.org/x/term/@v/v0.5.0.mod) = 67
SHA256 (google-boringssl-0.0.0.0.2023.04.26.01-a02b743_GH0.tar.gz) = 554f4146ab282beb07cd5b4ca260b68adcbbeb81145443a74984ad55d7d9ff95
SIZE (google-boringssl-0.0.0.0.2023.04.26.01-a02b743_GH0.tar.gz) = 32280592
-SHA256 (golang-crypto-v0.6.0_GH0.tar.gz) = abdd55e246751307493aac73d787c38953814668cf13a3dd73b600050e7b5058
-SIZE (golang-crypto-v0.6.0_GH0.tar.gz) = 1633588
-SHA256 (golang-net-v0.7.0_GH0.tar.gz) = 4949a0dbdd3c200c8681c18bebd65c8e8b620470189361dac05c89c714d9a59b
-SIZE (golang-net-v0.7.0_GH0.tar.gz) = 1241017
-SHA256 (golang-sys-v0.5.0_GH0.tar.gz) = 810c8f1b7704674971ab6b2b614aba20a5a1765018fd2c639f528dbbcbf88b1f
-SIZE (golang-sys-v0.5.0_GH0.tar.gz) = 1429723
-SHA256 (golang-term-v0.5.0_GH0.tar.gz) = a363183f934f45cb7a0b2fef46105e3e1983cd56bb3070a1a8b227e3276c74d3
-SIZE (golang-term-v0.5.0_GH0.tar.gz) = 14799
diff --git a/security/boringssl/files/patch-crypto_CMakeLists.txt b/security/boringssl/files/patch-crypto_CMakeLists.txt
index 2e772b4f50bb..6af61b5e7a9e 100644
--- a/security/boringssl/files/patch-crypto_CMakeLists.txt
+++ b/security/boringssl/files/patch-crypto_CMakeLists.txt
@@ -1,6 +1,6 @@
---- crypto/CMakeLists.txt.orig 2023-02-17 15:48:48.305900000 -0500
-+++ crypto/CMakeLists.txt 2023-02-17 15:48:53.117159000 -0500
-@@ -423,3 +423,5 @@
+--- crypto/CMakeLists.txt.orig 2023-04-26 21:06:18 UTC
++++ crypto/CMakeLists.txt
+@@ -426,3 +426,5 @@ add_executable(
)
target_link_libraries(crypto_test test_support_lib boringssl_gtest_main crypto)
add_dependencies(all_tests crypto_test)
diff --git a/security/boringssl/files/patch-ssl_CMakeLists.txt b/security/boringssl/files/patch-ssl_CMakeLists.txt
index 848ebf9197b7..e87e3fb40496 100644
--- a/security/boringssl/files/patch-ssl_CMakeLists.txt
+++ b/security/boringssl/files/patch-ssl_CMakeLists.txt
@@ -1,6 +1,6 @@
---- ssl/CMakeLists.txt.orig 2023-02-17 15:49:44.924011000 -0500
-+++ ssl/CMakeLists.txt 2023-02-17 15:49:50.939101000 -0500
-@@ -55,3 +55,5 @@
+--- ssl/CMakeLists.txt.orig 2023-04-26 21:06:18 UTC
++++ ssl/CMakeLists.txt
+@@ -55,3 +55,5 @@ add_executable(
)
target_link_libraries(ssl_test test_support_lib boringssl_gtest_main ssl crypto)
add_dependencies(all_tests ssl_test)
diff --git a/security/boringssl/pkg-descr b/security/boringssl/pkg-descr
index 1980d187b860..49a33d47a3ac 100644
--- a/security/boringssl/pkg-descr
+++ b/security/boringssl/pkg-descr
@@ -1 +1,6 @@
-Fork of OpenSSL that is designed to meet Google's needs
+Fork of OpenSSL that is designed to meet Google's needs.
+
+Although BoringSSL is an open source project, it is not intended for general
+use, as OpenSSL is. We don't recommend that third parties depend upon it.
+Doing so is likely to be frustrating because there are no guarantees of API
+or ABI stability.