aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:17:10 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-07-09 10:17:10 +0000
commit002cc383592964c949ce96603c2880040a46fa53 (patch)
tree7d4f38dc083870fe700c5a2a15d51f435aadf863
parent7545ae6089623e762d2c88ac5bf1aa4c0d626679 (diff)
downloadports-002cc383592964c949ce96603c2880040a46fa53.tar.gz
ports-002cc383592964c949ce96603c2880040a46fa53.zip
graphics/geos: Update to 3.12.0
- Use USES=pathfix to fix .pc installation Changes: https://github.com/libgeos/geos/releases
-rw-r--r--graphics/geos/Makefile4
-rw-r--r--graphics/geos/distinfo6
-rw-r--r--graphics/geos/pkg-plist53
3 files changed, 44 insertions, 19 deletions
diff --git a/graphics/geos/Makefile b/graphics/geos/Makefile
index 8597d2a383f5..a75cdc7017b4 100644
--- a/graphics/geos/Makefile
+++ b/graphics/geos/Makefile
@@ -1,5 +1,5 @@
PORTNAME= geos
-PORTVERSION= 3.11.2
+PORTVERSION= 3.12.0
CATEGORIES= graphics geography
MASTER_SITES= https://download.osgeo.org/geos/ \
https://github.com/libgeos/geos/releases/download/${PORTVERSION}/
@@ -12,7 +12,7 @@ WWW= https://libgeos.org/ \
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= cmake compiler:c++11-lang tar:bzip2
+USES= cmake compiler:c++14-lang pathfix tar:bzip2
CMAKE_OFF= BUILD_BENCHMARKS DISABLE_GEOS_INLINE
CMAKE_ON= BUILD_SHARED_LIBS
diff --git a/graphics/geos/distinfo b/graphics/geos/distinfo
index 473909c27ca1..19336dd792f8 100644
--- a/graphics/geos/distinfo
+++ b/graphics/geos/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1679498532
-SHA256 (geos-3.11.2.tar.bz2) = b1f077669481c5a3e62affc49e96eb06f281987a5d36fdab225217e5b825e4cc
-SIZE (geos-3.11.2.tar.bz2) = 6774288
+TIMESTAMP = 1688166060
+SHA256 (geos-3.12.0.tar.bz2) = d96db96011259178a35555a0f6d6e75a739e52a495a6b2aa5efb3d75390fbc39
+SIZE (geos-3.12.0.tar.bz2) = 6736650
diff --git a/graphics/geos/pkg-plist b/graphics/geos/pkg-plist
index 9730bd2ef15e..88c6fe8f65b9 100644
--- a/graphics/geos/pkg-plist
+++ b/graphics/geos/pkg-plist
@@ -13,9 +13,11 @@ include/geos/algorithm/HCoordinate.h
include/geos/algorithm/InteriorPointArea.h
include/geos/algorithm/InteriorPointLine.h
include/geos/algorithm/InteriorPointPoint.h
+include/geos/algorithm/Interpolate.h
include/geos/algorithm/Intersection.h
include/geos/algorithm/Length.h
include/geos/algorithm/LineIntersector.h
+include/geos/algorithm/MinimumAreaRectangle.h
include/geos/algorithm/MinimumBoundingCircle.h
include/geos/algorithm/MinimumDiameter.h
include/geos/algorithm/NotRepresentableException.h
@@ -25,7 +27,7 @@ include/geos/algorithm/PointLocation.h
include/geos/algorithm/PointLocator.h
include/geos/algorithm/PolygonNodeTopology.h
include/geos/algorithm/RayCrossingCounter.h
-include/geos/algorithm/RayCrossingCounterDD.h
+include/geos/algorithm/Rectangle.h
include/geos/algorithm/RobustDeterminant.h
include/geos/algorithm/SimplePointInRing.h
include/geos/algorithm/construct/LargestEmptyCircle.h
@@ -42,6 +44,19 @@ include/geos/algorithm/locate/IndexedPointInAreaLocator.h
include/geos/algorithm/locate/PointOnGeometryLocator.h
include/geos/algorithm/locate/SimplePointInAreaLocator.h
include/geos/constants.h
+include/geos/coverage/Corner.h
+include/geos/coverage/CoverageBoundarySegmentFinder.h
+include/geos/coverage/CoverageEdge.h
+include/geos/coverage/CoverageGapFinder.h
+include/geos/coverage/CoveragePolygonValidator.h
+include/geos/coverage/CoverageRing.h
+include/geos/coverage/CoverageRingEdges.h
+include/geos/coverage/CoverageSimplifier.h
+include/geos/coverage/CoverageUnion.h
+include/geos/coverage/CoverageValidator.h
+include/geos/coverage/InvalidSegmentDetector.h
+include/geos/coverage/TPVWSimplifier.h
+include/geos/coverage/VertexRingCounter.h
include/geos/edgegraph/EdgeGraph.h
include/geos/edgegraph/EdgeGraphBuilder.h
include/geos/edgegraph/HalfEdge.h
@@ -49,17 +64,14 @@ include/geos/edgegraph/MarkHalfEdge.h
include/geos/export.h
include/geos/geom.h
include/geos/geom/Coordinate.h
-include/geos/geom/CoordinateArraySequence.h
-include/geos/geom/CoordinateArraySequenceFactory.h
include/geos/geom/CoordinateFilter.h
include/geos/geom/CoordinateList.h
include/geos/geom/CoordinateSequence.h
-include/geos/geom/CoordinateSequenceFactory.h
include/geos/geom/CoordinateSequenceFilter.h
-include/geos/geom/DefaultCoordinateSequenceFactory.h
+include/geos/geom/CoordinateSequenceIterator.h
+include/geos/geom/CoordinateSequences.h
include/geos/geom/Dimension.h
include/geos/geom/Envelope.h
-include/geos/geom/FixedSizeCoordinateSequence.h
include/geos/geom/Geometry.h
include/geos/geom/GeometryCollection.h
include/geos/geom/GeometryComponentFilter.h
@@ -193,15 +205,20 @@ include/geos/index/sweepline/SweepLineOverlapAction.h
include/geos/io/ByteOrderDataInStream.h
include/geos/io/ByteOrderValues.h
include/geos/io/CLocalizer.h
+include/geos/io/CheckOrdinatesFilter.h
include/geos/io/GeoJSON.h
include/geos/io/GeoJSONReader.h
include/geos/io/GeoJSONWriter.h
+include/geos/io/OrdinateSet.h
include/geos/io/ParseException.h
include/geos/io/StringTokenizer.h
include/geos/io/WKBConstants.h
include/geos/io/WKBReader.h
+include/geos/io/WKBStreamReader.h
include/geos/io/WKBWriter.h
+include/geos/io/WKTFileReader.h
include/geos/io/WKTReader.h
+include/geos/io/WKTStreamReader.h
include/geos/io/WKTWriter.h
include/geos/io/Writer.h
include/geos/linearref/ExtractLineByLocation.h
@@ -217,6 +234,7 @@ include/geos/linearref/LocationIndexedLine.h
include/geos/math/DD.h
include/geos/namespaces.h
include/geos/noding/BasicSegmentString.h
+include/geos/noding/BoundaryChainNoder.h
include/geos/noding/FastNodingValidator.h
include/geos/noding/FastSegmentSetIntersectionFinder.h
include/geos/noding/GeometryNoder.h
@@ -264,11 +282,22 @@ include/geos/operation/buffer/BufferParameters.h
include/geos/operation/buffer/BufferSubgraph.h
include/geos/operation/buffer/OffsetCurve.h
include/geos/operation/buffer/OffsetCurveBuilder.h
+include/geos/operation/buffer/OffsetCurveSection.h
include/geos/operation/buffer/OffsetSegmentGenerator.h
include/geos/operation/buffer/OffsetSegmentString.h
include/geos/operation/buffer/RightmostEdgeFinder.h
include/geos/operation/buffer/SegmentMCIndex.h
include/geos/operation/buffer/SubgraphDepthLocater.h
+include/geos/operation/cluster/AbstractClusterFinder.h
+include/geos/operation/cluster/Clusters.h
+include/geos/operation/cluster/DBSCANClusterFinder.h
+include/geos/operation/cluster/DisjointOperation.h
+include/geos/operation/cluster/EnvelopeDistanceClusterFinder.h
+include/geos/operation/cluster/EnvelopeIntersectsClusterFinder.h
+include/geos/operation/cluster/GeometryDistanceClusterFinder.h
+include/geos/operation/cluster/GeometryFlattener.h
+include/geos/operation/cluster/GeometryIntersectsClusterFinder.h
+include/geos/operation/cluster/UnionFind.h
include/geos/operation/distance/ConnectedElementLocationFilter.h
include/geos/operation/distance/ConnectedElementPointFilter.h
include/geos/operation/distance/DistanceOp.h
@@ -285,15 +314,9 @@ include/geos/operation/linemerge/LineMergeEdge.h
include/geos/operation/linemerge/LineMergeGraph.h
include/geos/operation/linemerge/LineMerger.h
include/geos/operation/linemerge/LineSequencer.h
-include/geos/operation/overlay/EdgeSetNoder.h
-include/geos/operation/overlay/ElevationMatrix.h
-include/geos/operation/overlay/ElevationMatrixCell.h
-include/geos/operation/overlay/LineBuilder.h
include/geos/operation/overlay/MaximalEdgeRing.h
include/geos/operation/overlay/MinimalEdgeRing.h
include/geos/operation/overlay/OverlayNodeFactory.h
-include/geos/operation/overlay/OverlayOp.h
-include/geos/operation/overlay/PointBuilder.h
include/geos/operation/overlay/PolygonBuilder.h
include/geos/operation/overlay/snap/GeometrySnapper.h
include/geos/operation/overlay/snap/LineStringSnapper.h
@@ -351,6 +374,7 @@ include/geos/operation/relate/RelateOp.h
include/geos/operation/sharedpaths/SharedPathsOp.h
include/geos/operation/union/CascadedPolygonUnion.h
include/geos/operation/union/CoverageUnion.h
+include/geos/operation/union/DisjointSubsetUnion.h
include/geos/operation/union/OverlapUnion.h
include/geos/operation/union/PointGeometryUnion.h
include/geos/operation/union/UnaryUnionOp.h
@@ -362,7 +386,6 @@ include/geos/operation/valid/IsSimpleOp.h
include/geos/operation/valid/IsValidOp.h
include/geos/operation/valid/MakeValid.h
include/geos/operation/valid/PolygonIntersectionAnalyzer.h
-include/geos/operation/valid/PolygonNode.h
include/geos/operation/valid/PolygonRing.h
include/geos/operation/valid/PolygonRingSelfNode.h
include/geos/operation/valid/PolygonRingTouch.h
@@ -396,6 +419,7 @@ include/geos/shape/fractal/MortonCode.h
include/geos/simplify/DouglasPeuckerLineSimplifier.h
include/geos/simplify/DouglasPeuckerSimplifier.h
include/geos/simplify/LineSegmentIndex.h
+include/geos/simplify/LinkedLine.h
include/geos/simplify/LinkedRing.h
include/geos/simplify/PolygonHullSimplifier.h
include/geos/simplify/RingHull.h
@@ -442,6 +466,7 @@ include/geos/util/TopologyException.h
include/geos/util/UniqueCoordinateArrayFilter.h
include/geos/util/UnsupportedOperationException.h
include/geos/util/math.h
+include/geos/util/string.h
include/geos/vend/include_nlohmann_json.hpp
include/geos/vend/json.hpp
include/geos/version.h
@@ -454,5 +479,5 @@ lib/libgeos.so
lib/libgeos.so.%%PORTVERSION%%
lib/libgeos_c.so
lib/libgeos_c.so.1
-lib/libgeos_c.so.1.17.2
+lib/libgeos_c.so.1.18.0
libdata/pkgconfig/geos.pc