aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack <xxjack12xx@gmail.com>2021-04-29 08:59:23 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2021-04-29 09:02:31 +0000
commit004e688b9b4397e626f2850409a73651692852ff (patch)
tree73c8389bd76a5d73f7c7a4b30f3cd96afcb19f45
parent448693e731a7463cff4798da83f58d5096372c2e (diff)
downloadports-004e688b9b4397e626f2850409a73651692852ff.tar.gz
ports-004e688b9b4397e626f2850409a73651692852ff.zip
audio/audacity Upgrade to 3.0.2
PR: 255236
-rw-r--r--audio/audacity/Makefile2
-rw-r--r--audio/audacity/distinfo6
-rw-r--r--audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c12
-rw-r--r--audio/audacity/files/patch-src_ProjectSerializer.cpp60
-rw-r--r--audio/audacity/files/patch-src_import_Import.cpp16
-rw-r--r--audio/audacity/files/patch-src_widgets_FileConfig.cpp11
6 files changed, 4 insertions, 103 deletions
diff --git a/audio/audacity/Makefile b/audio/audacity/Makefile
index a860326b2886..ea72dd752093 100644
--- a/audio/audacity/Makefile
+++ b/audio/audacity/Makefile
@@ -2,7 +2,7 @@
PORTNAME= audacity
DISTVERSIONPREFIX= minsrc-
-DISTVERSION= 3.0.0
+DISTVERSION= 3.0.2
CATEGORIES= audio
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/Audacity-${PORTVERSION}/
diff --git a/audio/audacity/distinfo b/audio/audacity/distinfo
index 4b53733c5ba4..3442dbc6b929 100644
--- a/audio/audacity/distinfo
+++ b/audio/audacity/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1616886054
-SHA256 (audacity-minsrc-3.0.0.tar.xz) = d3bb1358b930ea4ef935ed83cc5a0f47006565762c5667c2fb376c6535876a6a
-SIZE (audacity-minsrc-3.0.0.tar.xz) = 13308836
+TIMESTAMP = 1619066304
+SHA256 (audacity-minsrc-3.0.2.tar.xz) = 728d6459931da006ed45a31e63b7fe6ca47a2547459a2aff3bf0880cef85c296
+SIZE (audacity-minsrc-3.0.2.tar.xz) = 13330160
diff --git a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c b/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c
deleted file mode 100644
index 4bb6881c486d..000000000000
--- a/audio/audacity/files/patch-lib-src_libnyquist_nyquist_xlisp_xlfio.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- lib-src/libnyquist/nyquist/xlisp/xlfio.c.orig 2021-02-04 18:52:51 UTC
-+++ lib-src/libnyquist/nyquist/xlisp/xlfio.c
-@@ -19,8 +19,7 @@
- /* do some sanity checking: */
- #ifndef XL_BIG_ENDIAN
- #ifndef XL_LITTLE_ENDIAN
--#error configuration error -- either XL_BIG_ or XL_LITTLE_ENDIAN must be defined
--in xlisp.h
-+#error configuration error -- either XL_BIG_ or XL_LITTLE_ENDIAN must be defined in xlisp.h
- #endif
- #endif
- #ifdef XL_BIG_ENDIAN
diff --git a/audio/audacity/files/patch-src_ProjectSerializer.cpp b/audio/audacity/files/patch-src_ProjectSerializer.cpp
deleted file mode 100644
index 3e43594c4a59..000000000000
--- a/audio/audacity/files/patch-src_ProjectSerializer.cpp
+++ /dev/null
@@ -1,60 +0,0 @@
---- src/ProjectSerializer.cpp.orig 2021-02-04 18:52:51 UTC
-+++ src/ProjectSerializer.cpp
-@@ -206,9 +206,9 @@ ProjectSerializer::ProjectSerializer(size_t allocSize)
- std::call_once(flag, []{
- // Just once per run, store header information in the unique static
- // dictionary that will be written into each project that is saved.
-- // Store the size of "wxChar" so we can convert during recovery in
-- // case the file is used on a system with a different character size.
-- char size = sizeof(wxChar);
-+ // Store the size of "wxStringCharType" so we can convert during recovery
-+ // in case the file is used on a system with a different character size.
-+ char size = sizeof(wxStringCharType);
- mDict.AppendByte(FT_CharSize);
- mDict.AppendData(&size, 1);
- });
-@@ -242,7 +242,7 @@ void ProjectSerializer::WriteAttr(const wxString & nam
- mBuffer.AppendByte(FT_String);
- WriteName(name);
-
-- const Length len = value.length() * sizeof(wxChar);
-+ const Length len = value.length() * sizeof(wxStringCharType);
- WriteLength( mBuffer, len );
- mBuffer.AppendData(value.wx_str(), len);
- }
-@@ -309,7 +309,7 @@ void ProjectSerializer::WriteData(const wxString & val
- {
- mBuffer.AppendByte(FT_Data);
-
-- Length len = value.length() * sizeof(wxChar);
-+ Length len = value.length() * sizeof(wxStringCharType);
- WriteLength( mBuffer, len );
- mBuffer.AppendData(value.wx_str(), len);
- }
-@@ -317,7 +317,7 @@ void ProjectSerializer::WriteData(const wxString & val
- void ProjectSerializer::Write(const wxString & value)
- {
- mBuffer.AppendByte(FT_Raw);
-- Length len = value.length() * sizeof(wxChar);
-+ Length len = value.length() * sizeof(wxStringCharType);
- WriteLength( mBuffer, len );
- mBuffer.AppendData(value.wx_str(), len);
- }
-@@ -334,7 +334,7 @@ void ProjectSerializer::WriteSubTree(const ProjectSeri
-
- void ProjectSerializer::WriteName(const wxString & name)
- {
-- wxASSERT(name.length() * sizeof(wxChar) <= SHRT_MAX);
-+ wxASSERT(name.length() * sizeof(wxStringCharType) <= SHRT_MAX);
- UShort id;
-
- auto nameiter = mNames.find(name);
-@@ -346,7 +346,7 @@ void ProjectSerializer::WriteName(const wxString & nam
- {
- // mNames is static. This appends each name to static mDict only once
- // in each run.
-- UShort len = name.length() * sizeof(wxChar);
-+ UShort len = name.length() * sizeof(wxStringCharType);
-
- id = mNames.size();
- mNames[name] = id;
diff --git a/audio/audacity/files/patch-src_import_Import.cpp b/audio/audacity/files/patch-src_import_Import.cpp
deleted file mode 100644
index 5e43033c33ee..000000000000
--- a/audio/audacity/files/patch-src_import_Import.cpp
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/import/Import.cpp.orig 2021-02-04 18:52:51 UTC
-+++ src/import/Import.cpp
-@@ -803,9 +803,11 @@ bool Importer::Import( AudacityProject &project,
- /* i18n-hint: %s will be the filename */
- "Audacity did not recognize the type of the file '%s'.\n\n%sFor uncompressed files, also try File > Import > Raw Data.")
- .Format( fName,
-+#if defined(USE_FFMPEG)
- !FFmpegLibsInst()
-- ? XO("Try installing FFmpeg.\n\n")
-- : XO("") );
-+ ? XO("Try installing FFmpeg.\n\n") :
-+#endif
-+ Verbatim("") );
- }
- else
- {
diff --git a/audio/audacity/files/patch-src_widgets_FileConfig.cpp b/audio/audacity/files/patch-src_widgets_FileConfig.cpp
deleted file mode 100644
index dbad602eaca0..000000000000
--- a/audio/audacity/files/patch-src_widgets_FileConfig.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/widgets/FileConfig.cpp.orig 2021-02-04 18:52:51 UTC
-+++ src/widgets/FileConfig.cpp
-@@ -10,6 +10,8 @@
-
- #include "../Audacity.h"
-
-+#include <errno.h>
-+
- #include <wx/defs.h>
- #include <wx/app.h>
- #include <wx/bmpbuttn.h>