aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-12-09 17:09:46 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-12-09 17:10:28 +0000
commit006599e4044cf57c2dd58dbbf660fd4807612143 (patch)
tree94698039b61283917a59a7a0819690786c9521ce
parent8f8073eda8a3e9e0331f043ea42996e8a638ce2b (diff)
downloadports-006599e4044cf57c2dd58dbbf660fd4807612143.tar.gz
ports-006599e4044cf57c2dd58dbbf660fd4807612143.zip
graphics/ospray-studio: New port: Ray tracing based rendering engine for high-fidelity visualization
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ospray-studio/Makefile35
-rw-r--r--graphics/ospray-studio/distinfo3
-rw-r--r--graphics/ospray-studio/pkg-descr6
4 files changed, 45 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index febf72db0c36..9f3dd3febb50 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -611,6 +611,7 @@
SUBDIR += osg34
SUBDIR += osgearth
SUBDIR += ospray
+ SUBDIR += ospray-studio
SUBDIR += ossim
SUBDIR += oyranos
SUBDIR += p5-Acme-Steganography-Image-Png
diff --git a/graphics/ospray-studio/Makefile b/graphics/ospray-studio/Makefile
new file mode 100644
index 000000000000..47ea75a1a5e6
--- /dev/null
+++ b/graphics/ospray-studio/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= ospray-studio
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.9.0
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Ray tracing based rendering engine for high-fidelity visualization
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libglfw.so:graphics/glfw \
+ libospray.so:graphics/ospray \
+ librkcommon.so:devel/rkcommon \
+ libtbb.so:devel/onetbb
+
+USES= cmake gl pkgconfig
+USE_GL= gl glu
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= ospray
+GH_PROJECT= ${PORTNAME:S/-/_/}
+
+CMAKE_ON= OSPRAY_INSTALL
+CMAKE_OFF= USE_PYSG
+
+PLIST_FILES= bin/ospStudio \
+ lib/libospray_sg.so
+
+do-install: # workaround for https://github.com/ospray/ospray_studio/issues/8
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/ospStudio ${STAGEDIR}${LOCALBASE}/bin
+ ${INSTALL_LIB} ${BUILD_WRKSRC}/libospray_sg.so ${STAGEDIR}${LOCALBASE}/lib
+
+.include <bsd.port.mk>
diff --git a/graphics/ospray-studio/distinfo b/graphics/ospray-studio/distinfo
new file mode 100644
index 000000000000..a37344fe75d3
--- /dev/null
+++ b/graphics/ospray-studio/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637832951
+SHA256 (ospray-ospray_studio-v0.9.0_GH0.tar.gz) = 55d71d324ea38ca10afd620ee7d652611845dc16c38494701b2f149b8b3826b3
+SIZE (ospray-ospray_studio-v0.9.0_GH0.tar.gz) = 1485795
diff --git a/graphics/ospray-studio/pkg-descr b/graphics/ospray-studio/pkg-descr
new file mode 100644
index 000000000000..385aa5ce46a5
--- /dev/null
+++ b/graphics/ospray-studio/pkg-descr
@@ -0,0 +1,6 @@
+Intel OSPRay Studio is an open source and interactive visualization and ray
+tracing application that leverages Intel OSPRay as its core rendering engine.
+It can be used to load complex scenes requiring high fidelity rendering or very
+large scenes requiring supercomputing resources.
+
+WWW: https://www.ospray.org/ospray_studio/