aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:03:53 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-02-21 15:15:29 +0000
commit006cc465564001640379410341b7e12686345e07 (patch)
tree3fc01e57516f1d5b7cb87fa2961c2aa666ee6699
parent2bbf0ed7999497be4cab90d75ff0327a1ac3d2bc (diff)
downloadports-006cc465564001640379410341b7e12686345e07.tar.gz
ports-006cc465564001640379410341b7e12686345e07.zip
www/py-grip: Fix runtime with py-markdown 3.4+
- Update version requirement of RUN_DEPENDS: Make sure py-markdown 3.4+ is used - Bump PORTREVISION for package change from [1]: In addition, the md_globals parameter of Markdown.extensions.Extension.extendMarkdown() is no longer recognized as a valid parameter and will raise an error if provided. Reference: https://github.com/Python-Markdown/markdown/blob/master/docs/changelog.md [1]
-rw-r--r--www/py-grip/Makefile1
-rw-r--r--www/py-grip/files/patch-markdown11
2 files changed, 12 insertions, 0 deletions
diff --git a/www/py-grip/Makefile b/www/py-grip/Makefile
index 80fab3e483cd..03d9fce1ebe6 100644
--- a/www/py-grip/Makefile
+++ b/www/py-grip/Makefile
@@ -1,5 +1,6 @@
PORTNAME= grip
PORTVERSION= 4.6.2
+PORTREVISION= 1
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/www/py-grip/files/patch-markdown b/www/py-grip/files/patch-markdown
new file mode 100644
index 000000000000..bc6be0723d1c
--- /dev/null
+++ b/www/py-grip/files/patch-markdown
@@ -0,0 +1,11 @@
+--- grip/vendor/mdx_urlize.py.orig 2016-04-09 07:45:36 UTC
++++ grip/vendor/mdx_urlize.py
+@@ -74,7 +74,7 @@ class UrlizeExtension(markdown.Extension):
+ """
+ Urlize Extension for Python-Markdown.
+ """
+- def extendMarkdown(self, md, md_globals):
++ def extendMarkdown(self, md):
+ """
+ Replace autolink with UrlizePattern
+ """