aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-11-19 19:22:15 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-11-19 19:22:15 +0000
commit00b77851ea6eb5ea86273ec5c2d526cef9e6e682 (patch)
tree91fb0098f96f9321249d9a42874ca2ea383f6861
parent7a920f2ebcca095779dbc2fc8906c89076593873 (diff)
downloadports-00b77851ea6eb5ea86273ec5c2d526cef9e6e682.tar.gz
ports-00b77851ea6eb5ea86273ec5c2d526cef9e6e682.zip
New port: math/ignition-math: General purpose math library for robot applications
Notes
Notes: svn path=/head/; revision=485354
-rw-r--r--math/Makefile1
-rw-r--r--math/ignition-math/Makefile27
-rw-r--r--math/ignition-math/distinfo3
-rw-r--r--math/ignition-math/files/patch-CMakeLists.txt11
-rw-r--r--math/ignition-math/pkg-descr7
-rw-r--r--math/ignition-math/pkg-plist66
6 files changed, 115 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 3cbd9f24fc94..d237f0aa17c1 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -278,6 +278,7 @@
SUBDIR += hs-statistics
SUBDIR += hs-vector-space
SUBDIR += igraph
+ SUBDIR += ignition-math
SUBDIR += intervaltree
SUBDIR += ipopt
SUBDIR += ised
diff --git a/math/ignition-math/Makefile b/math/ignition-math/Makefile
new file mode 100644
index 000000000000..745500f0ddb4
--- /dev/null
+++ b/math/ignition-math/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= ignition-math
+DISTVERSION= 6.0.0
+CATEGORIES= math
+MASTER_SITES= https://bitbucket.org/${BB_ACCOUNT}/${BB_PROJECT}/get/${BB_COMMIT}.tar.gz?dummy=/
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= General purpose math library for robot applications
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ignition-cmake==2:devel/ignition-cmake
+
+USES= cmake:outsource eigen:3
+USE_LDCONFIG= yes
+
+BB_ACCOUNT= ignitionrobotics
+BB_PROJECT= ign-math
+BB_COMMIT= 46f3dd24499c
+
+WRKSRC= ${WRKDIR}/${BB_ACCOUNT}-${BB_PROJECT}-${BB_COMMIT}
+
+PLIST_SUB+= IGN_VER=${DISTVERSION:R:R}
+
+.include <bsd.port.mk>
diff --git a/math/ignition-math/distinfo b/math/ignition-math/distinfo
new file mode 100644
index 000000000000..98273f6c0a74
--- /dev/null
+++ b/math/ignition-math/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1542654723
+SHA256 (ignition-math-6.0.0.tar.gz) = 9cc37738f24f2b98cc36d09a93d297cb99f3ff5a7c8bd14cb9f837713a20cce9
+SIZE (ignition-math-6.0.0.tar.gz) = 503076
diff --git a/math/ignition-math/files/patch-CMakeLists.txt b/math/ignition-math/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9f25606012d2
--- /dev/null
+++ b/math/ignition-math/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2018-11-19 19:12:40 UTC
++++ CMakeLists.txt
+@@ -37,7 +37,7 @@ ign_find_package(
+
+ ########################################
+ # Include swig
+-find_package(SWIG QUIET)
++#find_package(SWIG QUIET)
+ if (NOT SWIG_FOUND)
+ IGN_BUILD_WARNING("Swig is missing: Language interfaces are disabled.")
+ message (STATUS "Searching for swig - not found.")
diff --git a/math/ignition-math/pkg-descr b/math/ignition-math/pkg-descr
new file mode 100644
index 000000000000..156d00882d4d
--- /dev/null
+++ b/math/ignition-math/pkg-descr
@@ -0,0 +1,7 @@
+Math classes and functions for robot applications.
+
+Ignition Math is a component in the Ignition framework, a set of libraries
+designed to rapidly develop robot applications. The library defines math
+classes and functions used in other Ignition libraries and programs.
+
+WWW: https://ignitionrobotics.org/home
diff --git a/math/ignition-math/pkg-plist b/math/ignition-math/pkg-plist
new file mode 100644
index 000000000000..5f19f4ddc94a
--- /dev/null
+++ b/math/ignition-math/pkg-plist
@@ -0,0 +1,66 @@
+include/ignition/math%%IGN_VER%%/ignition/math.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Angle.hh
+include/ignition/math%%IGN_VER%%/ignition/math/AxisAlignedBox.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Box.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Color.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Cylinder.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Export.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Filter.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Frustum.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Helpers.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Inertial.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Kmeans.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Line2.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Line3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/MassMatrix3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Material.hh
+include/ignition/math%%IGN_VER%%/ignition/math/MaterialType.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Matrix3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Matrix4.hh
+include/ignition/math%%IGN_VER%%/ignition/math/MovingWindowFilter.hh
+include/ignition/math%%IGN_VER%%/ignition/math/OrientedBox.hh
+include/ignition/math%%IGN_VER%%/ignition/math/PID.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Plane.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Pose3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Quaternion.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Rand.hh
+include/ignition/math%%IGN_VER%%/ignition/math/RotationSpline.hh
+include/ignition/math%%IGN_VER%%/ignition/math/SemanticVersion.hh
+include/ignition/math%%IGN_VER%%/ignition/math/SignalStats.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Sphere.hh
+include/ignition/math%%IGN_VER%%/ignition/math/SphericalCoordinates.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Spline.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Stopwatch.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Temperature.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Triangle.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Triangle3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Vector2.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Vector3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Vector3Stats.hh
+include/ignition/math%%IGN_VER%%/ignition/math/Vector4.hh
+include/ignition/math%%IGN_VER%%/ignition/math/config.hh
+include/ignition/math%%IGN_VER%%/ignition/math/detail/Box.hh
+include/ignition/math%%IGN_VER%%/ignition/math/detail/Cylinder.hh
+include/ignition/math%%IGN_VER%%/ignition/math/detail/Export.hh
+include/ignition/math%%IGN_VER%%/ignition/math/detail/Sphere.hh
+include/ignition/math%%IGN_VER%%/ignition/math/eigen3.hh
+include/ignition/math%%IGN_VER%%/ignition/math/eigen3/Conversions.hh
+include/ignition/math%%IGN_VER%%/ignition/math/graph/Edge.hh
+include/ignition/math%%IGN_VER%%/ignition/math/graph/Graph.hh
+include/ignition/math%%IGN_VER%%/ignition/math/graph/GraphAlgorithms.hh
+include/ignition/math%%IGN_VER%%/ignition/math/graph/Vertex.hh
+lib/cmake/ignition-math%%IGN_VER%%-all/ignition-math%%IGN_VER%%-all-config-version.cmake
+lib/cmake/ignition-math%%IGN_VER%%-all/ignition-math%%IGN_VER%%-all-config.cmake
+lib/cmake/ignition-math%%IGN_VER%%-all/ignition-math%%IGN_VER%%-all-targets.cmake
+lib/cmake/ignition-math%%IGN_VER%%-eigen3/ignition-math%%IGN_VER%%-eigen3-config-version.cmake
+lib/cmake/ignition-math%%IGN_VER%%-eigen3/ignition-math%%IGN_VER%%-eigen3-config.cmake
+lib/cmake/ignition-math%%IGN_VER%%-eigen3/ignition-math%%IGN_VER%%-eigen3-targets.cmake
+lib/cmake/ignition-math%%IGN_VER%%/ignition-math%%IGN_VER%%-config-version.cmake
+lib/cmake/ignition-math%%IGN_VER%%/ignition-math%%IGN_VER%%-config.cmake
+lib/cmake/ignition-math%%IGN_VER%%/ignition-math%%IGN_VER%%-targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/ignition-math%%IGN_VER%%/ignition-math%%IGN_VER%%-targets.cmake
+lib/libignition-math%%IGN_VER%%.so
+lib/libignition-math%%IGN_VER%%.so.6
+lib/libignition-math%%IGN_VER%%.so.6.0.0~pre4
+libdata/pkgconfig/ignition-math%%IGN_VER%%-eigen3.pc
+libdata/pkgconfig/ignition-math%%IGN_VER%%.pc