aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2023-04-28 21:55:35 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2023-04-30 21:04:15 +0000
commit00c46f9fe7030e70c10ea2f69714c0b70b03a175 (patch)
tree5c9ed213f9e4481afd600b033a70472a755e3bb2
parent76b163ca87eb021ae9514a1742199871212f20bb (diff)
downloadports-00c46f9fe7030e70c10ea2f69714c0b70b03a175.tar.gz
ports-00c46f9fe7030e70c10ea2f69714c0b70b03a175.zip
devel/qt5-qmake: do not try to install qtconfig header
Qt-dist ports that are a module need to install their header to qt-config.h. This accidentally happens to qt5-qmake as well. This is only visible when *installing* qt5-qmake on an otherwise fresh system with no other Qt packages. If you install any other Qt packages, then the qt-config header is there for the post-install script to work on (though it doesn't do anything for qt5-qmake). In a clean system, the script fails. PR: 269232 Reported by: Zsolt Udvari
-rw-r--r--Mk/Uses/qt-dist.mk4
-rw-r--r--devel/qt5-qmake/Makefile1
2 files changed, 5 insertions, 0 deletions
diff --git a/Mk/Uses/qt-dist.mk b/Mk/Uses/qt-dist.mk
index de81ae118073..b000cd2b038b 100644
--- a/Mk/Uses/qt-dist.mk
+++ b/Mk/Uses/qt-dist.mk
@@ -457,7 +457,11 @@ _sub_need_clean=
. else
_sub_need_clean= \#\#
. endif
+# The Qt modules have an install- and deinstall-step for wrangling
+# the qconfig-modules.h header, but qmake does not.
+. if ${PORTNAME} != "qmake"
post-install: qt-post-install
+. endif # PORTNAME != qmake
qt-post-install:
# We can't use SUB_FILES with the shared pkg-change.in.
# We need it to be a script instead of a group of @unexecs.
diff --git a/devel/qt5-qmake/Makefile b/devel/qt5-qmake/Makefile
index 147f7b17cb93..548114ce4014 100644
--- a/devel/qt5-qmake/Makefile
+++ b/devel/qt5-qmake/Makefile
@@ -1,5 +1,6 @@
PORTNAME= qmake
PORTVERSION= ${QT5_VERSION}${QT5_KDE_PATCH}
+PORTREVISION= 2
CATEGORIES= devel
PKGNAMEPREFIX= qt5-