aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2021-10-17 15:40:38 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2021-10-17 15:43:25 +0000
commit00f889e0346cd6cf49a9379e00285e6addf0031a (patch)
tree7f99beff8a8453663fa84e435a0eb5c2e50a79c6
parent4523b2c8fa0552ffd30e61d94c8ead0ccd8168dc (diff)
downloadports-00f889e0346cd6cf49a9379e00285e6addf0031a.tar.gz
ports-00f889e0346cd6cf49a9379e00285e6addf0031a.zip
net/pacemaker1: fix building port with clang 11
wrong reason was added to BROKEN conditional; remove BROKEN flag if OSVERSION >= 1300000; current commit also fixes ability to build this port.
-rw-r--r--net/pacemaker1/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/net/pacemaker1/Makefile b/net/pacemaker1/Makefile
index da2a3734e572..3f3eaf5c20b4 100644
--- a/net/pacemaker1/Makefile
+++ b/net/pacemaker1/Makefile
@@ -1,7 +1,7 @@
# Created by: David Shane Holden <dpejesh@yahoo.com>
PORTVERSION= 1.1.24
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX= 1
.include "${.CURDIR}/Makefile.common"
@@ -24,8 +24,9 @@ REPLACE_ARGS_GETOPT= -e 's,getopt,${LOCALBASE}/bin/getopt,'
.include <bsd.port.pre.mk>
+# Fix building it with clang 11
.if ${OSVERSION} >= 1300000
-BROKEN= "includes <sys/timeb.h> which is deprecated"
+CFLAGS+= -fcommon
.endif
.if ${PYTHON_SUFFIX} > 36