aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2014-07-03 22:15:05 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2014-07-03 22:15:05 +0000
commit011fbf1aaf2ad80789025829ab37c20730f33b57 (patch)
tree53a42ae9564262ec885f80b4e3f31819f6d32adf
parentd5346ac7f72e94a58de36af2d546fd8d7e54ffff (diff)
downloadports-011fbf1aaf2ad80789025829ab37c20730f33b57.tar.gz
ports-011fbf1aaf2ad80789025829ab37c20730f33b57.zip
games/quake2-matrix: support stage
Notes
Notes: svn path=/head/; revision=360473
-rw-r--r--games/quake2-matrix/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/games/quake2-matrix/Makefile b/games/quake2-matrix/Makefile
index 98e8f7e7713e..c9c5cc396bf3 100644
--- a/games/quake2-matrix/Makefile
+++ b/games/quake2-matrix/Makefile
@@ -18,23 +18,20 @@ ALL_TARGET= release
DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
-NO_STAGE= yes
-.include "${.CURDIR}/../quake2-data/Makefile.include"
+OPTIONS_DEFINE= DOCS
-.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../quake2-data/Makefile.include"
post-patch:
@${REINPLACE_CMD} -e 's/__linux__/__unix__/' \
${BUILD_WRKSRC}/q_shared.[ch]
do-install:
- ${MKDIR} ${Q2DIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${Q2DIR}/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/matrix/game.so \
- ${Q2DIR}/${PORTNAME}
- cd ${WRKSRC} && ${INSTALL_DATA} *.cfg *.ini *.pak ${Q2DIR}/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg *.ini *.pak ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>