aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2023-02-11 12:00:48 +0000
committerMatthias Andree <mandree@FreeBSD.org>2023-02-20 22:06:37 +0000
commit01927a4913fa76325592b3331f39fcf0d2aa36de (patch)
tree90ac25020040a7ec0c3b6fd73c996af6007dd295
parent7fa86e6d6aa70dc1c4e07e91880af6520185373a (diff)
downloadports-01927a4913fa76325592b3331f39fcf0d2aa36de.tar.gz
ports-01927a4913fa76325592b3331f39fcf0d2aa36de.zip
www/node18: www/node19: honor ccache for build
This works because CCACHE_BIN is empty if not requested. Approved by: sunpoet@ (maintainer) PR: 269491
-rw-r--r--www/node18/Makefile4
-rw-r--r--www/node19/Makefile4
2 files changed, 4 insertions, 4 deletions
diff --git a/www/node18/Makefile b/www/node18/Makefile
index f08827eab1fa..6e949dff78f7 100644
--- a/www/node18/Makefile
+++ b/www/node18/Makefile
@@ -37,9 +37,9 @@ CONFIGURE_ARGS= --prefix=${PREFIX:S|^${DESTDIR}||} \
--shared-zlib \
--without-npm
HAS_CONFIGURE= yes
-MAKE_ENV= CC.host="${CC}" \
+MAKE_ENV= CC.host="${CCACHE_BIN} ${CC}" \
CFLAGS.host="${CFLAGS}" \
- CXX.host="${CXX}" \
+ CXX.host="${CCACHE_BIN} ${CXX}" \
CXXFLAGS.host="${CXXFLAGS}" \
LDFLAGS.host="${LDFLAGS}" \
LINK.host="${CXX}"
diff --git a/www/node19/Makefile b/www/node19/Makefile
index a393d5f3446d..ba1e8dc52a09 100644
--- a/www/node19/Makefile
+++ b/www/node19/Makefile
@@ -37,9 +37,9 @@ CONFIGURE_ARGS= --prefix=${PREFIX:S|^${DESTDIR}||} \
--shared-zlib \
--without-npm
HAS_CONFIGURE= yes
-MAKE_ENV= CC.host="${CC}" \
+MAKE_ENV= CC.host="${CCACHE_BIN} ${CC}" \
CFLAGS.host="${CFLAGS}" \
- CXX.host="${CXX}" \
+ CXX.host="${CCACHE_BIN} ${CXX}" \
CXXFLAGS.host="${CXXFLAGS}" \
LDFLAGS.host="${LDFLAGS}" \
LINK.host="${CXX}"