aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2010-11-25 04:12:51 +0000
committerWesley Shields <wxs@FreeBSD.org>2010-11-25 04:12:51 +0000
commit01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126 (patch)
tree52a1d4f80158154e90f915ba8af47907ab125256
parent98fa194a83186868773644a5c7661827a5e1ece4 (diff)
downloadports-01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126.tar.gz
ports-01dc94c1c1c1c798f4fb52bbd859bf9cb9a6d126.zip
Redshift adjusts the color temperature of your screen according
to your surroundings. This may help your eyes hurt less if you are working in front of the screen at night. WWW: http://jonls.dk/redshift/ PR: ports/152554 Submitted by: Mark Felder <feld@feld.me>
Notes
Notes: svn path=/head/; revision=265125
-rw-r--r--accessibility/Makefile1
-rw-r--r--accessibility/redshift/Makefile65
-rw-r--r--accessibility/redshift/distinfo2
-rw-r--r--accessibility/redshift/pkg-descr5
-rw-r--r--accessibility/redshift/pkg-plist47
5 files changed, 120 insertions, 0 deletions
diff --git a/accessibility/Makefile b/accessibility/Makefile
index 8ee0c9b7096f..7de845ee24c4 100644
--- a/accessibility/Makefile
+++ b/accessibility/Makefile
@@ -30,6 +30,7 @@
SUBDIR += py-atspi
SUBDIR += py-papi
SUBDIR += qt4-accessible
+ SUBDIR += redshift
SUBDIR += ruby-atk
SUBDIR += speech-dispatcher
SUBDIR += yasr
diff --git a/accessibility/redshift/Makefile b/accessibility/redshift/Makefile
new file mode 100644
index 000000000000..5cf3d4b1fe15
--- /dev/null
+++ b/accessibility/redshift/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: redshift
+# Date created: Wed Nov 24 12:35:17 CST 2010
+# Whom: Mark Felder <feld@feld.me>
+#
+# $FreeBSD$
+#
+
+PORTNAME= redshift
+PORTVERSION= 1.6
+CATEGORIES= accessibility
+MASTER_SITES= http://launchpad.net/redshift/trunk/${PORTVERSION}/+download/
+
+MAINTAINER= feld@feld.me
+COMMENT= Adjusts the color temperature of your screen
+
+FETCH_ARGS= "-pRr"
+USE_GMAKE= yes
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
+MAN1= redshift.1
+MANCOMPRESSED= no
+
+CONFIGURE_ARGS+=--disable-wingdi --disable-gnome-clock --disable-gui
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+CONFIGURE_ARGS+=--with-libiconv-prefix=${LOCALBASE} \
+ --with-libintl-prefix=${LOCALBASE}
+PLIST_SUB= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB= NLS="@comment "
+.endif
+
+OPTIONS= GUI "Tray icon & location via Gnome clock" off \
+ RANDR "Support RANDR for changing colors" on \
+ VIDMODE "Support VIDMODE for changing colors (NVIDIA)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_RANDR)
+CONFIGURE_ARGS+=--enable-randr
+USE_XORG= xrandr
+.else
+CONFIGURE_ARGS+=--disable-randr
+.endif
+
+.if defined(WITH_VIDMODE)
+CONFIGURE_ARGS+=--enable-vidmode
+.else
+CONFIGURE_ARGS+=--disable-vidmode
+.endif
+
+.if defined(WITH_GUI)
+CONFIGURE_ARGS+=--enable-gui --enable-gnome-clock
+RUN_DEPENDS+= py-gtk2:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ py-xdg:${PORTSDIR}/devel/py-xdg
+PLIST_SUB+= GUI=""
+.else
+CONFIGURE_ARGS+=--disable-gui --disable-gnome-clock
+PLIST_SUB+= GUI="@comment "
+.endif
+
+.include <bsd.port.mk>
diff --git a/accessibility/redshift/distinfo b/accessibility/redshift/distinfo
new file mode 100644
index 000000000000..bf1878b060a4
--- /dev/null
+++ b/accessibility/redshift/distinfo
@@ -0,0 +1,2 @@
+SHA256 (redshift-1.6.tar.bz2) = 9107451dee3c71c6ea146cb5409390814bf85b56ea495fb576c28f6e31fc863c
+SIZE (redshift-1.6.tar.bz2) = 266881
diff --git a/accessibility/redshift/pkg-descr b/accessibility/redshift/pkg-descr
new file mode 100644
index 000000000000..2a10b96d78e5
--- /dev/null
+++ b/accessibility/redshift/pkg-descr
@@ -0,0 +1,5 @@
+Redshift adjusts the color temperature of your screen according
+to your surroundings. This may help your eyes hurt less if you
+are working in front of the screen at night.
+
+WWW: http://jonls.dk/redshift/
diff --git a/accessibility/redshift/pkg-plist b/accessibility/redshift/pkg-plist
new file mode 100644
index 000000000000..1a73b4213eb2
--- /dev/null
+++ b/accessibility/redshift/pkg-plist
@@ -0,0 +1,47 @@
+bin/redshift
+share/icons/hicolor/scalable/apps/redshift.svg
+share/icons/hicolor/scalable/apps/redshift-status-off.svg
+share/icons/hicolor/scalable/apps/redshift-status-on.svg
+share/icons/ubuntu-mono-dark/scalable/apps/redshift-status-off.svg
+share/icons/ubuntu-mono-dark/scalable/apps/redshift-status-on.svg
+share/icons/ubuntu-mono-light/scalable/apps/redshift-status-off.svg
+share/icons/ubuntu-mono-light/scalable/apps/redshift-status-on.svg
+%%NLS%%share/locale/cs/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/da/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/de/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/es/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/he/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/it/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/ka/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/redshift.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/redshift.mo
+%%GUI%%bin/gtk-redshift
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/__init__.py
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/__init__.pyc
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/__init__.pyo
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/defs.py
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/defs.pyc
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/defs.pyo
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/statusicon.py
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/statusicon.pyc
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/statusicon.pyo
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/utils.py
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/utils.pyc
+%%GUI%%lib/python2.6/site-packages/gtk_redshift/utils.pyo
+%%GUI%%share/applications/gtk-redshift.desktop
+@dirrmtry share/icons/ubuntu-mono-dark/scalable/apps
+@dirrmtry share/icons/ubuntu-mono-dark/scalable
+@dirrmtry share/icons/ubuntu-mono-dark
+@dirrmtry share/icons/ubuntu-mono-light/scalable/apps
+@dirrmtry share/icons/ubuntu-mono-light/scalable
+@dirrmtry share/icons/ubuntu-mono-light
+@dirrmtry share/icons/hicolor/scalable/apps
+@dirrmtry share/icons/hicolor/scalable
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry lib/python2.6/site-packages/gtk_redshift