aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-11 06:44:18 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-11 06:44:18 +0000
commit0280b837667619363cee27f810fd0c3fc42f85fe (patch)
treeae45a91d7392e36a56baeb42b1bf5118929e11e6
parent4b06fe59476c6890a8c99689d5455c3a92cb740d (diff)
downloadports-0280b837667619363cee27f810fd0c3fc42f85fe.tar.gz
ports-0280b837667619363cee27f810fd0c3fc42f85fe.zip
lang/gcc8-devel: Remove
With the release of GCC 8.5 the GCC 8 release series has reached end of life. This also means the end of weekly snapshots. Remove lang/gcc8-devel which has been tracking those and redirect to lang/gcc8 and that final release instead.
-rw-r--r--MOVED1
-rw-r--r--lang/Makefile1
-rw-r--r--lang/gcc8-devel/Makefile159
-rw-r--r--lang/gcc8-devel/distinfo3
-rw-r--r--lang/gcc8-devel/files/patch-arm-unwind-cxx-support106
-rw-r--r--lang/gcc8-devel/files/patch-clang-vec_step21
-rw-r--r--lang/gcc8-devel/files/patch-gfortran-libgcc70
-rw-r--r--lang/gcc8-devel/files/patch-spe-config24
-rw-r--r--lang/gcc8-devel/files/pkg-message.in13
-rw-r--r--lang/gcc8-devel/pkg-descr7
-rw-r--r--lang/gcc8-devel/pkg-plist33
-rw-r--r--lang/gcc8/Makefile2
12 files changed, 1 insertions, 439 deletions
diff --git a/MOVED b/MOVED
index aaa787e2040e..80d7021cc8b4 100644
--- a/MOVED
+++ b/MOVED
@@ -16386,3 +16386,4 @@ net/py-python-glanceclient2|net/py-python-glanceclient|2021-06-10|Remove obsolet
net/py-python-keystoneclient3|net/py-python-keystoneclient|2021-06-10|Remove obsoleted port. Use net/py-python-keystoneclient instead
net/py-python-novaclient16|net/py-python-novaclient|2021-06-10|Remove obsoleted port. Use net/py-python-novaclient instead
print/py-pycups1|print/py-pycups|2021-06-10|Remove obsoleted port. Use print/py-pycups instead
+lang/gcc8-devel|lang/gcc8|2021-06-11|GCC 8 reached end of life, use the final release (or a new major version)
diff --git a/lang/Makefile b/lang/Makefile
index b96f54c8a2fe..aef0867138e8 100644
--- a/lang/Makefile
+++ b/lang/Makefile
@@ -98,7 +98,6 @@
SUBDIR += gcc6-aux
SUBDIR += gcc7
SUBDIR += gcc8
- SUBDIR += gcc8-devel
SUBDIR += gcc9
SUBDIR += gcc9-devel
SUBDIR += gforth
diff --git a/lang/gcc8-devel/Makefile b/lang/gcc8-devel/Makefile
deleted file mode 100644
index 69d626e586a5..000000000000
--- a/lang/gcc8-devel/Makefile
+++ /dev/null
@@ -1,159 +0,0 @@
-# Created by: Gerald Pfeifer <gerald@FreeBSD.org>
-
-PORTNAME= gcc
-PORTVERSION= 8.4.1.s20210512
-CATEGORIES= lang
-MASTER_SITES= GCC/snapshots/${DIST_VERSION}
-PKGNAMESUFFIX= ${SUFFIX}-devel
-DISTNAME= gcc-${DIST_VERSION}
-
-MAINTAINER= gerald@FreeBSD.org
-COMMENT= GNU Compiler Collection 8
-
-LICENSE= GPLv3 GPLv3RLE
-LICENSE_COMB= multi
-
-ONLY_FOR_ARCHS= aarch64 amd64 arm armv6 armv7 i386 powerpc powerpc64 powerpcspe
-
-LIB_DEPENDS= libgmp.so:math/gmp \
- libmpfr.so:math/mpfr \
- libmpc.so:math/mpc
-BUILD_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
-RUN_DEPENDS+= ${LOCALBASE}/bin/as:devel/binutils
-.if defined(MAINTAINER_MODE)
-BUILD_DEPENDS+= runtest:misc/dejagnu
-.endif
-
-USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:xz
-USE_BINUTILS= yes
-USE_PERL5= build
-
-CONFLICTS= gcc8-8.*
-
-CPE_VENDOR= gnu
-CPE_VERSION= ${GCC_VERSION}
-
-# DIST_VERSION relates to downloads, GCC_VERSION and SUFFIX to names
-# of executables and directories once installed. A PORTVERSION of
-# Y.2.1.s20140817 results in values of Y-20140817, Y.2.1, and Y
-# for these three.
-DIST_VERSION= ${PORTVERSION:C/([0-9]+).*\.s([0-9]+)/\1-\2/}
-GCC_VERSION= ${PORTVERSION:C/(.+)\.s[0-9]{8}/\1/}
-SUFFIX= ${PORTVERSION:C/([0-9]+).*/\1/}
-CFLAGS:= ${CFLAGS:N-mretpoline}
-CXXFLAGS:= ${CXXFLAGS:N-mretpoline}
-
-OPTIONS_DEFINE= BOOTSTRAP
-OPTIONS_DEFAULT= BOOTSTRAP
-BOOTSTRAP_DESC= Build using a full bootstrap
-
-.if exists(/usr/lib32/libc.so)
-OPTIONS_DEFINE_amd64+= MULTILIB
-OPTIONS_DEFAULT_amd64+= MULTILIB
-OPTIONS_DEFINE_powerpc64+= MULTILIB
-OPTIONS_DEFAULT_powerpc64+= MULTILIB
-MULTILIB_DESC= Build support for 32-bit and 64-bit targets
-MULTILIB_CONFIGURE_ENABLE= multilib
-.else
-CONFIGURE_ARGS+= --disable-multilib
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == amd64
-CONFIGURE_TARGET= x86_64-portbld-${OPSYS:tl}${OSREL}
-
-.elif ${ARCH} == powerpc64
-CONFIGURE_ENV+= UNAME_m="powerpc64"
-. if defined(PPC_ABI) && ${PPC_ABI} == ELFv2
-CONFIGURE_ARGS+= --with-abi=elfv2
-. else
-MAKE_ARGS+= CFLAGS_FOR_TARGET="-O1" CXXFLAGS_FOR_TARGET="-O1" BOOT_CFLAGS="-O1" # PR235975
-.endif
-
-.elif ${ARCH} == powerpcspe
-CONFIGURE_ARGS+= --with-cpu=8548 --enable-e500_double --without-fp
-.endif
-
-LANGUAGES:= c,c++,objc,fortran
-TARGLIB= ${PREFIX}/lib/gcc${SUFFIX}
-TARGLIB32= ${PREFIX}/lib32 # The version information is added later
-LIBEXEC= ${PREFIX}/libexec/gcc${SUFFIX}
-GNU_CONFIGURE= yes
-CONFIGURE_OUTSOURCE= yes
-.if empty(PORT_OPTIONS:MBOOTSTRAP)
-CONFIGURE_ARGS+=--disable-bootstrap
-.else
-CONFIGURE_ARGS+=--with-build-config=bootstrap-debug
-ALL_TARGET= bootstrap-lean
-.endif
-INSTALL_TARGET= install-strip
-.if ${UID} != 0
-BINMODE= 755
-.endif
-CONFIGURE_ARGS+=--disable-nls \
- --enable-gnu-indirect-function \
- --libdir=${TARGLIB} \
- --libexecdir=${LIBEXEC} \
- --program-suffix=${SUFFIX} \
- --with-as=${LOCALBASE}/bin/as \
- --with-gmp=${LOCALBASE} \
- --with-gxx-include-dir=${TARGLIB}/include/c++/ \
- --with-ld=${LOCALBASE}/bin/ld \
- ${ICONV_CONFIGURE_ARG} \
- --with-pkgversion="FreeBSD Ports Collection" \
- --with-system-zlib \
- --without-zstd
-MAKE_ARGS+= MAKEINFOFLAGS="--no-split"
-USE_LDCONFIG= ${TARGLIB}
-PLIST_SUB+= GCC_VERSION=${GCC_VERSION} \
- GNU_HOST=${CONFIGURE_TARGET} \
- SUFFIX=${SUFFIX}
-INFO= gcc${SUFFIX}/cpp \
- gcc${SUFFIX}/cppinternals \
- gcc${SUFFIX}/gcc \
- gcc${SUFFIX}/gccinstall \
- gcc${SUFFIX}/gccint \
- gcc${SUFFIX}/gfortran \
- gcc${SUFFIX}/libgomp
-.if ${ARCH} == amd64 || ${ARCH} == i386
-INFO+= gcc${SUFFIX}/libquadmath \
- gcc${SUFFIX}/libitm
-.endif
-SUB_FILES= pkg-message
-SUB_LIST+= TARGLIB=${TARGLIB}
-
-CONFIGURE_ARGS+=--enable-languages=${LANGUAGES}
-
-pre-everything::
- @${ECHO_MSG} "Making GCC ${PORTVERSION} for ${CONFIGURE_TARGET} [${LANGUAGES}]"
-
-pre-configure:
- cd ${WRKSRC} ; contrib/gcc_update --touch
- @${RM} ${WRKSRC}/gcc/*/*.info*
-
-.if defined(MAINTAINER_MODE)
-full-regression-test: build
- cd ${TEST_WRKSRC}; ${MAKE_CMD} -sk check \
- ; ${WRKSRC}/contrib/test_summary
-.endif
-
-post-stage:
- ${RM} ${STAGEDIR}${PREFIX}/man/man7/*
- ${RM} -r ${STAGEDIR}${TARGLIB}/gcc/*/${GCC_VERSION}/include-fixed/
- # Add target libraries and include files to packaging list.
- ${RM} ${WRKDIR}/PLIST.lib
-
-.if (${ARCH} == amd64 || ${ARCH} == powerpc64) && ${PORT_OPTIONS:MMULTILIB}
- ${MKDIR} ${STAGEDIR}${TARGLIB32}
- ${MV} ${STAGEDIR}${PREFIX}/lib/lib32 ${STAGEDIR}${TARGLIB32}/gcc${SUFFIX}
-.endif
-
-.for d in ${TARGLIB:S/^${PREFIX}\///} ${TARGLIB32:S/^${PREFIX}\///} ${LIBEXEC:S/^${PREFIX}\///}
- cd ${STAGEDIR}${PREFIX} ; if [ -d $d ]; then \
- ${FIND} $d -type f -o -type l >>${WRKDIR}/PLIST.lib ;\
- fi
-.endfor
- cd ${WRKDIR} ; ${SED} -i -e "/PLIST.lib/ r PLIST.lib" ${TMPPLIST}
-
-.include <bsd.port.post.mk>
diff --git a/lang/gcc8-devel/distinfo b/lang/gcc8-devel/distinfo
deleted file mode 100644
index 4f21b567c37e..000000000000
--- a/lang/gcc8-devel/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1621158125
-SHA256 (gcc-8-20210512.tar.xz) = d082a51995d466e45f47c74e2bb46bc248d55e8cebec54ba17df9b1de7c7e069
-SIZE (gcc-8-20210512.tar.xz) = 60803232
diff --git a/lang/gcc8-devel/files/patch-arm-unwind-cxx-support b/lang/gcc8-devel/files/patch-arm-unwind-cxx-support
deleted file mode 100644
index ec6959b9655c..000000000000
--- a/lang/gcc8-devel/files/patch-arm-unwind-cxx-support
+++ /dev/null
@@ -1,106 +0,0 @@
---- UTC
-Index: gcc/ginclude/unwind-arm-common.h
-===================================================================
---- gcc/ginclude/unwind-arm-common.h (revision 219113)
-+++ gcc/ginclude/unwind-arm-common.h (working copy)
-@@ -82,7 +82,11 @@
-
- struct _Unwind_Control_Block
- {
-+#ifdef __FreeBSD__
-+ unsigned exception_class __attribute__((__mode__(__DI__)));
-+#else
- char exception_class[8];
-+#endif
- void (*exception_cleanup)(_Unwind_Reason_Code, _Unwind_Control_Block *);
- /* Unwinder cache, private fields for the unwinder's use */
- struct
-@@ -181,7 +185,11 @@
-
- /* Support functions for the PR. */
- #define _Unwind_Exception _Unwind_Control_Block
-+#ifdef __FreeBSD__
-+ typedef unsigned _Unwind_Exception_Class __attribute__((__mode__(__DI__)));
-+#else
- typedef char _Unwind_Exception_Class[8];
-+#endif
-
- void * _Unwind_GetLanguageSpecificData (_Unwind_Context *);
- _Unwind_Ptr _Unwind_GetRegionStart (_Unwind_Context *);
-Index: libstdc++-v3/libsupc++/unwind-cxx.h
-===================================================================
---- libstdc++-v3/libsupc++/unwind-cxx.h (revision 219147)
-+++ libstdc++-v3/libsupc++/unwind-cxx.h (working copy)
-@@ -235,7 +235,7 @@
- return reinterpret_cast<__cxa_dependent_exception *>(exc + 1) - 1;
- }
-
--#ifdef __ARM_EABI_UNWINDER__
-+#if defined(__ARM_EABI_UNWINDER__) && !defined(__FreeBSD__)
- static inline bool
- __is_gxx_exception_class(_Unwind_Exception_Class c)
- {
-@@ -309,13 +309,7 @@
- c[6] = 'R';
- c[7] = '\0';
- }
--
--static inline void*
--__gxx_caught_object(_Unwind_Exception* eo)
--{
-- return (void*)eo->barrier_cache.bitpattern[0];
--}
--#else // !__ARM_EABI_UNWINDER__
-+#else // !__ARM_EABI_UNWINDER__ || __FreeBSD__
- // This is the primary exception class we report -- "GNUCC++\0".
- const _Unwind_Exception_Class __gxx_primary_exception_class
- = ((((((((_Unwind_Exception_Class) 'G'
-@@ -339,6 +333,16 @@
- << 8 | (_Unwind_Exception_Class) '+')
- << 8 | (_Unwind_Exception_Class) '\x01');
-
-+const _Unwind_Exception_Class __gxx_forced_unwind_class
-+= ((((((((_Unwind_Exception_Class) 'G'
-+ << 8 | (_Unwind_Exception_Class) 'N')
-+ << 8 | (_Unwind_Exception_Class) 'U')
-+ << 8 | (_Unwind_Exception_Class) 'C')
-+ << 8 | (_Unwind_Exception_Class) 'F')
-+ << 8 | (_Unwind_Exception_Class) 'O')
-+ << 8 | (_Unwind_Exception_Class) 'R')
-+ << 8 | (_Unwind_Exception_Class) '\0');
-+
- static inline bool
- __is_gxx_exception_class(_Unwind_Exception_Class c)
- {
-@@ -346,6 +350,12 @@
- || c == __gxx_dependent_exception_class;
- }
-
-+static inline bool
-+__is_gxx_forced_unwind_class(_Unwind_Exception_Class c)
-+{
-+ return c == __gxx_forced_unwind_class;
-+}
-+
- // Only checks for primary or dependent, but not that it is a C++ exception at
- // all.
- static inline bool
-@@ -357,7 +367,18 @@
- #define __GXX_INIT_PRIMARY_EXCEPTION_CLASS(c) c = __gxx_primary_exception_class
- #define __GXX_INIT_DEPENDENT_EXCEPTION_CLASS(c) \
- c = __gxx_dependent_exception_class
-+#define __GXX_INIT_FORCED_UNWIND_CLASS(c) c = __gxx_forced_unwind_class
-+#endif // __ARM_EABI_UNWINDER__ && !__FreeBSD__
-
-+#ifdef __ARM_EABI_UNWINDER__
-+static inline void*
-+__gxx_caught_object(_Unwind_Exception* eo)
-+{
-+ return (void*)eo->barrier_cache.bitpattern[0];
-+}
-+
-+#else // !__ARM_EABI_UNWINDER__
-+
- // GNU C++ personality routine, Version 0.
- extern "C" _Unwind_Reason_Code __gxx_personality_v0
- (int, _Unwind_Action, _Unwind_Exception_Class,
diff --git a/lang/gcc8-devel/files/patch-clang-vec_step b/lang/gcc8-devel/files/patch-clang-vec_step
deleted file mode 100644
index 68fbeedad582..000000000000
--- a/lang/gcc8-devel/files/patch-clang-vec_step
+++ /dev/null
@@ -1,21 +0,0 @@
-https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=239266 reports how
-clang unfortunately poisons user namespace by default (without any
-special options).
-
-Until that changes (or GCC changes) we need to avoid using vec_step
-as a variable.
-
---- UTC
-Index: gcc/tree-vect-loop.c
-===================================================================
---- gcc/tree-vect-loop.c (revision 273856)
-+++ gcc/tree-vect-loop.c (working copy)
-@@ -55,6 +55,8 @@ along with GCC; see the file COPYING3. If not see
- #include "vec-perm-indices.h"
- #include "tree-eh.h"
-
-+#define vec_step vec_step_
-+
- /* Loop Vectorization Pass.
-
- This pass tries to vectorize loops.
diff --git a/lang/gcc8-devel/files/patch-gfortran-libgcc b/lang/gcc8-devel/files/patch-gfortran-libgcc
deleted file mode 100644
index 89c6cb902c42..000000000000
--- a/lang/gcc8-devel/files/patch-gfortran-libgcc
+++ /dev/null
@@ -1,70 +0,0 @@
-GCC has two runtime libraries: The static library libgcc.a (-lgcc) and
-the shared library libgcc_s.so (-lgcc_s). Both implement many of the
-same functions but they also each have their unique functions. When
-gcc links programs and libraries there are three possibilities:
-
-1. gcc -static-libgcc or gcc -static: -lgcc
- => Just use libgcc.a.
-
-2. gcc -shared-libgcc: -lgcc_s -lgcc
- => Link with libgcc_s first, so libgcc.a is only used for its unique
- functions.
-
-3. gcc: -lgcc -Wl,--as-needed -lgcc_s -Wl,--no-as-needed
- => Link with libgcc.a first so libgcc_s is only used for its unique
- functions (_Unwind_* functions).
-
-Approach 3 is the default for gcc and it's also what clang and clang++ use;
-approach 2 is the default for gfortran, g++ and probably other front ends.
-
-This patch makes 3 the default for gfortran. It significantly reduces
-the use of libgcc_s. The _Unwind_* functions are also available in the
-old base system libgcc_s which means this reduces the need for
--rpath /usr/local/lib/gccN in ports that depend on libraries built with
-gfortran. Consider a dependency tree like this:
-
- prog -> libA -> libgcc_s (old base system libgcc_s is fine)
- -> libB -> libgcc_s (libB built with gfortran, needs new libgcc_s)
-
-Here prog needs to be linked with -rpath /usr/local/lib/gccN even if it's
-a normal C program compiled with clang. Without -rpath it will fail to
-start because it loads old libgcc_s first as a dependency of libA and then
-it fails to load libB. With this patch libB works with old base system
-libgcc_s or may not need libgcc_s at all, so prog does not need to be
-linked with -rpath.
-
-Upstream is unlikely accept a patch like this because libgfortran calls
-some _Unwind_* functions and so always needs libgcc_s. Also because
-every Fortran program and library links to libgfortran it makes sense
-that option 2 above is the default. On FreeBSD where clang and GCC
-compiled code can be mixed and where multiple libgcc_s may be installed,
-option 3 is just a lot easier to deal with.
-
-The bug that sparked this is PR 208120 (but note there's a lot of
-misleading information in that bug. CMake is not actually doing
-anything wrong.)
-
---- UTC
---- gcc/fortran/gfortranspec.c.orig 2015-06-26 17:47:23 UTC
-+++ gcc/fortran/gfortranspec.c
-@@ -404,7 +404,7 @@ For more information about these matters
- }
- }
-
--#ifdef ENABLE_SHARED_LIBGCC
-+#if 0
- if (library)
- {
- unsigned int i;
-
---- libgfortran/Makefile.in.orig 2019-02-22 14:22:13.000000000 +0000
-+++ libgfortran/Makefile.in 2019-02-27 16:27:08.856408000 +0000
-@@ -625,7 +625,7 @@
- $(LTLDFLAGS) $(LIBQUADLIB) ../libbacktrace/libbacktrace.la \
- $(HWCAP_LDFLAGS) \
- -lm $(extra_ldflags_libgfortran) \
-- $(version_arg) -Wc,-shared-libgcc
-+ $(version_arg)
-
- libgfortran_la_DEPENDENCIES = $(version_dep) libgfortran.spec $(LIBQUADLIB_DEP)
- cafexeclib_LTLIBRARIES = libcaf_single.la
diff --git a/lang/gcc8-devel/files/patch-spe-config b/lang/gcc8-devel/files/patch-spe-config
deleted file mode 100644
index 7a1689898e1f..000000000000
--- a/lang/gcc8-devel/files/patch-spe-config
+++ /dev/null
@@ -1,24 +0,0 @@
---- UTC
-Index: gcc/config.gcc
-===================================================================
---- gcc/config.gcc.orig 2018-06-25 19:34:01.000000000 +0000
-+++ gcc/config.gcc 2018-12-14 04:14:25.044026000 +0000
-@@ -455,7 +455,7 @@
- nvptx-*-*)
- cpu_type=nvptx
- ;;
--powerpc*-*-*spe*)
-+powerpcspe-*-*|powerpc*-*-*spe*)
- cpu_type=powerpcspe
- extra_headers="ppc-asm.h altivec.h spe.h ppu_intrinsics.h paired.h spu2vmx.h vec_types.h si2vmx.h htmintrin.h htmxlintrin.h"
- case x$with_cpu in
-@@ -2413,6 +2413,9 @@
- tm_file="${tm_file} rs6000/default64.h rs6000/freebsd64.h"
- tmake_file="${tmake_file} rs6000/t-freebsd64"
- extra_options="${extra_options} rs6000/linux64.opt"
-+ ;;
-+ powerpcspe-*)
-+ tm_file="${tm_file} powerpcspe/freebsd.h powerpcspe/linuxspe.h powerpcspe/e500.h"
- ;;
- *)
- tm_file="${tm_file} rs6000/freebsd.h"
diff --git a/lang/gcc8-devel/files/pkg-message.in b/lang/gcc8-devel/files/pkg-message.in
deleted file mode 100644
index df3ea725ce59..000000000000
--- a/lang/gcc8-devel/files/pkg-message.in
+++ /dev/null
@@ -1,13 +0,0 @@
-[
-{ type: install
- message: <<EOD
-To ensure binaries built with this toolchain find appropriate versions
-of the necessary run-time libraries, you may want to link using
-
- -Wl,-rpath=%%TARGLIB%%
-
-For ports leveraging USE_GCC, USES=compiler, or USES=fortran this happens
-transparently.
-EOD
-}
-]
diff --git a/lang/gcc8-devel/pkg-descr b/lang/gcc8-devel/pkg-descr
deleted file mode 100644
index 6269fd42b1fd..000000000000
--- a/lang/gcc8-devel/pkg-descr
+++ /dev/null
@@ -1,7 +0,0 @@
-GCC, the GNU Compiler Collection, supports a number of languages.
-This port installs the C, C++, and Fortran front ends as gcc8, g++8,
-and gfortran8, respectively.
-
-WWW: https://gcc.gnu.org
-
-Gerald Pfeifer <gerald@FreeBSD.org>
diff --git a/lang/gcc8-devel/pkg-plist b/lang/gcc8-devel/pkg-plist
deleted file mode 100644
index 8d302f0800b8..000000000000
--- a/lang/gcc8-devel/pkg-plist
+++ /dev/null
@@ -1,33 +0,0 @@
-bin/%%GNU_HOST%%-c++%%SUFFIX%%
-bin/%%GNU_HOST%%-g++%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-%%GCC_VERSION%%
-bin/%%GNU_HOST%%-gcc-ar%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-nm%%SUFFIX%%
-bin/%%GNU_HOST%%-gcc-ranlib%%SUFFIX%%
-bin/%%GNU_HOST%%-gfortran%%SUFFIX%%
-bin/c++%%SUFFIX%%
-bin/cpp%%SUFFIX%%
-bin/g++%%SUFFIX%%
-bin/gcc%%SUFFIX%%
-bin/gcc-ar%%SUFFIX%%
-bin/gcc-nm%%SUFFIX%%
-bin/gcc-ranlib%%SUFFIX%%
-bin/gcov%%SUFFIX%%
-bin/gcov-dump%%SUFFIX%%
-bin/gcov-tool%%SUFFIX%%
-bin/gfortran%%SUFFIX%%
-man/man1/cpp%%SUFFIX%%.1.gz
-man/man1/g++%%SUFFIX%%.1.gz
-man/man1/gcc%%SUFFIX%%.1.gz
-man/man1/gcov%%SUFFIX%%.1.gz
-man/man1/gcov-dump%%SUFFIX%%.1.gz
-man/man1/gcov-tool%%SUFFIX%%.1.gz
-man/man1/gfortran%%SUFFIX%%.1.gz
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/__init__.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/__init__.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/printers.py
-share/gcc-%%GCC_VERSION%%/python/libstdcxx/v6/xmethods.py
-@postexec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
-@postunexec if type ccache-update-links >/dev/null 2>&1; then ccache-update-links -v; fi
-@comment Insert PLIST.lib here
diff --git a/lang/gcc8/Makefile b/lang/gcc8/Makefile
index e0f500cbedaf..2bd0568b9bd1 100644
--- a/lang/gcc8/Makefile
+++ b/lang/gcc8/Makefile
@@ -27,8 +27,6 @@ USES= compiler cpe gmake iconv libtool makeinfo perl5 tar:xz
USE_BINUTILS= yes
USE_PERL5= build
-CONFLICTS= gcc8-devel-8.*
-
CPE_VENDOR= gnu
GCC_VERSION= ${PORTVERSION}