aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Tagato <tagattie@FreeBSD.org>2024-02-12 08:32:16 +0000
committerHiroki Tagato <tagattie@FreeBSD.org>2024-02-12 08:34:15 +0000
commit031172f0529f48f480ec0508b15c8f61ce86a040 (patch)
tree02349e0d6f13b7e4b8f3a65592f6e03d44481df7
parent730828c627631142966c84d4c2943defaad86e4e (diff)
downloadports-031172f0529f48f480ec0508b15c8f61ce86a040.tar.gz
ports-031172f0529f48f480ec0508b15c8f61ce86a040.zip
misc/py-shell-gpt: update to 1.3.0
While here, add DOCS option and update pkg-descr. Changelog: https://github.com/TheR1D/shell_gpt/releases/tag/1.3.0 Reported by: GitHub (watch releases)
-rw-r--r--misc/py-shell-gpt/Makefile15
-rw-r--r--misc/py-shell-gpt/distinfo6
-rw-r--r--misc/py-shell-gpt/pkg-descr13
3 files changed, 20 insertions, 14 deletions
diff --git a/misc/py-shell-gpt/Makefile b/misc/py-shell-gpt/Makefile
index b24039dd30ce..581d77631d50 100644
--- a/misc/py-shell-gpt/Makefile
+++ b/misc/py-shell-gpt/Makefile
@@ -1,24 +1,23 @@
PORTNAME= shell-gpt
-DISTVERSION= 1.2.0
+DISTVERSION= 1.3.0
CATEGORIES= misc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/-/_/}-${DISTVERSION}
MAINTAINER= tagattie@FreeBSD.org
-COMMENT= Command-line productivity tool powered by ChatGPT
+COMMENT= Command-line productivity tool powered by large language models
WWW= https://github.com/TheR1D/shell_gpt
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>0:devel/py-hatchling@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.28.2<3.0.0:www/py-requests@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}litellm>=1.20.1<2.0.0:misc/py-litellm@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typer>=0.7.0<1.0.0:devel/py-typer@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}click>=7.1.1<9.0.0:devel/py-click@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rich>=13.1.0<14.0.0:textproc/py-rich@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}distro>=1.8.0<2.0.0:sysutils/py-distro@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}openai>=1.6.1<2.0.0:misc/py-openai@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}instructor>=0.4.5<1.0.0:misc/py-instructor@${PY_FLAVOR} \
curl:ftp/curl
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests-mock>=1.10.0<2.0.0:www/py-requests-mock@${PY_FLAVOR}
@@ -29,4 +28,12 @@ USE_PYTHON= autoplist pep517 pytest
BINARY_ALIAS= python=${PYTHON_CMD}
NO_ARCH= yes
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/misc/py-shell-gpt/distinfo b/misc/py-shell-gpt/distinfo
index 032416f8c854..91a991382086 100644
--- a/misc/py-shell-gpt/distinfo
+++ b/misc/py-shell-gpt/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1707035719
-SHA256 (shell_gpt-1.2.0.tar.gz) = e11e29cd415b234fa8fa08bc711a9bacfa1397249e6e8fc5bc67ab12eee39deb
-SIZE (shell_gpt-1.2.0.tar.gz) = 37916
+TIMESTAMP = 1707725397
+SHA256 (shell_gpt-1.3.0.tar.gz) = ef8e267997c03c92fce351364ef88fbfa6b0096d4d36e0cc697d64b05c74c71e
+SIZE (shell_gpt-1.3.0.tar.gz) = 37728
diff --git a/misc/py-shell-gpt/pkg-descr b/misc/py-shell-gpt/pkg-descr
index cc3128ff1917..a5ada13166e9 100644
--- a/misc/py-shell-gpt/pkg-descr
+++ b/misc/py-shell-gpt/pkg-descr
@@ -1,7 +1,6 @@
-A command-line productivity tool powered by OpenAI's ChatGPT
-(GPT-3.5). As developers, we can leverage ChatGPT capabilities to
-generate shell commands, code snippets, comments, and documentation,
-among other things. Forget about cheat sheets and notes, with this
-tool you can get accurate answers right in your terminal, and you'll
-probably find yourself reducing your daily Google searches, saving you
-valuable time and effort.
+A command-line productivity tool powered by AI large language models
+(LLM). This command-line tool offers streamlined generation of shell
+commands, code snippets, documentation, eliminating the need for
+external resources (like Google search). Supports Linux, macOS,
+Windows and compatible with all major Shells like PowerShell, CMD,
+Bash, Zsh, etc.