aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteven Wallace <swallace@FreeBSD.org>1995-01-04 08:59:25 +0000
committerSteven Wallace <swallace@FreeBSD.org>1995-01-04 08:59:25 +0000
commit03343bc7fa5ad633d56e9eb3238496101d512343 (patch)
treed3e4ff52484cc3b5bd6d29c65e32a57660d59012
parent877df898f989ac6c30f8088259c81d8eac1a037a (diff)
downloadports-03343bc7fa5ad633d56e9eb3238496101d512343.tar.gz
ports-03343bc7fa5ad633d56e9eb3238496101d512343.zip
xchomp, a pac-man like X game
Notes
Notes: svn path=/head/; revision=697
-rw-r--r--games/xchomp/Makefile20
-rw-r--r--games/xchomp/files/patch-aa19
-rw-r--r--games/xchomp/pkg-comment1
-rw-r--r--games/xchomp/pkg-descr82
-rw-r--r--games/xchomp/pkg-plist2
5 files changed, 124 insertions, 0 deletions
diff --git a/games/xchomp/Makefile b/games/xchomp/Makefile
new file mode 100644
index 000000000000..3e6be37f9f25
--- /dev/null
+++ b/games/xchomp/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: xchomp
+# Version required: 1.1
+# Date created: 4 Jan 1995
+# Whom: swallace
+#
+# $Id: Makefile,v 1.3 1994/12/31 04:17:52 swallace Exp $
+#
+
+DISTNAME= xchomp
+USE_IMAKE= yes
+NO_INSTALL_MANPAGES= yes
+
+#Original sources in multi-part compressed shell archive
+#DISTFILES= part01.Z part02.Z part03.Z part04.Z part05.Z patch1.Z
+#MASTER_SITES= ftp://ftp.wustl.edu/usenet/comp.sources.x/volume06
+
+#Change -DFRAME_DELAY=40000 in patchfile/Imakefile value to adjust
+#speed of play depending on X server.
+
+.include <bsd.port.mk>
diff --git a/games/xchomp/files/patch-aa b/games/xchomp/files/patch-aa
new file mode 100644
index 000000000000..939478cf6d5a
--- /dev/null
+++ b/games/xchomp/files/patch-aa
@@ -0,0 +1,19 @@
+*** Imakefile.orig Mon Apr 23 05:50:51 1990
+--- Imakefile Wed Jan 4 00:23:19 1995
+***************
+*** 2,8 ****
+ #include BandAidCompiler
+ #endif
+
+! DEFINES = -DX11
+ INCLUDES = -I$(TOP) -I$(TOP)/X11
+ DEPLIBS = $(DEPXLIB)
+ LOCAL_LIBRARIES = $(XLIB)
+--- 2,8 ----
+ #include BandAidCompiler
+ #endif
+
+! DEFINES = -DX11 -DFRAME_DELAY=40000
+ INCLUDES = -I$(TOP) -I$(TOP)/X11
+ DEPLIBS = $(DEPXLIB)
+ LOCAL_LIBRARIES = $(XLIB)
diff --git a/games/xchomp/pkg-comment b/games/xchomp/pkg-comment
new file mode 100644
index 000000000000..a3da421cf70d
--- /dev/null
+++ b/games/xchomp/pkg-comment
@@ -0,0 +1 @@
+Pac-man-like game under X Windows
diff --git a/games/xchomp/pkg-descr b/games/xchomp/pkg-descr
new file mode 100644
index 000000000000..93f73da9db6a
--- /dev/null
+++ b/games/xchomp/pkg-descr
@@ -0,0 +1,82 @@
+
+ Xchomp, Version 1.1
+ -------------------
+
+INTRODUCTION
+
+Hello, and welcome to xchomp. Xchomp is a game closely patterned after
+Pac-Man(tm) that runs under the X window system. I've tried to make the
+game as close as possible to the original Pac-Man. However, I have not
+seen a Pac-Man arcade machine for years, so all the elements of the game
+have been recalled from memory. Also, I've added something which I
+always felt was missing from Pac-Man, namely several different mazes.
+
+INSTRUCTIONS FOR PLAYING
+
+The point of this game, as in all arcade-style games, is to amass the
+highest possible score. However, some may find that the fun in the game
+is in trying to reach the highest possible level. At least, that's what
+I thought was fun about the original. You, the player, are the circular
+mouth moving around the maze. Your opponents are the four ghosts following
+you around. Touching a ghost will cost you a life. When you start each
+level, the maze is filled with dots. Eating these dots (by simply going
+over them), gives you 10 points for each. You must eat all the dots on a
+maze to advance to the next level.
+
+On each maze, you will also find several large flashing dots; these are
+the power-dots. Eating one of these will add 50 points to your score,
+and temporarily give you the ability to eat the ghosts. While the ghosts
+can be eaten, they are white (transparent), they move at a reduced speed,
+and they try to run away from you. When they turn back to a solid color,
+they are back to their normal state, and they return to following you
+around. They won't become solid suddenly; they will flash for a couple
+of seconds to warn you. While they're flashing, you can still eat them.
+
+Eating a ghost adds points to your score, and the number of points is
+momentarily displayed on the screen. This action turns the ghost into
+a harmless pair of eyes. In this state, the ghost moves very quickly,
+seeking return to the ghost box in the center of the maze. Once it gets
+there, it is "reborn", and goes back to chasing you around the maze.
+
+The levels of the game are designated by symbols. The first few levels
+are "fruit" levels, that is, they are designated by little pictures of
+fruit on the bottom of the xchomp window. For example, the first level
+is the "cherry" level. Once in a while (twice on every level), the
+symbol corresponding to the current level appears in the maze. It will
+stay there only for a few seconds; eating it adds a number of points to
+your score. At the higher levels, this is a very significant number.
+In any case, when you eat a fruit, or other such symbol, the corresponding
+point value is briefly displayed on the screen.
+
+Reaching a score of 10,000 awards you an extra life.
+
+GAME CONTROLS
+
+This is strictly a keyboard-controlled game. The arcade game had very
+simple controls -- one four-directional joystick. In xchomp, all control
+is through the arrow keys. Hitting an arrow key in xchomp is equivalent
+to pushing the joystick in the corresponding direction and holding it down;
+the player on the screen will continue moving in its current direction
+until motion in the specified direction is possible, in which case it will
+switch to that direction, or until it hits a wall, in which case it will
+stop and wait for a key press corresponding to a valid direction. If this
+sounds complex, forget it, and just play the game. I believe you'll find
+the controls pretty natural. It can be thought of like this: the player
+on the screen will always try to move in the direction of the last key
+pressed, and if it can't, it'll keep moving in the direction it's moving
+until it can. Only one key press is remembered -- the last one. Don't
+hold down the keys; just hit them; otherwise, there may be times when
+you're pressing two keys at a time and the second one won't register.
+
+The game can be paused by pressing the space bar or by iconifying the xchomp
+window (the latter definitely works on Sun and DECwindows servers). While
+the game is paused, you can abort it by pressing 'R'. This will return
+you to the title screen. Pressing 'Q' will cause xchomp to terminate. If
+you iconify the xchomp window, the game will be in the paused state when
+you de-iconify it.
+---
++--------------------+-----------------------+-------------------------------+
+| | Polygen Corporation | UUCP: |
+| Jerry J. Shekhel | Waltham, MA 02254 | {princeton, mit-eddie, |
+| | (617) 890-2888 | buita, sunne}!polygen!jerry |
++--------------------+-----------------------+-------------------------------+
diff --git a/games/xchomp/pkg-plist b/games/xchomp/pkg-plist
new file mode 100644
index 000000000000..5c5105f741e2
--- /dev/null
+++ b/games/xchomp/pkg-plist
@@ -0,0 +1,2 @@
+@cwd /usr/X11R6
+bin/xchomp