aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThibault Payet <monwarez@mailoo.org>2021-08-06 14:07:50 +0000
committerGuangyuan Yang <ygy@FreeBSD.org>2021-08-06 14:14:05 +0000
commit033715ebea0515320f24b2d0984274e97b7a2140 (patch)
tree11b52dcef479301ba5945ce09e3802dcbbae8738
parent2c34153f36e800583600d3a26e932d98cd28e393 (diff)
downloadports-033715ebea0515320f24b2d0984274e97b7a2140.tar.gz
ports-033715ebea0515320f24b2d0984274e97b7a2140.zip
net/socketw: Update to 3.10.27
Changelog: https://github.com/RigsOfRods/socketw/releases/tag/3.10.27 PR: 257657 (cherry picked from commit b69b6e55f09ddc759b3fc8b9a9275c3a19a817bb)
-rw-r--r--net/socketw/Makefile3
-rw-r--r--net/socketw/distinfo6
-rw-r--r--net/socketw/files/patch-src_sw__ssl.cxx83
3 files changed, 4 insertions, 88 deletions
diff --git a/net/socketw/Makefile b/net/socketw/Makefile
index 85b215873a94..1a28d3797bd2 100644
--- a/net/socketw/Makefile
+++ b/net/socketw/Makefile
@@ -1,7 +1,7 @@
# Created by: Thibault Payet <monwarez@mailoo.org>
PORTNAME= socketw
-PORTVERSION= 3.10.26.20180918
+DISTVERSION= 3.10.27
CATEGORIES= net
MAINTAINER= monwarez@mailoo.org
@@ -13,7 +13,6 @@ USES= cmake ssl:build
USE_GITHUB= yes
GH_ACCOUNT= RigsOfRods
-GH_TAGNAME= f8db442
CFLAGS+= -I${OPENSSLINC}
diff --git a/net/socketw/distinfo b/net/socketw/distinfo
index 6635bb180ebb..dd45ffd2db08 100644
--- a/net/socketw/distinfo
+++ b/net/socketw/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1539420870
-SHA256 (RigsOfRods-socketw-3.10.26.20180918-f8db442_GH0.tar.gz) = 94c670bac6f5ec4fa2f37773db43fdb77d9127065af386d08170fb304d5696ec
-SIZE (RigsOfRods-socketw-3.10.26.20180918-f8db442_GH0.tar.gz) = 49810
+TIMESTAMP = 1628243974
+SHA256 (RigsOfRods-socketw-3.10.27_GH0.tar.gz) = 8f25b7ebf85ca12f2c3257e851be2a95819b9ac1ee78884fc4db81c850b5d70e
+SIZE (RigsOfRods-socketw-3.10.27_GH0.tar.gz) = 48424
diff --git a/net/socketw/files/patch-src_sw__ssl.cxx b/net/socketw/files/patch-src_sw__ssl.cxx
deleted file mode 100644
index 620a936bd279..000000000000
--- a/net/socketw/files/patch-src_sw__ssl.cxx
+++ /dev/null
@@ -1,83 +0,0 @@
---- src/sw_ssl.cxx.orig 2018-09-18 09:32:11 UTC
-+++ src/sw_ssl.cxx
-@@ -4,7 +4,7 @@
- // Started 020316
- //
- // License: LGPL v2.1+ (see the file LICENSE)
--// (c)2002-2003 Anders Lindström
-+// (c)2002-2003 Anders Lindström
-
- /***********************************************************************
- * This library is free software; you can redistribute it and/or *
-@@ -22,6 +22,7 @@
- #include <openssl/x509.h>
- #include <openssl/rsa.h>
- #include <openssl/evp.h>
-+#include <cstring>
-
- using namespace std;
-
-@@ -31,7 +32,25 @@ extern int close(int fd);
- extern int fcntl(int fd, int cmd, long arg);
- #endif
-
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
-
-+int X509_get_signature_nid(const X509* peer)
-+{
-+ return OBJ_obj2nid(peer->sig_alg->algorithm);
-+}
-+int X509_certificate_type(const X509 *, const EVP_PKEY *pubkey)
-+{
-+ return pubkey->type;
-+}
-+
-+int SSL_CTX_up_ref(SSL_CTX *ctx)
-+{
-+ return ctx->references++;
-+}
-+
-+#endif
-+
-+
- //====================================================================
- //== Helper functions
- //====================================================================
-@@ -557,7 +576,8 @@ bool SWSSLSocket::get_peerCert_info(SWSSLSocket::peerC
- info->version = X509_get_version(peer);
-
- // Signature algorithm
-- int nid = OBJ_obj2nid(peer->sig_alg->algorithm);
-+
-+ int nid = X509_get_signature_nid(peer);
- if( nid != NID_undef )
- info->sgnAlgorithm = OBJ_nid2sn(nid);
- else
-@@ -566,7 +586,7 @@ bool SWSSLSocket::get_peerCert_info(SWSSLSocket::peerC
- // Key algorithm
- EVP_PKEY *pkey = X509_get_pubkey(peer);
- if( pkey ){
-- info->keyAlgorithm = OBJ_nid2sn(pkey->type);
-+ info->keyAlgorithm = OBJ_nid2sn(X509_certificate_type(peer, pkey));
- info->keySize = 8 * EVP_PKEY_size(pkey);
- }else{
- info->keyAlgorithm = "";
-@@ -689,7 +709,8 @@ bool SWSSLSocket::check_cert(SWBaseError *error)
- }
- }
-
-- if( !(cert = BuildCertificate("SocketW session cert", NULL, NULL, evp_pkey)) ){
-+ char certificateName[22] = "SocketW session cert\0";
-+ if( !(cert = BuildCertificate(certificateName, NULL, NULL, evp_pkey)) ){
- handle_ERRerror(error, fatal, "SWSSLSocket::handle_crypto_data() ");
- return false;
- }
-@@ -718,7 +739,7 @@ SWBaseSocket* SWSSLSocket::create(int socketdescriptor
- // Copy CTX object pointer
- remoteClass->ctx = ctx;
- if( ctx )
-- ctx->references++; // We don't want our destructor to delete ctx if still in use
-+ SSL_CTX_up_ref(ctx);
-
- remoteClass->have_cert = have_cert; // Do CTX have cert loaded?
-