aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2023-12-17 21:27:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2023-12-17 21:27:11 +0000
commit038ccecdc309fd169e797addd6456b0c65891059 (patch)
tree9518fe59e70160e27cf107287553f55447b30660
parentb3f1221aa9b8eb4ce326098f2d51069440cb8d61 (diff)
www/py-fake-useragent: Use pep517 macro instead of dummy setup.py
-rw-r--r--www/py-fake-useragent/Makefile7
-rw-r--r--www/py-fake-useragent/files/patch-setup.py6
2 files changed, 5 insertions, 8 deletions
diff --git a/www/py-fake-useragent/Makefile b/www/py-fake-useragent/Makefile
index 282672aceab9..0887f786d3e3 100644
--- a/www/py-fake-useragent/Makefile
+++ b/www/py-fake-useragent/Makefile
@@ -1,5 +1,6 @@
PORTNAME= fake-useragent
-PORTVERSION= 1.4.0
+DISTVERSION= 1.4.0
+PORTREVISION= 1
CATEGORIES= www python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -10,12 +11,14 @@ WWW= https://pypi.org/project/fake-useragent/
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PY_SETUPTOOLS} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}importlib-metadata>=4.0:devel/py-importlib-metadata@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}importlib-resources>=5.0:devel/py-importlib-resources@${PY_FLAVOR}
USES= python
USE_GITHUB= yes
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist pep517
NO_ARCH= yes
diff --git a/www/py-fake-useragent/files/patch-setup.py b/www/py-fake-useragent/files/patch-setup.py
deleted file mode 100644
index 130806a8f6f1..000000000000
--- a/www/py-fake-useragent/files/patch-setup.py
+++ /dev/null
@@ -1,6 +0,0 @@
---- setup.py.orig 2022-11-12 09:41:13 UTC
-+++ setup.py
-@@ -0,0 +1,3 @@
-+import setuptools
-+if __name__ == "__main__":
-+ setuptools.setup(use_scm_version=False)