aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2024-02-25 04:52:05 +0000
committerJan Beich <jbeich@FreeBSD.org>2024-02-25 10:30:39 +0000
commit03e850d1923aa4e01980ab51302122569c3f3694 (patch)
tree1906e22d0660290958c7a2a663222b5958956d7d
parent881fe88502d161e43694c43248cdafd44dc3bdd0 (diff)
downloadports-03e850d1923aa4e01980ab51302122569c3f3694.tar.gz
ports-03e850d1923aa4e01980ab51302122569c3f3694.zip
x11-wm/cosmic-comp: unbreak build on 32-bit architectures
thread 'coordinator' panicked at compiler/rustc_middle/src/util/bug.rsfatal runtime error: Rust cannot catch foreign exceptions :36:26: /wrkdirs/usr/ports/lang/rust/work/rustc-1.76.0-src/compiler/rustc_codegen_ssa/src/back/write.rs:1586:29: worker thread panicked (signal: 6, SIGABRT: process abort signal) Reported by: pkg-fallout
-rw-r--r--x11-wm/cosmic-comp/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11-wm/cosmic-comp/Makefile b/x11-wm/cosmic-comp/Makefile
index b95e9b006702..2180f3f8ca44 100644
--- a/x11-wm/cosmic-comp/Makefile
+++ b/x11-wm/cosmic-comp/Makefile
@@ -27,6 +27,12 @@ CARGO_FEATURES= --no-default-features # disable systemd
PLIST_FILES= bin/${PORTNAME} \
share/wayland-sessions/${PORTNAME:S/-comp//}.desktop \
+.if ${MACHINE_ARCH} == i386 || ${MACHINE_ARCH:Marmv?}
+# https://github.com/rust-lang/rust/issues/85598
+LTO_UNSAFE= yes
+CARGO_ENV+= CARGO_PROFILE_RELEASE_LTO=false
+.endif
+
post-patch:
# XXX Strip double / to help "make cargo-crates"
@${REINPLACE_CMD} -e 's,\(smithay\)//,\1/,' \