aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2024-01-24 07:56:53 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2024-01-24 08:26:00 +0000
commit0415d9fd18195eae46ab89e177af87809c6c0408 (patch)
tree71c9cf190982faf71a3e07fb93ccd0de31a0f1bc
parent8089b655316d535821df38af50e7adc41ac7d39b (diff)
downloadports-0415d9fd18195eae46ab89e177af87809c6c0408.tar.gz
ports-0415d9fd18195eae46ab89e177af87809c6c0408.zip
math/stanmath: update 4.7.0 → 4.8.1
Reported by: portscout
-rw-r--r--math/stanmath/Makefile8
-rw-r--r--math/stanmath/distinfo6
-rw-r--r--math/stanmath/pkg-plist9
3 files changed, 17 insertions, 6 deletions
diff --git a/math/stanmath/Makefile b/math/stanmath/Makefile
index 32f883f294a6..49abb795e4dd 100644
--- a/math/stanmath/Makefile
+++ b/math/stanmath/Makefile
@@ -1,6 +1,6 @@
PORTNAME= stanmath
DISTVERSIONPREFIX= v
-DISTVERSION= 4.7.0
+DISTVERSION= 4.8.1
CATEGORIES= math
MAINTAINER= yuri@FreeBSD.org
@@ -14,7 +14,7 @@ RUN_DEPENDS= ${LOCALBASE}/include/boost/math/constants/constants.hpp:devel/boost
${LOCALBASE}/include/tbb/task_arena.h:devel/onetbb # compiler define -DTBB_INTERFACE_NEW chooses oneTBB as opposed to TBB
TEST_DEPENDS= gmake:devel/gmake
-USES= eigen:3,run python:test shebangfix
+USES= eigen:3,run gmake python:test shebangfix
USE_GITHUB= yes
GH_ACCOUNT= stan-dev
@@ -24,13 +24,15 @@ SHEBANG_FILES= runTests.py
MAKE_ENV= TBB_LIB="${LOCALBASE}/lib"
+BINARY_ALIAS= make=${GMAKE}
+
NO_BUILD= yes
NO_ARCH= yes
do-install:
@cd ${WRKSRC} && ${COPYTREE_SHARE} stan ${STAGEDIR}${PREFIX}/include
-do-test: # fails to compile: https://github.com/stan-dev/math/issues/2571
+do-test: # fails to link with TBB, see https://github.com/stan-dev/math/issues/2851
@cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ./runTests.py test/unit test/prob
.include <bsd.port.mk>
diff --git a/math/stanmath/distinfo b/math/stanmath/distinfo
index 80ce83024567..0d6667634bee 100644
--- a/math/stanmath/distinfo
+++ b/math/stanmath/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1693983643
-SHA256 (stan-dev-math-v4.7.0_GH0.tar.gz) = c314325d20c3f4a3b6eda31b41f84f71c3fff9521906b5c3ff671e5702ded92f
-SIZE (stan-dev-math-v4.7.0_GH0.tar.gz) = 30466004
+TIMESTAMP = 1706081004
+SHA256 (stan-dev-math-v4.8.1_GH0.tar.gz) = 78e115c89c298fb9e6fa5941b7e39c84cfea0a8f491a0dc556ab5746d5699136
+SIZE (stan-dev-math-v4.8.1_GH0.tar.gz) = 30104206
diff --git a/math/stanmath/pkg-plist b/math/stanmath/pkg-plist
index 273562441ce7..30ac8e0bd7c5 100644
--- a/math/stanmath/pkg-plist
+++ b/math/stanmath/pkg-plist
@@ -143,8 +143,10 @@ include/stan/math/fwd/fun/value_of.hpp
include/stan/math/fwd/fun/value_of_rec.hpp
include/stan/math/fwd/functor.hpp
include/stan/math/fwd/functor/apply_scalar_unary.hpp
+include/stan/math/fwd/functor/finite_diff.hpp
include/stan/math/fwd/functor/gradient.hpp
include/stan/math/fwd/functor/hessian.hpp
+include/stan/math/fwd/functor/integrate_1d.hpp
include/stan/math/fwd/functor/jacobian.hpp
include/stan/math/fwd/functor/operands_and_partials.hpp
include/stan/math/fwd/functor/partials_propagator.hpp
@@ -185,6 +187,7 @@ include/stan/math/opencl/kernel_generator.hpp
include/stan/math/opencl/kernel_generator/append.hpp
include/stan/math/opencl/kernel_generator/as_column_vector_or_scalar.hpp
include/stan/math/opencl/kernel_generator/as_operation_cl.hpp
+include/stan/math/opencl/kernel_generator/assignment_ops.hpp
include/stan/math/opencl/kernel_generator/binary_operation.hpp
include/stan/math/opencl/kernel_generator/block_zero_based.hpp
include/stan/math/opencl/kernel_generator/broadcast.hpp
@@ -288,6 +291,7 @@ include/stan/math/opencl/prim/bernoulli_lpmf.hpp
include/stan/math/opencl/prim/beta_binomial_lpmf.hpp
include/stan/math/opencl/prim/beta_lpdf.hpp
include/stan/math/opencl/prim/beta_proportion_lpdf.hpp
+include/stan/math/opencl/prim/binomial_logit_glm_lpmf.hpp
include/stan/math/opencl/prim/binomial_logit_lpmf.hpp
include/stan/math/opencl/prim/binomial_lpmf.hpp
include/stan/math/opencl/prim/block.hpp
@@ -508,6 +512,7 @@ include/stan/math/opencl/rev/floor.hpp
include/stan/math/opencl/rev/fmax.hpp
include/stan/math/opencl/rev/fmin.hpp
include/stan/math/opencl/rev/fmod.hpp
+include/stan/math/opencl/rev/grad.hpp
include/stan/math/opencl/rev/hypot.hpp
include/stan/math/opencl/rev/inv.hpp
include/stan/math/opencl/rev/inv_Phi.hpp
@@ -1002,6 +1007,7 @@ include/stan/math/prim/fun/scaled_add.hpp
include/stan/math/prim/fun/sd.hpp
include/stan/math/prim/fun/segment.hpp
include/stan/math/prim/fun/select.hpp
+include/stan/math/prim/fun/serializer.hpp
include/stan/math/prim/fun/sign.hpp
include/stan/math/prim/fun/signbit.hpp
include/stan/math/prim/fun/simplex_constrain.hpp
@@ -1220,6 +1226,7 @@ include/stan/math/prim/prob/binomial_cdf_log.hpp
include/stan/math/prim/prob/binomial_lccdf.hpp
include/stan/math/prim/prob/binomial_lcdf.hpp
include/stan/math/prim/prob/binomial_log.hpp
+include/stan/math/prim/prob/binomial_logit_glm_lpmf.hpp
include/stan/math/prim/prob/binomial_logit_log.hpp
include/stan/math/prim/prob/binomial_logit_lpmf.hpp
include/stan/math/prim/prob/binomial_lpmf.hpp
@@ -1250,6 +1257,8 @@ include/stan/math/prim/prob/chi_square_rng.hpp
include/stan/math/prim/prob/dirichlet_log.hpp
include/stan/math/prim/prob/dirichlet_lpdf.hpp
include/stan/math/prim/prob/dirichlet_lpmf.hpp
+include/stan/math/prim/prob/dirichlet_multinomial_lpmf.hpp
+include/stan/math/prim/prob/dirichlet_multinomial_rng.hpp
include/stan/math/prim/prob/dirichlet_rng.hpp
include/stan/math/prim/prob/discrete_range_ccdf_log.hpp
include/stan/math/prim/prob/discrete_range_cdf.hpp