aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2010-03-28 04:44:55 +0000
committerDoug Barton <dougb@FreeBSD.org>2010-03-28 04:44:55 +0000
commit045030410823853fcaee9042f4e1670a9da7caef (patch)
tree42ba2c5101f78b89c9b7bb3085073058c04cd034
parent1cf2d1f305b2585356800e21a9660a45ad4483f7 (diff)
downloadports-045030410823853fcaee9042f4e1670a9da7caef.tar.gz
ports-045030410823853fcaee9042f4e1670a9da7caef.zip
Cleanse uneeded RC_SUBR variables
Approved by: pgolluci
Notes
Notes: svn path=/head/; revision=251602
-rw-r--r--www/apache13-modssl/Makefile1
-rw-r--r--www/apache13-modssl/files/apache.in2
-rw-r--r--www/apache20/Makefile2
-rw-r--r--www/apache20/files/apache2.sh.in2
-rw-r--r--www/nginx-devel/Makefile2
-rw-r--r--www/nginx-devel/files/nginx.sh.in2
-rw-r--r--www/nginx/Makefile2
-rw-r--r--www/nginx/files/nginx.sh.in2
8 files changed, 6 insertions, 9 deletions
diff --git a/www/apache13-modssl/Makefile b/www/apache13-modssl/Makefile
index f1e6fae883bb..9e67b349537b 100644
--- a/www/apache13-modssl/Makefile
+++ b/www/apache13-modssl/Makefile
@@ -55,7 +55,6 @@ MASTER_SITES_MODSSL= http://www.modssl.org/source/ \
${MASTER_SITE_RINGSERVER:S,%SUBDIR%,net/www/mod_ssl/source,}
MODSSL_FILE= mod_ssl-${VERSION_MODSSL}-${VERSION_APACHE}${EXTRACT_SUFX}
MODSNMP_FILE= mod_snmp_${VERSION_MODSNMP}${EXTRACT_SUFX}
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
USE_RC_SUBR= apache
diff --git a/www/apache13-modssl/files/apache.in b/www/apache13-modssl/files/apache.in
index 95f8bb7fd321..5590ae86dca9 100644
--- a/www/apache13-modssl/files/apache.in
+++ b/www/apache13-modssl/files/apache.in
@@ -114,7 +114,7 @@ else
;;
esac
echo "===> apache profile: ${profile}"
- %%PREFIX%%/etc/rc.d/apache%%RC_SUBR_SUFFIX%% $1 ${profile}
+ %%PREFIX%%/etc/rc.d/apache $1 ${profile}
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${profile} (${retcode}) ${failed:-}"
diff --git a/www/apache20/Makefile b/www/apache20/Makefile
index e1b759ba48c7..922c6eccee80 100644
--- a/www/apache20/Makefile
+++ b/www/apache20/Makefile
@@ -54,7 +54,6 @@ USE_ICONV= yes
USE_AUTOTOOLS= autoconf:262 libtool:22
USE_PERL5= yes
USE_RC_SUBR= apache2.sh
-SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX}
USE_APACHE= common20
LIBTOOLFILES= configure
USE_LDCONFIG= ${PREFIX}/lib/apache2
@@ -75,7 +74,6 @@ CONFIGURE_ENV= CC="${CC}" CPPFLAGS="${CPPFLAGS}" \
LOCALBASE="${LOCALBASE}"
PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
-RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
MAKE_ENV+= EXPR_COMPAT=yes
diff --git a/www/apache20/files/apache2.sh.in b/www/apache20/files/apache2.sh.in
index 6e3b5112d55d..0b767a7fc1cf 100644
--- a/www/apache20/files/apache2.sh.in
+++ b/www/apache20/files/apache2.sh.in
@@ -71,7 +71,7 @@ else
if [ "x${apache2_profiles}" != "x" -a "x$1" != "x" ]; then
for profile in ${apache2_profiles}; do
echo "===> apache2 profile: ${profile}"
- %%PREFIX%%/etc/rc.d/apache2%%RC_SUBR_SUFFIX%% $1 ${profile}
+ %%PREFIX%%/etc/rc.d/apache2 $1 ${profile}
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${profile} (${retcode}) ${failed:-}"
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index 7ad35f34ac64..983c23d9753a 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -95,7 +95,7 @@ NGINX_ERRORLOG?= ${NGINX_LOGDIR}/nginx-error.log
CONFLICTS?= nginx-0.7.*
USE_RC_SUBR= nginx.sh
-SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX} WWWOWN=${WWWOWN}
+SUB_LIST+= WWWOWN=${WWWOWN}
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${ETCDIR} \
diff --git a/www/nginx-devel/files/nginx.sh.in b/www/nginx-devel/files/nginx.sh.in
index e0992e201d49..7e6d0d19c869 100644
--- a/www/nginx-devel/files/nginx.sh.in
+++ b/www/nginx-devel/files/nginx.sh.in
@@ -64,7 +64,7 @@ else
if [ "x${nginx_profiles}" != "x" -a "x$1" != "x" ]; then
for profile in ${nginx_profiles}; do
echo "===> nginx profile: ${profile}"
- %%PREFIX%%/etc/rc.d/nginx%%RC_SUBR_SUFFIX%% $1 ${profile}
+ %%PREFIX%%/etc/rc.d/nginx $1 ${profile}
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${profile} (${retcode}) ${failed:-}"
diff --git a/www/nginx/Makefile b/www/nginx/Makefile
index a3b488b48530..844452c60544 100644
--- a/www/nginx/Makefile
+++ b/www/nginx/Makefile
@@ -92,7 +92,7 @@ NGINX_ERRORLOG?= ${NGINX_LOGDIR}/nginx-error.log
CONFLICTS?= nginx-devel-0.*
USE_RC_SUBR= nginx.sh
-SUB_LIST+= RC_SUBR_SUFFIX=${RC_SUBR_SUFFIX} WWWOWN=${WWWOWN}
+SUB_LIST+= WWWOWN=${WWWOWN}
HAS_CONFIGURE= yes
CONFIGURE_ARGS+=--prefix=${ETCDIR} \
diff --git a/www/nginx/files/nginx.sh.in b/www/nginx/files/nginx.sh.in
index e0992e201d49..7e6d0d19c869 100644
--- a/www/nginx/files/nginx.sh.in
+++ b/www/nginx/files/nginx.sh.in
@@ -64,7 +64,7 @@ else
if [ "x${nginx_profiles}" != "x" -a "x$1" != "x" ]; then
for profile in ${nginx_profiles}; do
echo "===> nginx profile: ${profile}"
- %%PREFIX%%/etc/rc.d/nginx%%RC_SUBR_SUFFIX%% $1 ${profile}
+ %%PREFIX%%/etc/rc.d/nginx $1 ${profile}
retcode="$?"
if [ "0${retcode}" -ne 0 ]; then
failed="${profile} (${retcode}) ${failed:-}"