aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2024-11-01 13:24:13 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2024-11-01 14:14:38 +0000
commit049f13bc6a60bd458d82a1aedebdcc4ebbaf1436 (patch)
treed17d6b74a78a0fceceda1883225c1ecf57fa9e34
parent9053715487cb19b53270782a21ac62e29290fcf2 (diff)
sysutils/fusefs-curlftpfs: Add debian patches
Update curlftpfs code by integration additional debian patches who provide multiple fixes. Major changes: * fix-CURLOPT_INFILESIZE : Fix an unsupported curl value (-1) for CURLOPT_INFILESIZE option. * free_ftpfs_file-memleak-fix: Fix a memory leak. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587250 * nocache-memleak-fix : Fix a memory leak when cache is disabled. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=614347 * curlftpfs__no_verify_hostname : Fix no_verify_hostname option with recent versions of curl * consistent feature flag : ensure consistent use of _XOPEN_SOURCE * getpass prototype : add getpass() prototype * Fix a typo in one of our patches who does an urlencode of paths. Bump portrevision PR: 282358 Reported by: diizzy
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile11
-rw-r--r--sysutils/fusefs-curlftpfs/distinfo15
-rw-r--r--sysutils/fusefs-curlftpfs/files/patch-path__utils.c2
3 files changed, 24 insertions, 4 deletions
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
index 50c771dca219..038e07337dfa 100644
--- a/sysutils/fusefs-curlftpfs/Makefile
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -1,9 +1,18 @@
PORTNAME= curlftpfs
PORTVERSION= 0.9.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= SF
PKGNAMEPREFIX= fusefs-
+DIST_SUBDIR= ${PORTNAME}
+
+PATCH_SITES= https://sources.debian.org/data/main/c/curlftpfs/0.9.2-9/debian/patches/
+PATCHFILES= fix-CURLOPT_INFILESIZE.patch \
+ free_ftpfs_file-memleak-fix.patch \
+ nocache-memleak-fix.patch \
+ curlftpfs__no_verify_hostname.patch \
+ consistent-feature-flag.patch
+PATCH_DIST_STRIP= -p1
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= Mount remote FTP directories
diff --git a/sysutils/fusefs-curlftpfs/distinfo b/sysutils/fusefs-curlftpfs/distinfo
index 4e2622d3d992..822419798166 100644
--- a/sysutils/fusefs-curlftpfs/distinfo
+++ b/sysutils/fusefs-curlftpfs/distinfo
@@ -1,2 +1,13 @@
-SHA256 (curlftpfs-0.9.2.tar.gz) = 4eb44739c7078ba0edde177bdd266c4cfb7c621075f47f64c85a06b12b3c6958
-SIZE (curlftpfs-0.9.2.tar.gz) = 365503
+TIMESTAMP = 1730467218
+SHA256 (curlftpfs/curlftpfs-0.9.2.tar.gz) = 4eb44739c7078ba0edde177bdd266c4cfb7c621075f47f64c85a06b12b3c6958
+SIZE (curlftpfs/curlftpfs-0.9.2.tar.gz) = 365503
+SHA256 (curlftpfs/fix-CURLOPT_INFILESIZE.patch) = 19734139dfcd5252f5b8005343afba89e809bed6b476901c24dc6c3535e36501
+SIZE (curlftpfs/fix-CURLOPT_INFILESIZE.patch) = 644
+SHA256 (curlftpfs/free_ftpfs_file-memleak-fix.patch) = accd3b5a322bacbf4ccdc8433ce3fc97b6d6284a56ab29daa1579424e7e41f39
+SIZE (curlftpfs/free_ftpfs_file-memleak-fix.patch) = 425
+SHA256 (curlftpfs/nocache-memleak-fix.patch) = 75db4498ca4879078e25e87da4ef57d648f22aee692e3b5ae23030762f6b4ac2
+SIZE (curlftpfs/nocache-memleak-fix.patch) = 1864
+SHA256 (curlftpfs/curlftpfs__no_verify_hostname.patch) = f69d4537447acbb559a14efbd8f880cde2b20f06ca2b0edd2229f8bb319675db
+SIZE (curlftpfs/curlftpfs__no_verify_hostname.patch) = 872
+SHA256 (curlftpfs/consistent-feature-flag.patch) = afd83c6640c281517e9aea548f760f911e4f5bf00485645e4368ffb0b90c9784
+SIZE (curlftpfs/consistent-feature-flag.patch) = 1724
diff --git a/sysutils/fusefs-curlftpfs/files/patch-path__utils.c b/sysutils/fusefs-curlftpfs/files/patch-path__utils.c
index 9ce6c500dbab..7855c90e7043 100644
--- a/sysutils/fusefs-curlftpfs/files/patch-path__utils.c
+++ b/sysutils/fusefs-curlftpfs/files/patch-path__utils.c
@@ -12,7 +12,7 @@
+static inline int is_unreserved_rfc3986(char c)
+{
+ int is_locase_alpha = (c >= 'a' && c <= 'z');
-+ int is_upcase_alpha = (c >= 'a' && c <= 'z');
++ int is_upcase_alpha = (c >= 'A' && c <= 'Z');
+ int is_digit = (c >= '0' && c <= '9');
+ int is_special = c == '-'
+ || c == '.'