aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2024-05-05 17:20:52 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2024-05-06 19:11:21 +0000
commit04a50fdffdfcf12183556b691aa138ef7a173d59 (patch)
treee71988e122ff1b24f68bfb3e0142eed61bf176e3
parentacd3c137f3e308c54257087623be47bba0bf89c9 (diff)
downloadports-04a50fdffdfcf12183556b691aa138ef7a173d59.tar.gz
ports-04a50fdffdfcf12183556b691aa138ef7a173d59.zip
sysutils/slurm-wlm: add correct linker emulation for aarch64
Approved by: portmgr (blanket) MFH: 2024Q2
-rw-r--r--sysutils/slurm-wlm/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/sysutils/slurm-wlm/Makefile b/sysutils/slurm-wlm/Makefile
index 88eae618e62e..3355f4090c56 100644
--- a/sysutils/slurm-wlm/Makefile
+++ b/sysutils/slurm-wlm/Makefile
@@ -150,6 +150,9 @@ pre-configure:
.elif ${ARCH} == powerpc64
${FIND} ${LLD2FIX:C|^|${WRKSRC}/src/|} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|-r -o|-r -m elf64ppc -o|'
+.elif ${ARCH} == aarch64
+ ${FIND} ${LLD2FIX:C|^|${WRKSRC}/src/|} -name Makefile.in | ${XARGS} \
+ ${REINPLACE_CMD} -e 's|-r -o|-r -m aarch64elf -o|'
.else
${FIND} ${LLD2FIX:C|^|${WRKSRC}/src/|} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|-r -o|-r -m elf_${ARCH} -o|'