aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2018-05-07 17:14:43 +0000
committerKurt Jaeger <pi@FreeBSD.org>2018-05-07 17:14:43 +0000
commit04eb8ddb0be7b2bcf54ecdc94405ab2cf93106bc (patch)
tree1db3f5c52954eefff1dea7973cb281776d673ebb
parent852654c6fac6ba161c69c43b257b778f7ebc3416 (diff)
downloadports-04eb8ddb0be7b2bcf54ecdc94405ab2cf93106bc.tar.gz
ports-04eb8ddb0be7b2bcf54ecdc94405ab2cf93106bc.zip
New port: graphics/p5-Image-PNG-Libpng
Image::PNG::Libpng is a Perl library for accessing the contents of PNG (Portable Network Graphics) images. Image::PNG::Libpng enables Perl to use the "libpng" library for reading and writing files in the PNG format. Image::PNG::Libpng consists of Perl subroutines which mirror the C functions in libpng, plus helper subroutines to make it easier to read and write PNG data in Perl. WWW: http://search.cpan.org/dist/Image-PNG-Libpng/ PR: 227751 Submitted by: Greg Kennedy <kennedy.greg@gmail.com>
Notes
Notes: svn path=/head/; revision=469298
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-Image-PNG-Libpng/Makefile24
-rw-r--r--graphics/p5-Image-PNG-Libpng/distinfo3
-rw-r--r--graphics/p5-Image-PNG-Libpng/pkg-descr10
-rw-r--r--graphics/p5-Image-PNG-Libpng/pkg-plist9
5 files changed, 47 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 644b739056fd..f5d0f6fe9a8c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -753,6 +753,7 @@
SUBDIR += p5-Image-MetaData-JPEG
SUBDIR += p5-Image-ObjectDetect
SUBDIR += p5-Image-PBMlib
+ SUBDIR += p5-Image-PNG-Libpng
SUBDIR += p5-Image-Pngslimmer
SUBDIR += p5-Image-Sane
SUBDIR += p5-Image-Scale
diff --git a/graphics/p5-Image-PNG-Libpng/Makefile b/graphics/p5-Image-PNG-Libpng/Makefile
new file mode 100644
index 000000000000..f32e22a7a641
--- /dev/null
+++ b/graphics/p5-Image-PNG-Libpng/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= Image-PNG-Libpng
+DISTVERSION= 0.45
+CATEGORIES= graphics perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl interface to the C library "libpng"
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+LIB_DEPENDS= libpng.so:graphics/png
+
+USES= perl5
+USE_PERL5= 5.8.1+ configure
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|# *INC *=> *$$inc|INC => "-I${LOCALBASE}/include"|' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-Image-PNG-Libpng/distinfo b/graphics/p5-Image-PNG-Libpng/distinfo
new file mode 100644
index 000000000000..183df5be1047
--- /dev/null
+++ b/graphics/p5-Image-PNG-Libpng/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1524547415
+SHA256 (Image-PNG-Libpng-0.45.tar.gz) = 00424fbe28efe9978dc9c96877989be897a2e8ddb3132e63903c54ae0cb1c353
+SIZE (Image-PNG-Libpng-0.45.tar.gz) = 220492
diff --git a/graphics/p5-Image-PNG-Libpng/pkg-descr b/graphics/p5-Image-PNG-Libpng/pkg-descr
new file mode 100644
index 000000000000..cd7bf98bf4c9
--- /dev/null
+++ b/graphics/p5-Image-PNG-Libpng/pkg-descr
@@ -0,0 +1,10 @@
+Image::PNG::Libpng is a Perl library for accessing the contents of
+PNG (Portable Network Graphics) images. Image::PNG::Libpng enables
+Perl to use the "libpng" library for reading and writing files in
+the PNG format.
+
+Image::PNG::Libpng consists of Perl subroutines which mirror the C
+functions in libpng, plus helper subroutines to make it easier to
+read and write PNG data in Perl.
+
+WWW: http://search.cpan.org/dist/Image-PNG-Libpng/
diff --git a/graphics/p5-Image-PNG-Libpng/pkg-plist b/graphics/p5-Image-PNG-Libpng/pkg-plist
new file mode 100644
index 000000000000..852eddd79b97
--- /dev/null
+++ b/graphics/p5-Image-PNG-Libpng/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_ARCH%%/auto/Image/PNG/Libpng/Libpng.so
+%%SITE_ARCH%%/Image/PNG/Libpng.pm
+%%SITE_ARCH%%/Image/PNG/Const.pm
+%%SITE_ARCH%%/Image/PNG/Libpng.pod
+%%SITE_ARCH%%/Image/PNG/memory-test.pl
+%%PERL5_MAN1%%/pnginspect.1.gz
+%%PERL5_MAN3%%/Image::PNG::Const.3.gz
+%%PERL5_MAN3%%/Image::PNG::Libpng.3.gz
+bin/pnginspect