aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:09:05 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-12-20 19:09:05 +0000
commit04f27771e787c718af841e76e8a092ee37812663 (patch)
treeb124bb18c6d57e9317409b1e24cc21872d155929
parent97f8402e5f89684005257c9f1ee00321115890ed (diff)
downloadports-04f27771e787c718af841e76e8a092ee37812663.tar.gz
ports-04f27771e787c718af841e76e8a092ee37812663.zip
Fix build with clang
PR: ports/184878 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Notes
Notes: svn path=/head/; revision=337078
-rw-r--r--x11/tycoon/Makefile17
-rw-r--r--x11/tycoon/files/patch-ac19
-rw-r--r--x11/tycoon/pkg-descr2
3 files changed, 21 insertions, 17 deletions
diff --git a/x11/tycoon/Makefile b/x11/tycoon/Makefile
index 3c844575d7fd..6c2944935f62 100644
--- a/x11/tycoon/Makefile
+++ b/x11/tycoon/Makefile
@@ -5,24 +5,25 @@ PORTNAME= tycoon
PORTVERSION= 1.07o
PORTREVISION= 5
CATEGORIES= x11
-MASTER_SITES= ${MASTER_SITE_SUNSITE}
-MASTER_SITE_SUBDIR= X11/desktop
+MASTER_SITES= SUNSITE/X11/desktop
MAINTAINER= ports@FreeBSD.org
COMMENT= Nifty set of desktop apps, including floating buttons
-LIB_DEPENDS= forms.2:${PORTSDIR}/x11-toolkits/xforms
+LIB_DEPENDS= libforms.so:${PORTSDIR}/x11-toolkits/xforms
USES= imake
USE_XORG= xaw
-REINPLACE_ARGS= -i ""
-NO_STAGE= yes
post-patch:
- ${RM} -f ${WRKSRC}/xbackdrop/backdrops/index~
- ${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
+ @${REINPLACE_CMD} -e 's,/usr/lib,${PREFIX}/lib,' \
${WRKSRC}/xbackdrop/backdrops/index
- ${FIND} ${WRKSRC} -name '*.c' -type f | ${XARGS} ${REINPLACE_CMD} -e \
+ @${REINPLACE_CMD} -e 's|^update_file|void update_file|' \
+ ${WRKSRC}/xchooser/xchooser.c
+ @${FIND} ${WRKSRC} -name '*.c' -type f | ${XARGS} ${REINPLACE_CMD} -e \
's,FL_REVISION>=80,FL_REVISION >= 80 || FL_VERSION != 0,g'
+pre-configure:
+ @${RM} -f ${WRKSRC}/xbackdrop/backdrops/index?*
+
.include <bsd.port.mk>
diff --git a/x11/tycoon/files/patch-ac b/x11/tycoon/files/patch-ac
index 818830025ad3..ea9b55dc277b 100644
--- a/x11/tycoon/files/patch-ac
+++ b/x11/tycoon/files/patch-ac
@@ -1,6 +1,6 @@
--- xbackdrop/Imakefile.orig Sat Mar 9 22:41:13 1996
+++ xbackdrop/Imakefile Wed Nov 1 08:19:17 2000
-@@ -1,24 +1,28 @@
+@@ -1,26 +1,27 @@
-XBACKDROP_DIR = /usr/lib/X11/backdrops
+XCOMM
+XCOMM FBSD--SF--I'm not sure about this location--backdrops??
@@ -28,12 +28,15 @@
+ComplexProgramTargetNoMan(xbackdrop)
-install:: xbackdrop @@\
-+install:: xbackdrop @@\
- @if [ -d $(XBACKDROP_DIR) ]; then set +x; \ @@\
- else (set -x; $(MKDIRHIER) $(XBACKDROP_DIR)); fi @@\
- cp backdrops/?* $(XBACKDROP_DIR); @@\
+- @if [ -d $(XBACKDROP_DIR) ]; then set +x; \ @@\
+- else (set -x; $(MKDIRHIER) $(XBACKDROP_DIR)); fi @@\
+- cp backdrops/?* $(XBACKDROP_DIR); @@\
- chown root.root $(XBACKDROP_DIR) $(XBACKDROP_DIR)/?*; @@\
-+ chown root:daemon $(XBACKDROP_DIR) $(XBACKDROP_DIR)/?*; @@\
- chmod 0755 $(XBACKDROP_DIR); @@\
- chmod 0644 $(XBACKDROP_DIR)/?*; @@\
+- chmod 0755 $(XBACKDROP_DIR); @@\
+- chmod 0644 $(XBACKDROP_DIR)/?*; @@\
++install:: xbackdrop @@\
++ @if [ -d $(DESTDIR)$(XBACKDROP_DIR) ]; then set +x; \ @@\
++ else (set -x; $(MKDIRHIER) $(DESTDIR)$(XBACKDROP_DIR)); fi @@\
++ $(INSTALL) $(INSTALLFLAGS) $(INSTDATFLAGS) backdrops/?* $(DESTDIR)$(XBACKDROP_DIR); @@\
+
diff --git a/x11/tycoon/pkg-descr b/x11/tycoon/pkg-descr
index b5062fe26f89..ff3fffc924b0 100644
--- a/x11/tycoon/pkg-descr
+++ b/x11/tycoon/pkg-descr
@@ -4,5 +4,5 @@ is remembered and restored on the next run.
Right now I have put into tycoon support for OffiX drag-and-drop,
so now you can drag icons from the OffiX filemanager into tycoon
-icons and have apppropriate action invoked. Check out OffiX, it's
+icons and have appropriate action invoked. Check out OffiX, it's
very fine package.