aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-10 10:11:00 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:18 +0000
commit05044ea01992c28028cc87f374560aad1b6c595d (patch)
treed238fa9faf70458ab3b928a3ca716de78e7d7863
parent0ee9911e8c932f92e7aac08aa64c52b5dbd71f14 (diff)
downloadports-05044ea.tar.gz
ports-05044ea.zip
math/Imath: new port (replaces graphics/ilmbase)
Patch series to update OpenEXR and ports that depend on ilmbase/OpenEXR coming up. --------------- Imath is a basic, light-weight, and efficient C++ representation of 2D and 3D vectors and matrices and other simple but useful mathematical objects, functions, and data types common in computer graphics applications, including the "half" 16-bit floating-point type. Imath also includes optional python bindings for all types and functions, including optimized implementations of vector and matrix arrays. Imath was originally developed at Industrial Light & Magic in the early 2000's and was originally distributed as open source as a part of the OpenEXR project. Imath continues to be maintained as a sub-project of OpenEXR, which is now a project of the Academy Software Foundation. See the OpenEXR project's GOVERNANCE.md for more information about how the project operates. WWW: https://github.com/AcademySoftwareFoundation/Imath/
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/ilmbase/Makefile53
-rw-r--r--graphics/ilmbase/distinfo3
-rw-r--r--graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake13
-rw-r--r--graphics/ilmbase/pkg-descr18
-rw-r--r--graphics/ilmbase/pkg-plist82
-rw-r--r--math/Imath/Makefile53
-rw-r--r--math/Imath/distinfo3
-rw-r--r--math/Imath/pkg-descr16
-rw-r--r--math/Imath/pkg-plist90
-rw-r--r--math/Makefile1
12 files changed, 164 insertions, 170 deletions
diff --git a/MOVED b/MOVED
index 5b3da31c1558..37f905401173 100644
--- a/MOVED
+++ b/MOVED
@@ -16277,3 +16277,4 @@ dns/dnsmasq-devel|dns/dnsmasq|2021-04-08|Has expired: use dns/dnsmasq instead, w
net/coturn|net/turnserver|2021-04-09|Remove duplicate port: coturn is another name for turnserver
databases/percona55-server||2021-04-11|EOL upstream
databases/percona55-client||2021-04-11|EOL upstream
+graphics/ilmbase|math/Imath|2021-04-10|Ilmbase was split out into Imath and OpenEXR.
diff --git a/graphics/Makefile b/graphics/Makefile
index 0d333342d609..8f4a7b7dffbb 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -344,7 +344,6 @@
SUBDIR += iec16022
SUBDIR += iiview
SUBDIR += ikona
- SUBDIR += ilmbase
SUBDIR += imageindex
SUBDIR += imageviewer
SUBDIR += imageworsener
diff --git a/graphics/ilmbase/Makefile b/graphics/ilmbase/Makefile
deleted file mode 100644
index 928b9683abb2..000000000000
--- a/graphics/ilmbase/Makefile
+++ /dev/null
@@ -1,53 +0,0 @@
-# Created by: nork@FreeBSD.org
-
-PORTNAME= ilmbase
-PORTVERSION= 2.5.5
-PORTREVISION= 1
-CATEGORIES= graphics devel
-
-MAINTAINER= mandree@FreeBSD.org
-COMMENT= ILM Base libraries a.k.a. Half, IlmThread, Imath, and Iex
-
-LICENSE= BSD3CLAUSE
-
-USES= cmake compiler:c++14-lang libtool pkgconfig
-
-USE_GITHUB= yes
-GH_TUPLE= AcademySoftwareFoundation:openexr:v${PORTVERSION}
-USE_LDCONFIG= yes
-
-CMAKE_ARGS+= -DCMAKE_INSTALL_PREFIX=${PREFIX}
-
-WRKSRC_SUBDIR= IlmBase
-
-PLIST_SUB= MAJORVER=${_MAJORVER} \
- VER=${_VER} \
- MINVER=${_MINVER} \
- PLVER=${_PLVER}
-PORTDOCS= README.md
-
-OPTIONS_DEFINE= DOCS LARGE_STACK
-OPTIONS_SUB= yes
-
-LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
-LARGE_STACK_CMAKE_BOOL= ILMBASE_ENABLE_LARGE_STACK
-LARGE_STACK_CONFIGURE_ENABLE= large-stack
-
-_MAJORVER= 2_5
-_VER= 25
-_MINVER= 0
-_PLVER= 4
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libHalf-${_MAJORVER}.so
-.for l in libHalf libIex libIexMath libImath libIlmThread
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${_MAJORVER}.so
-.endfor
-
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-
-do-test:
- cd ${BUILD_WRKSRC} && ctest
-
-.include <bsd.port.mk>
diff --git a/graphics/ilmbase/distinfo b/graphics/ilmbase/distinfo
deleted file mode 100644
index db539cb930e4..000000000000
--- a/graphics/ilmbase/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1613162196
-SHA256 (AcademySoftwareFoundation-openexr-2.5.5-v2.5.5_GH0.tar.gz) = 59e98361cb31456a9634378d0f653a2b9554b8900f233450f2396ff495ea76b3
-SIZE (AcademySoftwareFoundation-openexr-2.5.5-v2.5.5_GH0.tar.gz) = 27536865
diff --git a/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake b/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake
deleted file mode 100644
index 1ec7bf625aee..000000000000
--- a/graphics/ilmbase/files/patch-config_IlmBaseSetup.cmake
+++ /dev/null
@@ -1,13 +0,0 @@
---- config/IlmBaseSetup.cmake.orig 2019-09-18 01:02:06 UTC
-+++ config/IlmBaseSetup.cmake
-@@ -48,10 +48,6 @@ set(ILMBASE_OUTPUT_SUBDIR OpenEXR CACHE STRING "Destin
- # but is pretty harmless to set globally
- set(CMAKE_INCLUDE_CURRENT_DIR ON)
-
--# Suffix for debug configuration libraries
--# (if you should choose to install those)
--set(CMAKE_DEBUG_POSTFIX "_d" CACHE STRING "Suffix for debug builds")
--
- # Usual cmake option to build shared libraries or not
- option(BUILD_SHARED_LIBS "Build shared library" ON)
- # This allows a "double library" setup, where we compile both
diff --git a/graphics/ilmbase/pkg-descr b/graphics/ilmbase/pkg-descr
deleted file mode 100644
index 29f70a223c7c..000000000000
--- a/graphics/ilmbase/pkg-descr
+++ /dev/null
@@ -1,18 +0,0 @@
-ABOUT THE ILMBASE LIBRARIES
-----------------------------
-
-Half is a class that encapsulates our 16-bit floating-point format.
-
-IlmThread is a thread abstraction library for use with OpenEXR
-and other software packages. It currently supports pthreads and
-Windows threads.
-
-Imath implements 2D and 3D vectors, 3x3 and 4x4 matrices, quaternions
-and other useful 2D and 3D math functions.
-
-Iex is an exception-handling library.
-
-If you have questions about using the IlmBase libraries, you may want
-to join our developer mailing list.
-
-WWW: https://www.openexr.com/
diff --git a/graphics/ilmbase/pkg-plist b/graphics/ilmbase/pkg-plist
deleted file mode 100644
index d47191596918..000000000000
--- a/graphics/ilmbase/pkg-plist
+++ /dev/null
@@ -1,82 +0,0 @@
-include/OpenEXR/Iex.h
-include/OpenEXR/IexBaseExc.h
-include/OpenEXR/IexErrnoExc.h
-include/OpenEXR/IexExport.h
-include/OpenEXR/IexForward.h
-include/OpenEXR/IexMacros.h
-include/OpenEXR/IexMathExc.h
-include/OpenEXR/IexMathFloatExc.h
-include/OpenEXR/IexMathFpu.h
-include/OpenEXR/IexMathIeeeExc.h
-include/OpenEXR/IexNamespace.h
-include/OpenEXR/IexThrowErrnoExc.h
-include/OpenEXR/IlmBaseConfig.h
-include/OpenEXR/IlmThread.h
-include/OpenEXR/IlmThreadExport.h
-include/OpenEXR/IlmThreadForward.h
-include/OpenEXR/IlmThreadMutex.h
-include/OpenEXR/IlmThreadNamespace.h
-include/OpenEXR/IlmThreadPool.h
-include/OpenEXR/IlmThreadSemaphore.h
-include/OpenEXR/ImathBox.h
-include/OpenEXR/ImathBoxAlgo.h
-include/OpenEXR/ImathColor.h
-include/OpenEXR/ImathColorAlgo.h
-include/OpenEXR/ImathEuler.h
-include/OpenEXR/ImathExc.h
-include/OpenEXR/ImathExport.h
-include/OpenEXR/ImathForward.h
-include/OpenEXR/ImathFrame.h
-include/OpenEXR/ImathFrustum.h
-include/OpenEXR/ImathFrustumTest.h
-include/OpenEXR/ImathFun.h
-include/OpenEXR/ImathGL.h
-include/OpenEXR/ImathGLU.h
-include/OpenEXR/ImathHalfLimits.h
-include/OpenEXR/ImathInt64.h
-include/OpenEXR/ImathInterval.h
-include/OpenEXR/ImathLimits.h
-include/OpenEXR/ImathLine.h
-include/OpenEXR/ImathLineAlgo.h
-include/OpenEXR/ImathMath.h
-include/OpenEXR/ImathMatrix.h
-include/OpenEXR/ImathMatrixAlgo.h
-include/OpenEXR/ImathNamespace.h
-include/OpenEXR/ImathPlane.h
-include/OpenEXR/ImathPlatform.h
-include/OpenEXR/ImathQuat.h
-include/OpenEXR/ImathRandom.h
-include/OpenEXR/ImathRoots.h
-include/OpenEXR/ImathShear.h
-include/OpenEXR/ImathSphere.h
-include/OpenEXR/ImathVec.h
-include/OpenEXR/ImathVecAlgo.h
-include/OpenEXR/half.h
-include/OpenEXR/halfExport.h
-include/OpenEXR/halfFunction.h
-include/OpenEXR/halfLimits.h
-lib/cmake/IlmBase/IlmBaseConfig.cmake
-lib/cmake/IlmBase/IlmBaseConfigVersion.cmake
-lib/cmake/IlmBase/IlmBaseTargets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/IlmBase/IlmBaseTargets.cmake
-lib/libHalf-%%MAJORVER%%.so
-lib/libHalf-%%MAJORVER%%.so.%%VER%%
-lib/libHalf-%%MAJORVER%%.so.%%VER%%.%%MINVER%%.%%PLVER%%
-lib/libHalf.so
-lib/libIex-%%MAJORVER%%.so
-lib/libIex-%%MAJORVER%%.so.%%VER%%
-lib/libIex-%%MAJORVER%%.so.%%VER%%.%%MINVER%%.%%PLVER%%
-lib/libIex.so
-lib/libIexMath-%%MAJORVER%%.so
-lib/libIexMath-%%MAJORVER%%.so.%%VER%%
-lib/libIexMath-%%MAJORVER%%.so.%%VER%%.%%MINVER%%.%%PLVER%%
-lib/libIexMath.so
-lib/libIlmThread-%%MAJORVER%%.so
-lib/libIlmThread-%%MAJORVER%%.so.%%VER%%
-lib/libIlmThread-%%MAJORVER%%.so.%%VER%%.%%MINVER%%.%%PLVER%%
-lib/libIlmThread.so
-lib/libImath-%%MAJORVER%%.so
-lib/libImath-%%MAJORVER%%.so.%%VER%%
-lib/libImath-%%MAJORVER%%.so.%%VER%%.%%MINVER%%.%%PLVER%%
-lib/libImath.so
-libdata/pkgconfig/IlmBase.pc
diff --git a/math/Imath/Makefile b/math/Imath/Makefile
new file mode 100644
index 000000000000..78b3b78adb52
--- /dev/null
+++ b/math/Imath/Makefile
@@ -0,0 +1,53 @@
+# Based on the graphics/ilmbase port that was done by: nork@FreeBSD.org
+
+PORTNAME= Imath
+PORTVERSION= 3.0.1
+CATEGORIES= math devel graphics
+
+MAINTAINER= mandree@FreeBSD.org
+COMMENT= C++/Python lib of 2D/3D vector, matrix, math ops for computer graphics
+
+LICENSE= BSD3CLAUSE
+
+USES= cmake compiler:c++14-lang pkgconfig
+
+USE_GITHUB= yes
+GH_TUPLE= AcademySoftwareFoundation:Imath:v${PORTVERSION}
+USE_LDCONFIG= yes
+
+CMAKE_ARGS+= -DCMAKE_DEBUG_POSTFIX= \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
+PLIST_SUB= MAJORVER=${_MAJORVER} \
+ MINVER=${_MINVER} \
+ PLVER=${_PLVER} \
+ VER=${_VER}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS LARGE_STACK PYTHON
+OPTIONS_SUB= yes
+
+LARGE_STACK_DESC= Enable sys-dependent large stack optimizations
+LARGE_STACK_CMAKE_BOOL= IMATH_ENABLE_LARGE_STACK
+
+PYTHON_LIB_DEPENDS= ${PY_BOOST}
+PYTHON_USES= python
+PYTHON_CMAKE_BOOL= PYTHON
+
+_MAJORVER= 3_0
+_VER= 27
+_MINVER= 0
+_PLVER= 0
+
+post-install:
+.for l in libImath
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${l}-${_MAJORVER}.so
+.endfor
+
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+
+do-test:
+ cd ${BUILD_WRKSRC} && ctest
+
+.include <bsd.port.mk>
diff --git a/math/Imath/distinfo b/math/Imath/distinfo
new file mode 100644
index 000000000000..bf17cc48430c
--- /dev/null
+++ b/math/Imath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618044321
+SHA256 (AcademySoftwareFoundation-Imath-3.0.1-v3.0.1_GH0.tar.gz) = 9cd984bb6b0a9572dd4a373b1fab60bc4c992a52ec5c68328fe0f48f194ba3c0
+SIZE (AcademySoftwareFoundation-Imath-3.0.1-v3.0.1_GH0.tar.gz) = 527715
diff --git a/math/Imath/pkg-descr b/math/Imath/pkg-descr
new file mode 100644
index 000000000000..1bb0435286f1
--- /dev/null
+++ b/math/Imath/pkg-descr
@@ -0,0 +1,16 @@
+Imath is a basic, light-weight, and efficient C++ representation of 2D and 3D
+vectors and matrices and other simple but useful mathematical objects,
+functions, and data types common in computer graphics applications, including
+the "half" 16-bit floating-point type.
+
+Imath also includes optional python bindings for all types and functions,
+including optimized implementations of vector and matrix arrays.
+
+Imath was originally developed at Industrial Light & Magic in the early 2000's
+and was originally distributed as open source as a part of the OpenEXR project.
+
+Imath continues to be maintained as a sub-project of OpenEXR, which is now a
+project of the Academy Software Foundation. See the OpenEXR project's
+GOVERNANCE.md for more information about how the project operates.
+
+WWW: https://github.com/AcademySoftwareFoundation/Imath/
diff --git a/math/Imath/pkg-plist b/math/Imath/pkg-plist
new file mode 100644
index 000000000000..d91437901ce9
--- /dev/null
+++ b/math/Imath/pkg-plist
@@ -0,0 +1,90 @@
+include/Imath/ImathBox.h
+include/Imath/ImathBoxAlgo.h
+include/Imath/ImathColor.h
+include/Imath/ImathColorAlgo.h
+include/Imath/ImathConfig.h
+include/Imath/ImathEuler.h
+include/Imath/ImathExport.h
+include/Imath/ImathForward.h
+include/Imath/ImathFrame.h
+include/Imath/ImathFrustum.h
+include/Imath/ImathFrustumTest.h
+include/Imath/ImathFun.h
+include/Imath/ImathGL.h
+include/Imath/ImathGLU.h
+include/Imath/ImathInt64.h
+include/Imath/ImathInterval.h
+include/Imath/ImathLine.h
+include/Imath/ImathLineAlgo.h
+include/Imath/ImathMath.h
+include/Imath/ImathMatrix.h
+include/Imath/ImathMatrixAlgo.h
+include/Imath/ImathNamespace.h
+include/Imath/ImathPlane.h
+include/Imath/ImathPlatform.h
+include/Imath/ImathQuat.h
+include/Imath/ImathRandom.h
+include/Imath/ImathRoots.h
+include/Imath/ImathShear.h
+include/Imath/ImathSphere.h
+include/Imath/ImathTypeTraits.h
+include/Imath/ImathVec.h
+include/Imath/ImathVecAlgo.h
+include/Imath/half.h
+include/Imath/halfFunction.h
+include/Imath/halfLimits.h
+lib/cmake/Imath/ImathConfig.cmake
+lib/cmake/Imath/ImathConfigVersion.cmake
+lib/cmake/Imath/ImathTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/Imath/ImathTargets.cmake
+lib/libImath-%%MAJORVER%%.so
+lib/libImath-%%MAJORVER%%.so.27
+lib/libImath-%%MAJORVER%%.so.27.0.0
+lib/libImath.so
+libdata/pkgconfig/Imath.pc
+%%PYTHON%%include/Imath/PyImath.h
+%%PYTHON%%include/Imath/PyImathAutovectorize.h
+%%PYTHON%%include/Imath/PyImathBasicTypes.h
+%%PYTHON%%include/Imath/PyImathBox.h
+%%PYTHON%%include/Imath/PyImathBoxArrayImpl.h
+%%PYTHON%%include/Imath/PyImathColor.h
+%%PYTHON%%include/Imath/PyImathColor3ArrayImpl.h
+%%PYTHON%%include/Imath/PyImathColor4Array2DImpl.h
+%%PYTHON%%include/Imath/PyImathColor4ArrayImpl.h
+%%PYTHON%%include/Imath/PyImathDecorators.h
+%%PYTHON%%include/Imath/PyImathEuler.h
+%%PYTHON%%include/Imath/PyImathExport.h
+%%PYTHON%%include/Imath/PyImathFixedArray.h
+%%PYTHON%%include/Imath/PyImathFixedArray2D.h
+%%PYTHON%%include/Imath/PyImathFixedMatrix.h
+%%PYTHON%%include/Imath/PyImathFixedVArray.h
+%%PYTHON%%include/Imath/PyImathFrustum.h
+%%PYTHON%%include/Imath/PyImathFun.h
+%%PYTHON%%include/Imath/PyImathLine.h
+%%PYTHON%%include/Imath/PyImathM44Array.h
+%%PYTHON%%include/Imath/PyImathMathExc.h
+%%PYTHON%%include/Imath/PyImathMatrix.h
+%%PYTHON%%include/Imath/PyImathOperators.h
+%%PYTHON%%include/Imath/PyImathPlane.h
+%%PYTHON%%include/Imath/PyImathQuat.h
+%%PYTHON%%include/Imath/PyImathRandom.h
+%%PYTHON%%include/Imath/PyImathShear.h
+%%PYTHON%%include/Imath/PyImathStringArray.h
+%%PYTHON%%include/Imath/PyImathStringArrayRegister.h
+%%PYTHON%%include/Imath/PyImathStringTable.h
+%%PYTHON%%include/Imath/PyImathTask.h
+%%PYTHON%%include/Imath/PyImathUtil.h
+%%PYTHON%%include/Imath/PyImathVec.h
+%%PYTHON%%include/Imath/PyImathVec2Impl.h
+%%PYTHON%%include/Imath/PyImathVec3ArrayImpl.h
+%%PYTHON%%include/Imath/PyImathVec3Impl.h
+%%PYTHON%%include/Imath/PyImathVec4ArrayImpl.h
+%%PYTHON%%include/Imath/PyImathVec4Impl.h
+%%PYTHON%%include/Imath/PyImathVecOperators.h
+%%PYTHON%%lib/cmake/Imath/ImathConfig-%%CMAKE_BUILD_TYPE%%.cmake
+%%PYTHON%%lib/libPyImath_Python3_7-%%MAJORVER%%.so
+%%PYTHON%%lib/libPyImath_Python3_7-%%MAJORVER%%.so.27
+%%PYTHON%%lib/libPyImath_Python3_7-%%MAJORVER%%.so.27.0.0
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/imath.so
+%%PYTHON%%%%PYTHON_SITELIBDIR%%/imathnumpy.so
+%%PYTHON%%libdata/pkgconfig/PyImath.pc
diff --git a/math/Makefile b/math/Makefile
index 24c7e1efbd37..096d586d5779 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -2,6 +2,7 @@
SUBDIR += 4ti2
SUBDIR += GiNaC
+ SUBDIR += Imath
SUBDIR += PDL
SUBDIR += R
SUBDIR += R-cran-ADGofTest